]> git.pld-linux.org Git - packages/geninitrd.git/blame - geninitrd.spec
- currently initramfs used by default, romfs is optional
[packages/geninitrd.git] / geninitrd.spec
CommitLineData
5bba2f6c 1# TODO:
8d4b3be5
PG
2# - BUG: you can't set in /etc/mdadm.conf:
3# DEVICE partitions containers
4# (which is default BTW if none set). Generation of initrd will fail
5#
70a0ef68 6Summary: Creates an initial ramdisk image for preloading modules
4bd9777f 7Summary(pl.UTF-8): Narzędzie do tworzenia inicjalnego ramdysku używanego przy starcie systemu
70a0ef68 8Name: geninitrd
916449d2 9Version: 12462
b7842622 10Release: 2
70a0ef68 11License: GPL
6e7d5844 12Group: Applications/System
3adc6ee3 13Source0: %{name}-%{version}.tar.gz
916449d2 14# Source0-md5: 7bab5ccd79af683dd3162f660e552332
929a4239 15Patch0: %{name}-romfs.patch
b05ab846 16Patch1: %{name}-gzip-compressor.patch
229da7eb 17#Patch2: %{name}-svn.patch
aa605112 18URL: http://svn.pld-linux.org/trac/svn/wiki/packages/geninitrd
0dd71c4b 19BuildRequires: xmlto >= 0:0.0.18-1
fe2d4469 20Requires: /usr/bin/ldd
0e068c76 21Requires: awk
7c70c4dc 22Requires: busybox-initrd >= 1.1.0
417ef52a 23Requires: coreutils
7b29e9b5 24Requires: cpio
0e068c76 25Requires: fileutils
87c020ab 26Requires: glibc-misc
0e068c76 27Requires: gzip
16ac31fd 28Requires: mktemp >= 1.5-8
0e068c76 29Requires: mount
495990cb 30Requires: pci-database >= 0.4
e018b691 31Requires: rc-scripts >= 0.2.7
0e068c76 32Requires: tar
b7842622 33Requires: virtual(module-tools)
6f0074bc 34%if "%{pld_release}" == "ti"
35Requires: lvm2-initrd
36Requires: mdadm-initrd >= 1.12.0-1
37%else
55c24912 38# otherwise LVM subsystem is not enabled in geninitrd
f3d68afb 39Suggests: lvm2-initrd
e018b691 40# without this softraid installations of PLD fail
ac7d5e9a 41Suggests: mdadm-initrd >= 1.12.0-1
6f0074bc 42%endif
229da7eb 43Suggests: genromfs
2a458b9c 44Suggests: pciutils
55c24912
ER
45# suggest for blkid
46%if "%{pld_release}" != "ac"
244b296a 47Suggests: util-linux-initrd
55c24912 48%endif
70a0ef68 49Obsoletes: mkinitrd
fe2d4469
ER
50%if "%{pld_release}" == "ac"
51Conflicts: grubby < 5.0.4-3.1
52%else
429e8b1c 53Conflicts: grubby < 6.0.24-3
fe2d4469 54%endif
b7842622 55Conflicts: module-init-tools < 3.2.2-6
a843f5f7 56Conflicts: udev-initrd < 1:168
ba3bd13f 57Conflicts: xz < 4.999.9
cf111fa1 58BuildArch: noarch
70a0ef68
JK
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
570eccb2
ER
62Geninitrd creates filesystem images for use as initial ramdisk
63(initrd) images. These ramdisk images are often used to preload the
64block device modules (SCSI or RAID) needed to access the root
65filesystem.
70a0ef68
JK
66
67In other words, generic kernels can be built without drivers for any
68SCSI adapters which load the SCSI driver as a module. Since the kernel
69needs to read those modules, but in this case it isn't able to address
70the SCSI adapter, an initial ramdisk is used. The initial ramdisk is
71loaded by the operating system loader (normally LILO) and is available
72to the kernel as soon as the ramdisk is loaded. The ramdisk image
73loads the proper SCSI adapter and allows the kernel to mount the root
74filesystem. The geninitrd program creates such a ramdisk using
75information found in the /etc/modules.conf file.
76
54baa167
JR
77%description -l pl.UTF-8
78Geninitrd służy do tworzenia obrazu systemu plikowego używanego jako
79inicjalny ramdysk (initrd), z którego przy starcie systemu są ładowane
80moduły kernela z obsługą urządzeń których obsługa nie jest
81wkompilowana w kernel. Zazwyczaj modułami ładowanymi z inicjalnego
82systemu plikowego są sterowniki SCSI, IDE czy też RAID po to żeby w
83dalszej części inicjacji systemu był możliwy dostęp do głównego
70a0ef68
JK
84systemu plikowego (root fs).
85
54baa167
JR
86Dzięki initrd jest możliwe używanie dystrybucyjnego kernela w którym
87wkompilowana jest minimalna ilość obsługi różnych urządzeń, a reszta
88kodu obsługi sterowników SCSI, IDE czy RAID jest doczytywana w trakcie
70a0ef68 89startu z initrd. Skrypt geninitrd generuje obraz ramdysku na podstawie
54baa167 90bieżących informacji zawartych w /etc/modules.conf.
70a0ef68
JK
91
92%prep
93%setup -q
929a4239 94%if "%{pld_release}" == "ti"
95%patch0 -p1
b05ab846 96%patch1 -p1
929a4239 97%endif
2bc9ddcf 98#%patch2 -p0
f2aef47d 99
0dd71c4b 100%build
e0c74de2 101%{__make}
0dd71c4b 102
70a0ef68
JK
103%install
104rm -rf $RPM_BUILD_ROOT
37688ad3 105%{__make} install \
e0c74de2 106 DESTDIR=$RPM_BUILD_ROOT
70a0ef68
JK
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(644,root,root,755)
61d0a20b 113%doc ChangeLog
417ef52a 114%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/geninitrd
70a0ef68 115%attr(755,root,root) /sbin/geninitrd
429e8b1c 116%{_mandir}/man8/geninitrd.8*
417ef52a 117
429e8b1c
ER
118%dir /lib/geninitrd
119/lib/geninitrd/functions
120/lib/geninitrd/mod-*.sh
824e8293 121%attr(755,root,root) /lib/geninitrd/extract-ikconfig
2bc9ddcf
ER
122
123%dir /lib/geninitrd/udev-rules
124/lib/geninitrd/udev-rules/*.rules
This page took 0.106071 seconds and 4 git commands to generate.