]> git.pld-linux.org Git - packages/gegl.git/blobdiff - gegl.spec
- disable lua on x32 (due to no luajit)
[packages/gegl.git] / gegl.spec
index 4fc40b3dd529b16c932b8b2c60cfc718b6a3ff1c..e56cac5fe83118e9c952951065815ac74f68e264 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
@@ -3,6 +3,7 @@
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    sse             # use SSE instructions
 %bcond_without doc             # apidocs
+%bcond_without lua             # without lua support
 %bcond_without static_libs     # static library
 %bcond_without introspection   # API introspection
 %bcond_without vala            # Vala API
 %undefine      with_vala
 %endif
 
+%ifarch x32
+%undefine      with_lua
+%endif
+
 %define        babl_version    0.1.62
 %define        mrg_version     0.1.2-1.20190322.1
 
@@ -33,6 +38,7 @@ Patch1:               %{name}-ruby1.9.patch
 Patch2:                %{name}-build.patch
 Patch3:                umfpack.patch
 Patch4:                %{name}-Wformat-security.patch
+Patch5:                %{name}-without-lua.patch
 URL:           http://www.gegl.org/
 BuildRequires: OpenEXR-devel >= 1.6.1
 BuildRequires: SDL-devel >= 1.2.0
@@ -67,8 +73,10 @@ BuildRequires:       libtiff-devel >= 4.0.0
 BuildRequires: libtool >= 2:2.2
 BuildRequires: libv4l-devel >= 1.0.1
 BuildRequires: libwebp-devel >= 0.5.0
+%if %{with lua}
 BuildRequires: luajit-devel >= 2.0.4
 BuildRequires: lua51-devel >= 5.1.5-2
+%endif
 BuildRequires: mrg-devel >= %{mrg_version}
 BuildRequires: pango-devel >= 1:1.38.0
 BuildRequires: perl-base
@@ -172,6 +180,7 @@ API języka Vala dla biblioteki gegl.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
@@ -187,7 +196,8 @@ API języka Vala dla biblioteki gegl.
        %{!?with_sse:--disable-sse} \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
-       --with-vala%{!?with_vala:=no}
+       --with-vala%{!?with_vala:=no} \
+       %{__with_without lua}
 %{__make}
 
 %install
This page took 0.131947 seconds and 4 git commands to generate.