]> git.pld-linux.org Git - packages/gegl.git/blobdiff - gegl.spec
- removed outdated without-lua patch (broke x32 build now); release 2
[packages/gegl.git] / gegl.spec
index 2ff32ff6aefbc61ca5b811d6b6ccf90e3e27f56e..0d8bb1d711c30147669e3e7f339c98348b78fdc5 100644 (file)
--- a/gegl.spec
+++ b/gegl.spec
@@ -1,8 +1,12 @@
 #
+# TODO:
+# - links against zstd (some of the BR: misses dep on zstd)
+#
 # Conditional build:
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    sse             # use SSE instructions
 %bcond_without doc             # apidocs
+%bcond_without lua             # without lua support
 %bcond_without static_libs     # static library
 %bcond_without introspection   # API introspection
 %bcond_without vala            # Vala API
 %undefine      with_vala
 %endif
 
+%ifarch x32
+%undefine      with_lua
+%endif
+
 %define        babl_version    0.1.62
 %define        mrg_version     0.1.2-1.20190322.1
 
 Summary:       Generic image processing library
 Summary(pl.UTF-8):     Ogólna biblioteka przetwarzania obrazu
 Name:          gegl
-Version:       0.4.14
-Release:       1
+Version:       0.4.16
+Release:       2
 License:       LGPL v3+
 Group:         Libraries
 Source0:       https://download.gimp.org/pub/gegl/0.4/%{name}-%{version}.tar.bz2
-# Source0-md5: 88004f3a204e2506cd0cc445eba8d63e
+# Source0-md5: cb17ac529a882f25f54c0115c63d4027
 Patch1:                %{name}-ruby1.9.patch
 Patch2:                %{name}-build.patch
 Patch3:                umfpack.patch
-Patch4:                %{name}-Wformat-security.patch
-Patch5:                %{name}-without-lua.patch
 URL:           http://www.gegl.org/
 BuildRequires: OpenEXR-devel >= 1.6.1
 BuildRequires: SDL-devel >= 1.2.0
@@ -45,34 +51,36 @@ BuildRequires:      babl-devel >= %{babl_version}
 BuildRequires: cairo-devel >= 1.12.2
 BuildRequires: enscript
 BuildRequires: exiv2-devel >= 0.25
-# libavformat >= 55.48.100, libavcodec >= 55.69.100, libswscale >= 2.6.100
+# libavformat >= 55.48.100, libavcodec >= 55.69.100, libavutil >= 52.92.100, libswscale >= 2.6.100
 BuildRequires: ffmpeg-devel >= 2.3
 BuildRequires: gdk-pixbuf2-devel >= 2.32.0
-BuildRequires: gettext-tools
+BuildRequires: gettext-tools >= 0.19.8
 BuildRequires: gexiv2-devel
 BuildRequires: glib2-devel >= 1:2.44.0
 %{?with_introspection:BuildRequires:   gobject-introspection-devel >= 1.32.0}
 BuildRequires: graphviz
 BuildRequires: gtk-doc >= 1.0
-BuildRequires: intltool >= 0.40.1
 BuildRequires: jasper-devel >= 1.900.1
 BuildRequires: json-glib-devel
 BuildRequires: lcms2-devel >= 2.8
 BuildRequires: lensfun-devel >= 0.2.5
 BuildRequires: libjpeg-devel
-BuildRequires: libpng-devel
+BuildRequires: libpng-devel >= 2:1.6.0
 BuildRequires: libraw-devel >= 0.15.4
 BuildRequires: librsvg-devel >= 1:2.40.6
 BuildRequires: libspiro-devel
 BuildRequires: libtiff-devel >= 4.0.0
 BuildRequires: libtool >= 2:2.2
-BuildRequires: libv4l-devel >= 1.0.1
+# as of 0.4.16, internal copy of code is used
+#BuildRequires:        libv4l-devel >= 1.0.1
 BuildRequires: libwebp-devel >= 0.5.0
+%if %{with lua}
 BuildRequires: luajit-devel >= 2.0.4
 BuildRequires: lua51-devel >= 5.1.5-2
+%endif
 BuildRequires: mrg-devel >= %{mrg_version}
 BuildRequires: pango-devel >= 1:1.38.0
-BuildRequires: perl-base
+BuildRequires: perl-base >= 5
 BuildRequires: pkgconfig
 BuildRequires: poppler-glib-devel >= 0.71.0
 BuildRequires: python >= 1:2.5.0
@@ -82,16 +90,22 @@ BuildRequires:      python-pygobject3-devel >= 3.2
 BuildRequires: poly2tri-c-devel
 BuildRequires: ruby >= 1.9
 %{?with_vala:BuildRequires:    vala >= 2:0.20.0}
+BuildRequires: zlib-devel >= 1.2.0
 Requires:      babl >= %{babl_version}
+Requires:      cairo >= 1.12.2
 Requires:      gdk-pixbuf2 >= 2.32.0
 Requires:      glib2 >= 1:2.44.0
 Requires:      jasper-libs >= 1.900.1
+Requires:      lcms2 >= 2.8
 Requires:      lensfun >= 0.2.5
 Requires:      libraw >= 0.15.4
 Requires:      librsvg >= 1:2.40.6
 Requires:      libtiff >= 4.0.0
+Requires:      libwebp >= 0.5.0
 Requires:      mrg-libs >= %{mrg_version}
 Requires:      pango >= 1:1.38.0
+Requires:      poppler-glib >= 0.71.0
+Requires:      zlib >= 1.2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -118,6 +132,8 @@ Group:              Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      babl-devel >= %{babl_version}
 Requires:      glib2-devel >= 1:2.44.0
+Requires:      json-glib-devel
+Requires:      poly2tri-c-devel
 
 %description devel
 Header files for gegl library.
@@ -172,8 +188,6 @@ API języka Vala dla biblioteki gegl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 %build
 %{__libtoolize}
@@ -189,7 +203,8 @@ API języka Vala dla biblioteki gegl.
        %{!?with_sse:--disable-sse} \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
-       --with-vala%{!?with_vala:=no}
+       --with-vala%{!?with_vala:=no} \
+       %{__with_without lua}
 %{__make}
 
 %install
This page took 0.080362 seconds and 4 git commands to generate.