]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb.spec
index ae7118757104ce9b111bc656ef23026824533e5e..5ce5af420f0473201ce6bc588acc33d1d6e210b1 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -2,12 +2,11 @@
 
 # TODO
 # - debuginfod (BR: elfutils-debuginfod-devel >= 0.179)
-# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
+# - amd-dbgapi (BR: pkgconfig(amd-dbgapi) >= 0.68.0) <https://github.com/ROCm/ROCdbgapi>
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
-# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
 #
 # Conditional build:
-%bcond_with    guile           # Guile embedded scripting
+%bcond_without guile           # Guile embedded scripting
 %bcond_without python          # build without python support
 
 Summary:       A GNU source-level debugger for C, C++ and Fortran
@@ -22,12 +21,12 @@ Summary(uk.UTF-8):  Символьний відладчик для С та інш
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
-Version:       12.1
+Version:       14.1
 Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       https://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: 759a1b8d2b4d403367dd0e14fa04643d
+# Source0-md5: 4a084d03915b271f67e9b8ea2ab24972
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -36,7 +35,6 @@ Patch101:     gdb-6.6-buildid-locate-solib-missing-ids.patch
 Patch102:      gdb-6.6-buildid-locate-rpm.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
-Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
@@ -51,24 +49,24 @@ BuildRequires:      bison
 BuildRequires: expat-devel
 BuildRequires: flex >= 2.6.4
 BuildRequires: gettext-tools >= 0.12.1
-BuildRequires: gmp-devel
+BuildRequires: gmp-devel >= 4.3.2
 %if %{with guile}
-BuildRequires: guile-devel >= 2.0
-BuildRequires: guile-devel < 3.2
+BuildRequires: guile-devel >= 5:2.0
+BuildRequires: guile-devel < 5:3.2
 %endif
 %ifarch %{ix86} %{x8664}
 BuildRequires: libipt-devel
 %endif
-BuildRequires: libmpc-devel
+BuildRequires: libmpc-devel >= 0.8.1
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool >= 2:2
 BuildRequires: make >= 3.81
-BuildRequires: mpfr-devel
+BuildRequires: mpfr-devel >= 3.1.6
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
-BuildRequires: rpm-devel >= 4.6
+BuildRequires: rpm-devel >= 1:4.6
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: source-highlight-devel >= 3.0
 BuildRequires: tar >= 1:1.22
@@ -89,6 +87,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                autoconf_ver    %(rpm -q --qf='%%{VERSION}' autoconf)
 
+%define                _noautostrip    .*%{_datadir}/gdb/guile/.*\.go
+
 %description
 Gdb is a full featured, command driven debugger. Gdb allows you to
 trace the execution of programs and examine their internal state at
@@ -196,7 +196,6 @@ GDB w postaci biblioteki statycznej.
 %patch102 -p1
 %patch104 -p1
 %patch105 -p1
-%patch106 -p1
 %patch110 -p1
 
 %patch1000 -p1
@@ -323,7 +322,7 @@ cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
 # These are part of binutils:
 %{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
-%{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec}.info*
+%{__rm} $RPM_BUILD_ROOT%{_infodir}/{bfd,ctf-spec,sframe-spec}.info*
 %{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfdlink,ctf,ctf-api,diagnostics,dis-asm,symcat,plugin-api}.h
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,ctf,ctf-nobfd,opcodes}.a
This page took 0.076002 seconds and 4 git commands to generate.