]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- release 5
[packages/gdb.git] / gdb.spec
index 2c19ae5af63d8db99d52c59d8f8a4a58dfb320a1..3d22c3314df4d748c97f669742b11864832d7225 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,17 +1,12 @@
 # NOTE
 # - Do not remove -lib package, it is required by FPC
-# - does not build with -j2 - use -j1
 
 # TODO
-# - python subpkg
-# - remove hacks in python, use sys.lib, use standard python dirs
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
 #
 # Conditional build:
 %bcond_without python          # build without python support
 
-%define                snap    20090930
-%define                rel             0.4
 Summary:       A GNU source-level debugger for C, C++ and Fortran
 Summary(de.UTF-8):     Symbolischer Debugger für C und andere Sprachen
 Summary(es.UTF-8):     Depurador de programas C y otras lenguajes
@@ -25,19 +20,21 @@ Summary(zh_CN.UTF-8):       [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
 Name:          gdb
 Version:       7.0
-Release:       0.7.fc12.%{rel}
+Release:       5
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
 # Source0-md5: 3386a7b69c010785c920ffc1e9cb890a
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
+Source3:       %{name}-gstack.man
 Source4:       libstdc++-v3-python-r151798.tar.bz2
 # Source4-md5: 7507540c50a1edeb2fc22a37bc4a08b8
 
 # FEDORA -- use the same numbering that they do
 # don't ever modify these patches, apply secondary patch to alter it pld way
 # use:'<,'>!grep -vE '^(\#|$)' in vim to filterout comments, spaces
+
 Patch1:                %{name}-6.3-rh-dummykfail-20041202.patch
 Patch2:                %{name}-6.3-rh-testversion-20041202.patch
 Patch3:                %{name}-6.3-rh-testlibunwind-20041202.patch
@@ -49,9 +46,9 @@ Patch112:     %{name}-6.6-scheduler_locking-step-sw-watchpoints2.patch
 Patch260:      %{name}-6.6-scheduler_locking-step-is-default.patch
 Patch118:      %{name}-6.3-gstack-20050411.patch
 Patch122:      %{name}-6.3-test-pie-20050107.patch
-Patch124:      %{name}-6.3-pie-20050110.patch
+Patch124:      %{name}-archer-pie.patch
+Patch389:      %{name}-archer-pie-addons.patch
 Patch125:      %{name}-6.3-test-self-20050110.patch
-Patch128:      %{name}-6.3-nonthreaded-wp-20050117.patch
 Patch133:      %{name}-6.3-test-dtorfix-20050121.patch
 Patch136:      %{name}-6.3-test-movedir-20050125.patch
 Patch140:      %{name}-6.3-gcore-thread-20050204.patch
@@ -148,6 +145,8 @@ Patch384:   %{name}-bz528668-symfile-cleanup.patch
 Patch385:      %{name}-bz528668-symfile-multi.patch
 Patch387:      %{name}-bz539590-gnu-ifunc.patch
 Patch388:      %{name}-bz538626-bp_location-accel-bp-cond.patch
+Patch390:      %{name}-readline-6.0-signal.patch
+Patch391:      %{name}-x86_64-i386-syscall-restart.patch
 
 # PLD patches
 Patch1000:     %{name}-readline.patch
@@ -155,15 +154,16 @@ Patch1001:        %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
 Patch1005:     %{name}-pretty-print-by-default.patch
 Patch1006:     buildid-locate-rpm-pld.patch
-
 URL:           http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
 BuildRequires: bison
+BuildRequires: expat-devel
 BuildRequires: flex
 BuildRequires: libtool
 BuildRequires: ncurses-devel >= 5.2
-BuildRequires: readline-devel >= 6.0
+BuildRequires: pkgconfig
+BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: texinfo >= 4.4
 BuildRequires: zlib-devel
@@ -270,11 +270,13 @@ rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
 rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 
 # FEDORA PATCHES -- keep them in same order they do
+%patch2 -p1
 %patch232 -p1
 %patch349 -p1
 %patch383 -p1
 %patch384 -p1
 %patch385 -p1
+%patch124 -p1
 %patch1 -p1
 %patch3 -p1
 %patch104 -p1
@@ -285,7 +287,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch118 -p1
 %patch122 -p1
 %patch125 -p1
-%patch128 -p1
 %patch133 -p1
 %patch136 -p1
 %patch140 -p1
@@ -378,7 +379,9 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch382 -p1
 %patch387 -p1
 %patch388 -p1
-%patch124 -p1
+%patch389 -p1
+%patch390 -p1
+%patch391 -p1
 
 # PLD patches
 %patch1000 -p1
@@ -389,6 +392,11 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 
 mv $(basename %{SOURCE4} .tar.bz2) libstdcxxpython
 
+# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
+cat > gdb/version.in << EOF
+PLD Linux (%{version}-%{release})
+EOF
+
 %build
 for dir in $(find gdb -name 'configure.in'); do
        dir=$(dirname "$dir")
@@ -466,6 +474,8 @@ cp -a libstdcxxpython/libstdcxx     $RPM_BUILD_ROOT%{py_sitescriptdir}
 %py_postclean
 %endif
 
+cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
+
 # Remove the files that are part of a gdb build but that are owned and provided by other packages.
 # These are part of binutils
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
@@ -495,6 +505,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gdb/syscalls
 %{_mandir}/man1/gdb.1*
 %{_mandir}/man1/gdbtui.1*
+%{_mandir}/man1/gstack.1*
 %lang(es) %{_mandir}/es/man1/*
 %lang(fr) %{_mandir}/fr/man1/*
 %lang(hu) %{_mandir}/hu/man1/*
This page took 0.036194 seconds and 4 git commands to generate.