]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb-readline.patch
- converted to UTF-8
[packages/gdb.git] / gdb-readline.patch
index 47cd0d9834642c29e4d88ff8c104245ccc736d7b..89dd8f732ccac52794c7594c3851b47a3cf7d6c4 100644 (file)
@@ -1,7 +1,7 @@
-diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
---- gdb-5.0.org/Makefile.in    Thu May 18 07:00:23 2000
-+++ gdb-5.0/Makefile.in        Tue Sep  5 18:32:37 2000
-@@ -558,7 +558,6 @@
+diff -ur gdb-5.1.orig/Makefile.in gdb-5.1/Makefile.in
+--- gdb-5.1.orig/Makefile.in   Sun Nov 18 20:37:49 2001
++++ gdb-5.1/Makefile.in        Tue Jan 22 23:52:34 2002
+@@ -530,7 +530,6 @@
        all-perl \
        all-prms \
        all-rcs \
@@ -9,7 +9,7 @@ diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
        all-release \
        all-recode \
        all-sed \
-@@ -631,7 +630,6 @@
+@@ -607,7 +606,6 @@
        check-perl \
        check-prms \
        check-rcs \
@@ -17,7 +17,7 @@ diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
        check-recode \
        check-sed \
        check-send-pr \
-@@ -705,7 +703,6 @@
+@@ -684,7 +682,6 @@
        install-perl \
        install-prms \
        install-rcs \
@@ -25,7 +25,7 @@ diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
        install-recode \
        install-sed \
        install-send-pr \
-@@ -869,7 +866,6 @@
+@@ -886,7 +883,6 @@
        clean-perl \
        clean-prms \
        clean-rcs \
@@ -33,30 +33,31 @@ diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
        clean-release \
        clean-recode \
        clean-sed \
-@@ -1561,7 +1557,7 @@
- all-gcc: all-bison all-byacc all-binutils all-gas all-ld
- all-bootstrap: all-libiberty all-bison all-byacc all-binutils all-gas all-ld
+@@ -1602,7 +1598,7 @@
+ all-gcc: all-bison all-byacc all-binutils all-gas all-ld all-zlib
+ all-bootstrap: all-libiberty all-texinfo all-bison all-byacc all-binutils all-gas all-ld all-zlib
  GDB_TK = all-tk all-tcl all-itcl all-tix all-libgui
 -all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-readline all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
 +all-gdb: all-libiberty all-opcodes all-bfd all-mmalloc all-bison all-byacc all-sim $(gdbnlmrequirements) $(GDB_TK)
  all-gettext:
  all-gnuserv:
- configure-target-gperf: $(ALL_GCC)
-@@ -1606,12 +1602,11 @@
- all-perl:
- all-prms: all-libiberty
+ configure-target-gperf: $(ALL_GCC_C)
+@@ -1662,13 +1658,12 @@
+ configure-target-qthreads: $(ALL_GCC_C)
+ all-target-qthreads: configure-target-qthreads
  all-rcs:
 -all-readline:
  all-recode: all-libiberty
  all-sed: all-libiberty
  all-send-pr: all-prms
  all-shellutils:
--all-sim: all-libiberty all-bfd all-opcodes all-readline
-+all-sim: all-libiberty all-bfd all-opcodes
+ all-sid: all-tcl all-tk
+-all-sim: all-libiberty all-bfd all-opcodes all-readline all-cgen
++all-sim: all-libiberty all-bfd all-opcodes all-cgen
+ all-snavigator: all-tcl all-tk all-itcl all-db all-grep all-libgui
  all-tar: all-libiberty
  all-tcl:
- all-tcl8.1:
-@@ -1853,7 +1848,7 @@
+@@ -1925,7 +1920,7 @@
                SUPPORT_FILES="$(GNATS_SUPPORT_DIRS)"
  
  .PHONY: gdb.tar.bz2
@@ -65,10 +66,10 @@ diff -urN gdb-5.0.org/Makefile.in gdb-5.0/Makefile.in
  gdb.tar.bz2: $(DIST_SUPPORT) $(GDB_SUPPORT_DIRS) gdb
        $(MAKE) -f Makefile.in gdb-taz TOOL=gdb \
                MD5PROG="$(MD5PROG)" \
-diff -urN gdb-5.0.org/gdb/Makefile.in gdb-5.0/gdb/Makefile.in
---- gdb-5.0.org/gdb/Makefile.in        Tue Sep  5 18:30:00 2000
-+++ gdb-5.0/gdb/Makefile.in    Tue Sep  5 19:15:00 2000
-@@ -126,10 +126,10 @@
+diff -ur gdb-5.1.orig/gdb/Makefile.in gdb-5.1/gdb/Makefile.in
+--- gdb-5.1.orig/gdb/Makefile.in       Sun Nov 18 06:08:36 2001
++++ gdb-5.1/gdb/Makefile.in    Tue Jan 22 23:54:56 2002
+@@ -120,10 +120,10 @@
  BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
  
  # Where is the READLINE library?  Typically in ../readline.
@@ -83,9 +84,21 @@ diff -urN gdb-5.0.org/gdb/Makefile.in gdb-5.0/gdb/Makefile.in
  
  WARN_CFLAGS = @WARN_CFLAGS@
  WERROR_CFLAGS = @WERROR_CFLAGS@
-diff -urN gdb-5.0.org/gdb/event-top.c gdb-5.0/gdb/event-top.c
---- gdb-5.0.org/gdb/event-top.c        Tue Sep  5 19:34:20 2000
-+++ gdb-5.0/gdb/event-top.c    Tue Sep  5 19:34:42 2000
+diff -ur gdb-5.1.orig/gdb/defs.h gdb-5.1/gdb/defs.h
+--- gdb-5.1.orig/gdb/defs.h    Thu Aug  2 23:36:51 2001
++++ gdb-5.1/gdb/defs.h Tue Jan 22 23:59:50 2002
+@@ -800,7 +800,7 @@
+ /* From readline (but not in any readline .h files).  */
+-extern char *tilde_expand (char *);
++extern char *tilde_expand (const char *);
+ /* Control types for commands */
+diff -ur gdb-5.1.orig/gdb/event-top.c gdb-5.1/gdb/event-top.c
+--- gdb-5.1.orig/gdb/event-top.c       Sat Jul 14 20:59:07 2001
++++ gdb-5.1/gdb/event-top.c    Tue Jan 22 23:59:50 2002
 @@ -32,6 +32,7 @@
  #include "gdbcmd.h"
  
@@ -94,10 +107,10 @@ diff -urN gdb-5.0.org/gdb/event-top.c gdb-5.0/gdb/event-top.c
  #include <readline/readline.h>
  #include <readline/history.h>
  
-diff -urN gdb-5.0.org/gdb/gdbserver/Makefile.in gdb-5.0/gdb/gdbserver/Makefile.in
---- gdb-5.0.org/gdb/gdbserver/Makefile.in      Tue Sep  5 18:30:00 2000
-+++ gdb-5.0/gdb/gdbserver/Makefile.in  Tue Sep  5 18:30:35 2000
-@@ -87,7 +87,7 @@
+diff -ur gdb-5.1.orig/gdb/gdbserver/Makefile.in gdb-5.1/gdb/gdbserver/Makefile.in
+--- gdb-5.1.orig/gdb/gdbserver/Makefile.in     Tue Mar  6 09:21:43 2001
++++ gdb-5.1/gdb/gdbserver/Makefile.in  Tue Jan 22 23:59:50 2002
+@@ -88,7 +88,7 @@
  
  # Where is the source dir for the READLINE library?  Traditionally in .. or .
  # (For the binary library built from it, we use ${READLINE_DIR}${subdir}.)
@@ -106,21 +119,21 @@ diff -urN gdb-5.0.org/gdb/gdbserver/Makefile.in gdb-5.0/gdb/gdbserver/Makefile.i
  READLINE_DEP = $$(READLINE_DIR)
  
  # All the includes used for CFLAGS and for lint.
-diff -urN gdb-5.0.org/gdb/top.c gdb-5.0/gdb/top.c
---- gdb-5.0.org/gdb/top.c      Wed Apr 12 18:46:03 2000
-+++ gdb-5.0/gdb/top.c  Tue Sep  5 19:45:56 2000
-@@ -36,6 +36,7 @@
- #include "version.h"
+diff -ur gdb-5.1.orig/gdb/top.c gdb-5.1/gdb/top.c
+--- gdb-5.1.orig/gdb/top.c     Sun Oct 21 21:41:19 2001
++++ gdb-5.1/gdb/top.c  Tue Jan 22 23:59:50 2002
+@@ -42,6 +42,7 @@
+ #include "serial.h"
  
  /* readline include files */
 +#define savestring
  #include <readline/readline.h>
  #include <readline/history.h>
  
-diff -urN gdb-5.0.org/gdb/tracepoint.c gdb-5.0/gdb/tracepoint.c
---- gdb-5.0.org/gdb/tracepoint.c       Tue Dec 14 02:05:38 1999
-+++ gdb-5.0/gdb/tracepoint.c   Tue Sep  5 19:38:26 2000
-@@ -36,6 +36,7 @@
+diff -ur gdb-5.1.orig/gdb/tracepoint.c gdb-5.1/gdb/tracepoint.c
+--- gdb-5.1.orig/gdb/tracepoint.c      Thu Aug  2 14:05:57 2001
++++ gdb-5.1/gdb/tracepoint.c   Tue Jan 22 23:59:50 2002
+@@ -40,6 +40,7 @@
  #include "ax-gdb.h"
  
  /* readline include files */
@@ -128,41 +141,84 @@ diff -urN gdb-5.0.org/gdb/tracepoint.c gdb-5.0/gdb/tracepoint.c
  #include <readline/readline.h>
  #include <readline/history.h>
  
-diff -urN gdb-5.0.org/gdb/tui/Makefile.in gdb-5.0/gdb/tui/Makefile.in
---- gdb-5.0.org/gdb/tui/Makefile.in    Tue Sep  5 18:30:00 2000
-+++ gdb-5.0/gdb/tui/Makefile.in        Tue Sep  5 18:28:16 2000
-@@ -49,9 +49,9 @@
- BFD_CFLAGS = -I$(BFD_DIR) -I$(BFD_SRC)
- # Where is the READLINE library?  Typically in ../readline.
--READLINE_DIR = ../../readline
--READLINE_SRC = $(srcdir)/$(READLINE_DIR)
--READLINE_CFLAGS = -I$(READLINE_SRC)
-+READLINE_DIR = /usr/lib
-+READLINE_SRC = /usr/lib
-+READLINE_CFLAGS = -I/usr/include/readline
+diff -ur gdb-5.1.orig/gdb/utils.c gdb-5.1/gdb/utils.c
+--- gdb-5.1.orig/gdb/utils.c   Fri Nov  2 23:06:29 2001
++++ gdb-5.1/gdb/utils.c        Tue Jan 22 23:59:50 2002
+@@ -54,6 +54,7 @@
  
- # Where is the INTL library?  Typically in ../intl.
- INTL_DIR = ../../intl
-diff -urN gdb-5.0.org/gdb/utils.c gdb-5.0/gdb/utils.c
---- gdb-5.0.org/gdb/utils.c    Tue Sep  5 18:54:25 2000
-+++ gdb-5.0/gdb/utils.c        Tue Sep  5 19:49:03 2000
-@@ -50,6 +50,7 @@
- #include "language.h"
- #include "annotate.h"
+ #include "inferior.h" /* for signed_pointer_to_address */
  
 +#define savestring
  #include <readline/readline.h>
  
- #undef XMALLOC
---- gdb-5.0/gdb/defs.h.wiget   Fri Apr 13 14:59:59 2001
-+++ gdb-5.0/gdb/defs.h Fri Apr 13 15:00:09 2001
-@@ -603,7 +603,7 @@
- /* From readline (but not in any readline .h files).  */
--extern char *tilde_expand (char *);
-+extern char *tilde_expand (const char *);
- /* Control types for commands */
+ #ifndef MALLOC_INCOMPATIBLE
+--- gdb-5.1.1/gdb/tui/tuiWin.c.orig    Sat Jul 28 21:30:54 2001
++++ gdb-5.1.1/gdb/tui/tuiWin.c Sat Feb  2 15:19:33 2002
+@@ -619,10 +619,10 @@
+ tuiResizeAll (void)
+ {
+   int heightDiff, widthDiff;
+-  extern int screenheight, screenwidth;               /* in readline */
++  extern int _rl_screenheight, _rl_screenwidth;               /* in readline */
+-  widthDiff = screenwidth - termWidth ();
+-  heightDiff = screenheight - termHeight ();
++  widthDiff = _rl_screenwidth - termWidth ();
++  heightDiff = _rl_screenheight - termHeight ();
+   if (heightDiff || widthDiff)
+     {
+       TuiLayoutType curLayout = currentLayout ();
+@@ -636,8 +636,8 @@
+       if (winWithFocus != cmdWin)
+       keypad (cmdWin->generic.handle, FALSE);
+       init_page_info ();
+-      setTermHeightTo (screenheight);
+-      setTermWidthTo (screenwidth);
++      setTermHeightTo (_rl_screenheight);
++      setTermWidthTo (_rl_screenwidth);
+       if (curLayout == SRC_DISASSEM_COMMAND ||
+       curLayout == SRC_DATA_COMMAND || curLayout == DISASSEM_DATA_COMMAND)
+       numWinsDisplayed++;
+@@ -664,8 +664,8 @@
+         if (heightDiff == 0)
+           newHeight = firstWin->generic.height;
+         else if ((firstWin->generic.height + splitDiff) >=
+-                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
+-          newHeight = screenheight - MIN_CMD_WIN_HEIGHT - 1;
++                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
++          newHeight = _rl_screenheight - MIN_CMD_WIN_HEIGHT - 1;
+         else if ((firstWin->generic.height + splitDiff) <= 0)
+           newHeight = MIN_WIN_HEIGHT;
+         else
+@@ -674,7 +674,7 @@
+         _makeInvisibleAndSetNewHeight (firstWin, newHeight);
+         cmdWin->generic.origin.y = locator->origin.y + 1;
+         cmdWin->generic.width += widthDiff;
+-        newHeight = screenheight - cmdWin->generic.origin.y;
++        newHeight = _rl_screenheight - cmdWin->generic.origin.y;
+         _makeInvisibleAndSetNewHeight (cmdWin, newHeight);
+         _makeVisibleWithNewHeight (firstWin);
+         _makeVisibleWithNewHeight (cmdWin);
+@@ -702,8 +702,8 @@
+           newHeight = firstWin->generic.height;
+         else if ((firstWin->generic.height +
+                   secondWin->generic.height + (splitDiff * 2)) >=
+-                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
+-          newHeight = (screenheight - MIN_CMD_WIN_HEIGHT - 1) / 2;
++                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
++          newHeight = (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1) / 2;
+         else if ((firstWin->generic.height + splitDiff) <= 0)
+           newHeight = MIN_WIN_HEIGHT;
+         else
+@@ -722,9 +722,9 @@
+           newHeight = secondWin->generic.height;
+         else if ((firstWin->generic.height +
+                   secondWin->generic.height + (splitDiff * 2)) >=
+-                 (screenheight - MIN_CMD_WIN_HEIGHT - 1))
++                 (_rl_screenheight - MIN_CMD_WIN_HEIGHT - 1))
+           {
+-            newHeight = screenheight - MIN_CMD_WIN_HEIGHT - 1;
++            newHeight = _rl_screenheight - MIN_CMD_WIN_HEIGHT - 1;
+             if (newHeight % 2)
+               newHeight = (newHeight / 2) + 1;
+             else
This page took 0.11619 seconds and 4 git commands to generate.