]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb-6.6-buildid-locate-rpm.patch
- updated to 14.1 + rebased Fedora buildid patches set
[packages/gdb.git] / gdb-6.6-buildid-locate-rpm.patch
index efaf98999b38189d90cdbf332c935fadea4bb8f0..f38fdd55b2ecf8691e3d330ffe9d0d1e3126c52f 100644 (file)
@@ -1,6 +1,6 @@
 From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
-From: Fedora GDB patches <invalid@email.com>
-Date: Fri, 27 Oct 2017 21:07:50 +0200
+From: Kevin Buettner <kevinb@redhat.com>
+Date: Wed, 22 Feb 2023 22:30:40 -0700
 Subject: gdb-6.6-buildid-locate-rpm.patch
 
 ;;=push+jan
@@ -232,10 +232,44 @@ diff --git a/gdb/aclocal.m4 b/gdb/aclocal.m4
  # AM_AUX_DIR_EXPAND                                         -*- Autoconf -*-
  
  # Copyright (C) 2001-2017 Free Software Foundation, Inc.
+diff --git a/gdb/build-id.c b/gdb/build-id.c
+--- a/gdb/build-id.c
++++ b/gdb/build-id.c
+@@ -780,10 +780,10 @@ missing_rpm_enlist_1 (const char *filename, int verify_vendor)
+   static rpmts (*rpmtsCreate_p) (void);
+   extern rpmts rpmtsFree(rpmts ts);
+   static rpmts (*rpmtsFree_p) (rpmts ts);
+-  extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmTag rpmtag,
++  extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmDbiTagVal rpmtag,
+                                               const void * keyp, size_t keylen);
+   static rpmdbMatchIterator (*rpmtsInitIterator_p) (const rpmts ts,
+-                                                  rpmTag rpmtag,
++                                                  rpmDbiTagVal rpmtag,
+                                                   const void *keyp,
+                                                   size_t keylen);
+ #else /* !DLOPEN_LIBRPM */
+@@ -838,7 +838,7 @@ missing_rpm_enlist_1 (const char *filename, int verify_vendor)
+             && (rpmdbNextIterator_p = (Header (*) (rpmdbMatchIterator mi)) dlsym (h, "rpmdbNextIterator"))
+             && (rpmtsCreate_p = (rpmts (*) (void)) dlsym (h, "rpmtsCreate"))
+             && (rpmtsFree_p = (rpmts (*) (rpmts ts)) dlsym (h, "rpmtsFree"))
+-            && (rpmtsInitIterator_p = (rpmdbMatchIterator (*) (const rpmts ts, rpmTag rpmtag, const void *keyp, size_t keylen)) dlsym (h, "rpmtsInitIterator"))))
++            && (rpmtsInitIterator_p = (rpmdbMatchIterator (*) (const rpmts ts, rpmDbiTagVal rpmtag, const void *keyp, size_t keylen)) dlsym (h, "rpmtsInitIterator"))))
+         {
+           warning (_("Opened library \"%s\" is incompatible (%s), "
+                     "missing debuginfos notifications will not be displayed"),
+@@ -926,7 +926,7 @@ missing_rpm_enlist_1 (const char *filename, int verify_vendor)
+         /* RPMDBI_PACKAGES requires keylen == sizeof (int).  */
+         /* RPMDBI_LABEL is an interface for NVR-based dbiFindByLabel().  */
+-        mi_debuginfo = rpmtsInitIterator_p (ts, (rpmTag) RPMDBI_LABEL, debuginfo, 0);
++        mi_debuginfo = rpmtsInitIterator_p (ts, (rpmDbiTagVal) RPMDBI_LABEL, debuginfo, 0);
+         xfree (debuginfo);
+         if (mi_debuginfo)
+           {
 diff --git a/gdb/config.in b/gdb/config.in
 --- a/gdb/config.in
 +++ b/gdb/config.in
-@@ -39,6 +39,9 @@
+@@ -42,6 +42,9 @@
  /* Handle .ctf type-info sections */
  #undef ENABLE_LIBCTF
  
@@ -245,9 +279,9 @@ diff --git a/gdb/config.in b/gdb/config.in
  /* Define to 1 if translation of program messages to the user's native
     language is requested. */
  #undef ENABLE_NLS
-@@ -259,6 +262,9 @@
- /* Define if you have the mpfr library. */
- #undef HAVE_LIBMPFR
+@@ -265,6 +268,9 @@
+ /* Define to 1 if you have the `m' library (-lm). */
+ #undef HAVE_LIBM
  
 +/* Define if librpm library is being used. */
 +#undef HAVE_LIBRPM
@@ -258,7 +292,7 @@ diff --git a/gdb/config.in b/gdb/config.in
 diff --git a/gdb/configure b/gdb/configure
 --- a/gdb/configure
 +++ b/gdb/configure
-@@ -775,6 +775,11 @@ TARGET_OBS
+@@ -778,6 +778,11 @@ AMD_DBGAPI_CFLAGS
  ENABLE_BFD_64_BIT_FALSE
  ENABLE_BFD_64_BIT_TRUE
  subdirs
@@ -270,25 +304,25 @@ diff --git a/gdb/configure b/gdb/configure
  GDB_DATADIR
  DEBUGDIR
  MAKEINFO_EXTRA_FLAGS
-@@ -880,6 +885,7 @@ with_gdb_datadir
+@@ -911,6 +916,7 @@ with_gdb_datadir
  with_relocated_sources
  with_auto_load_dir
  with_auto_load_safe_path
 +with_rpm
  enable_targets
  enable_64_bit_bfd
enable_gdbmi
-@@ -959,6 +965,8 @@ PKG_CONFIG_PATH
- PKG_CONFIG_LIBDIR
with_amd_dbgapi
+@@ -988,6 +994,8 @@ AMD_DBGAPI_CFLAGS
+ AMD_DBGAPI_LIBS
  DEBUGINFOD_CFLAGS
  DEBUGINFOD_LIBS
 +RPM_CFLAGS
 +RPM_LIBS
  YACC
  YFLAGS
- XMKMF'
-@@ -1635,6 +1643,8 @@ Optional Packages:
-                           do not restrict auto-loaded files locations
+ ZSTD_CFLAGS
+@@ -1679,6 +1687,8 @@ Optional Packages:
+   --with-amd-dbgapi       support for the amd-dbgapi target (yes / no / auto)
    --with-debuginfod       Enable debuginfo lookups with debuginfod
                            (auto/yes/no)
 +  --with-rpm              query rpm database for missing debuginfos (yes/no,
@@ -296,7 +330,7 @@ diff --git a/gdb/configure b/gdb/configure
    --with-libunwind-ia64   use libunwind frame unwinding for ia64 targets
    --with-curses           use the curses library instead of the termcap
                            library
-@@ -1715,6 +1725,8 @@ Some influential environment variables:
+@@ -1759,6 +1769,8 @@ Some influential environment variables:
                C compiler flags for DEBUGINFOD, overriding pkg-config
    DEBUGINFOD_LIBS
                linker flags for DEBUGINFOD, overriding pkg-config
@@ -305,7 +339,7 @@ diff --git a/gdb/configure b/gdb/configure
    YACC        The `Yet Another Compiler Compiler' implementation to use.
                Defaults to the first program found out of: `bison -y', `byacc',
                `yacc'.
-@@ -6634,6 +6646,494 @@ _ACEOF
+@@ -18039,6 +18051,495 @@ _ACEOF
  { $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
  $as_echo "$with_auto_load_safe_path" >&6; }
  
@@ -369,6 +403,7 @@ diff --git a/gdb/configure b/gdb/configure
 +#include <rpm/rpmlib.h>
 +#include <dlfcn.h>
 +#include <errno.h>
++#include <string.h>
 +
 +int
 +main ()
@@ -485,7 +520,7 @@ diff --git a/gdb/configure b/gdb/configure
 +extern Header rpmdbNextIterator(rpmdbMatchIterator mi);
 +extern rpmts rpmtsCreate(void);
 +extern rpmts rpmtsFree(rpmts ts);
-+extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmTag rpmtag,
++extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmDbiTagVal rpmtag,
 +                                          const void * keyp, size_t keylen);
 +
 +int
@@ -747,7 +782,7 @@ diff --git a/gdb/configure b/gdb/configure
 +extern Header rpmdbNextIterator(rpmdbMatchIterator mi);
 +extern rpmts rpmtsCreate(void);
 +extern rpmts rpmtsFree(rpmts ts);
-+extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmTag rpmtag,
++extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmDbiTagVal rpmtag,
 +                                          const void * keyp, size_t keylen);
 +
 +int
@@ -803,7 +838,7 @@ diff --git a/gdb/configure b/gdb/configure
 diff --git a/gdb/configure.ac b/gdb/configure.ac
 --- a/gdb/configure.ac
 +++ b/gdb/configure.ac
-@@ -153,6 +153,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escape_dir,
+@@ -173,6 +173,200 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escape_dir,
              [Directories safe to hold auto-loaded files.])
  AC_MSG_RESULT([$with_auto_load_safe_path])
  
@@ -853,6 +888,7 @@ diff --git a/gdb/configure.ac b/gdb/configure.ac
 +#include <rpm/rpmlib.h>
 +#include <dlfcn.h>
 +#include <errno.h>
++#include <string.h>
 +  ]], [[
 +    void *h;
 +    const char *const *rpmverp;
@@ -947,7 +983,7 @@ diff --git a/gdb/configure.ac b/gdb/configure.ac
 +extern Header rpmdbNextIterator(rpmdbMatchIterator mi);
 +extern rpmts rpmtsCreate(void);
 +extern rpmts rpmtsFree(rpmts ts);
-+extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmTag rpmtag,
++extern rpmdbMatchIterator rpmtsInitIterator(const rpmts ts, rpmDbiTagVal rpmtag,
 +                                          const void * keyp, size_t keylen);
 +    ]]), [
 +      LIBRPM_COMPAT=true
@@ -1006,15 +1042,15 @@ diff --git a/gdb/configure.ac b/gdb/configure.ac
 diff --git a/gdb/event-top.c b/gdb/event-top.c
 --- a/gdb/event-top.c
 +++ b/gdb/event-top.c
-@@ -42,6 +42,7 @@
- #include "gdbsupport/gdb-sigmask.h"
+@@ -43,6 +43,7 @@
  #include "async-event.h"
  #include "bt-utils.h"
+ #include "pager.h"
 +#include "symfile.h"
  
  /* readline include files.  */
  #include "readline/readline.h"
-@@ -374,6 +375,8 @@ display_gdb_prompt (const char *new_prompt)
+@@ -404,6 +405,8 @@ display_gdb_prompt (const char *new_prompt)
    /* Reset the nesting depth used when trace-commands is set.  */
    reset_command_nest_depth ();
  
@@ -1023,7 +1059,7 @@ diff --git a/gdb/event-top.c b/gdb/event-top.c
    /* Do not call the python hook on an explicit prompt change as
       passed to this function, as this forms a secondary/local prompt,
       IE, displayed but not set.  */
-@@ -800,7 +803,10 @@ command_line_handler (gdb::unique_xmalloc_ptr<char> &&rl)
+@@ -788,7 +791,10 @@ command_line_handler (gdb::unique_xmalloc_ptr<char> &&rl)
        command_handler (cmd);
  
        if (ui->prompt_state != PROMPTED)
@@ -1038,7 +1074,7 @@ diff --git a/gdb/event-top.c b/gdb/event-top.c
 diff --git a/gdb/symfile.h b/gdb/symfile.h
 --- a/gdb/symfile.h
 +++ b/gdb/symfile.h
-@@ -342,6 +342,7 @@ extern void generic_load (const char *args, int from_tty);
+@@ -367,6 +367,7 @@ extern void generic_load (const char *args, int from_tty);
  /* build-id support.  */
  extern struct bfd_build_id *build_id_addr_get (CORE_ADDR addr);
  extern void debug_print_missing (const char *binary, const char *debug);
This page took 0.075396 seconds and 4 git commands to generate.