]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb-6.6-buildid-locate-rpm.patch
- up to 8.2
[packages/gdb.git] / gdb-6.6-buildid-locate-rpm.patch
index 7697afaf36331364365928ce38a52817c7c9aac4..d5ec4b08c7d1f1692edd216cae7e69bcc83a9fc0 100644 (file)
@@ -3,25 +3,12 @@ From: Fedora GDB patches <invalid@email.com>
 Date: Fri, 27 Oct 2017 21:07:50 +0200
 Subject: gdb-6.6-buildid-locate-rpm.patch
 
-FileName: gdb-6.6-buildid-locate-rpm.patch
-
 ;;=push+jan
----
- gdb/aclocal.m4   | 215 +++++++++++++++++++++++
- gdb/build-id.c   | 407 +++++++++++++++++++++++++++++++++++++++++++-
- gdb/config.in    |   6 +
- gdb/configure    | 508 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
- gdb/configure.ac | 193 +++++++++++++++++++++
- gdb/corelow.c    |   2 +-
- gdb/event-top.c  |   8 +-
- gdb/symfile.h    |   2 +
- 8 files changed, 1331 insertions(+), 10 deletions(-)
 
 diff --git a/gdb/aclocal.m4 b/gdb/aclocal.m4
-index e0d38ea267..da5ac313e3 100644
 --- a/gdb/aclocal.m4
 +++ b/gdb/aclocal.m4
-@@ -12,6 +12,221 @@
+@@ -11,7 +11,223 @@
  # even the implied warranty of MERCHANTABILITY or FITNESS FOR A
  # PARTICULAR PURPOSE.
  
@@ -239,12 +226,13 @@ index e0d38ea267..da5ac313e3 100644
 +
 +AS_VAR_IF([$1], [""], [$5], [$4])dnl
 +])# PKG_CHECK_VAR
++
+ m4_ifndef([AC_CONFIG_MACRO_DIRS], [m4_defun([_AM_CONFIG_MACRO_DIRS], [])m4_defun([AC_CONFIG_MACRO_DIRS], [_AM_CONFIG_MACRO_DIRS($@)])])
 +
  # AM_AUX_DIR_EXPAND                                         -*- Autoconf -*-
  
- # Copyright (C) 2001, 2003, 2005, 2011 Free Software Foundation, Inc.
+ # Copyright (C) 2001-2017 Free Software Foundation, Inc.
 diff --git a/gdb/build-id.c b/gdb/build-id.c
-index 5740628386..d60cf622dc 100644
 --- a/gdb/build-id.c
 +++ b/gdb/build-id.c
 @@ -35,6 +35,8 @@
@@ -256,7 +244,7 @@ index 5740628386..d60cf622dc 100644
  
  #define BUILD_ID_VERBOSE_NONE 0
  #define BUILD_ID_VERBOSE_FILENAMES 1
-@@ -666,8 +668,366 @@ build_id_to_filename (const struct bfd_build_id *build_id, char **link_return)
+@@ -640,8 +642,366 @@ build_id_to_filename (const struct bfd_build_id *build_id, char **link_return)
    return result;
  }
  
@@ -624,7 +612,7 @@ index 5740628386..d60cf622dc 100644
     avoidance.  */
  
  struct missing_filepair
-@@ -721,11 +1081,17 @@ missing_filepair_change (void)
+@@ -695,11 +1055,17 @@ missing_filepair_change (void)
        /* All their memory came just from missing_filepair_OBSTACK.  */
        missing_filepair_hash = NULL;
      }
@@ -642,7 +630,7 @@ index 5740628386..d60cf622dc 100644
    missing_filepair_change ();
  }
  
-@@ -792,14 +1158,39 @@ debug_print_missing (const char *binary, const char *debug)
+@@ -766,14 +1132,39 @@ debug_print_missing (const char *binary, const char *debug)
  
    *slot = missing_filepair;
  
@@ -690,7 +678,6 @@ index 5740628386..d60cf622dc 100644
  
  /* See build-id.h.  */
 diff --git a/gdb/config.in b/gdb/config.in
-index 1d11a97080..edd7028f76 100644
 --- a/gdb/config.in
 +++ b/gdb/config.in
 @@ -33,6 +33,9 @@
@@ -703,7 +690,7 @@ index 1d11a97080..edd7028f76 100644
  /* Define to 1 if translation of program messages to the user's native
     language is requested. */
  #undef ENABLE_NLS
-@@ -264,6 +267,9 @@
+@@ -270,6 +273,9 @@
  /* Define if Python 2.7 is being used. */
  #undef HAVE_LIBPYTHON2_7
  
@@ -714,10 +701,9 @@ index 1d11a97080..edd7028f76 100644
  #undef HAVE_LIBUNWIND_IA64_H
  
 diff --git a/gdb/configure b/gdb/configure
-index 092893d757..1cecdbc3b5 100755
 --- a/gdb/configure
 +++ b/gdb/configure
-@@ -716,6 +716,11 @@ PKGVERSION
+@@ -749,6 +749,11 @@ CODESIGN_CERT
  HAVE_NATIVE_GCORE_TARGET
  TARGET_OBS
  subdirs
@@ -729,7 +715,7 @@ index 092893d757..1cecdbc3b5 100755
  GDB_DATADIR
  DEBUGDIR
  MAKEINFO_EXTRA_FLAGS
-@@ -820,6 +825,7 @@ with_gdb_datadir
+@@ -853,6 +858,7 @@ with_gdb_datadir
  with_relocated_sources
  with_auto_load_dir
  with_auto_load_safe_path
@@ -737,7 +723,7 @@ index 092893d757..1cecdbc3b5 100755
  enable_targets
  enable_64_bit_bfd
  enable_gdbcli
-@@ -878,6 +884,11 @@ CCC
+@@ -912,6 +918,11 @@ CCC
  CPP
  MAKEINFO
  MAKEINFOFLAGS
@@ -749,7 +735,7 @@ index 092893d757..1cecdbc3b5 100755
  YACC
  YFLAGS
  XMKMF'
-@@ -1548,6 +1559,8 @@ Optional Packages:
+@@ -1583,6 +1594,8 @@ Optional Packages:
                            [--with-auto-load-dir]
    --without-auto-load-safe-path
                            do not restrict auto-loaded files locations
@@ -758,7 +744,7 @@ index 092893d757..1cecdbc3b5 100755
    --with-libunwind-ia64   use libunwind frame unwinding for ia64 targets
    --with-curses           use the curses library instead of the termcap
                            library
-@@ -1605,6 +1618,13 @@ Some influential environment variables:
+@@ -1640,6 +1653,13 @@ Some influential environment variables:
    MAKEINFO    Parent configure detects if it is of sufficient version.
    MAKEINFOFLAGS
                Parameters for MAKEINFO.
@@ -769,10 +755,10 @@ index 092893d757..1cecdbc3b5 100755
 +              path overriding pkg-config's built-in search path
 +  RPM_CFLAGS  C compiler flags for RPM, overriding pkg-config
 +  RPM_LIBS    linker flags for RPM, overriding pkg-config
-   YACC        The `Yet Another C Compiler' implementation to use. Defaults to
-               the first program found out of: `bison -y', `byacc', `yacc'.
-   YFLAGS      The list of arguments that will be passed by default to $YACC.
-@@ -6486,6 +6506,494 @@ _ACEOF
+   YACC        The `Yet Another Compiler Compiler' implementation to use.
+               Defaults to the first program found out of: `bison -y', `byacc',
+               `yacc'.
+@@ -6575,6 +6595,494 @@ _ACEOF
  { $as_echo "$as_me:${as_lineno-$LINENO}: result: $with_auto_load_safe_path" >&5
  $as_echo "$with_auto_load_safe_path" >&6; }
  
@@ -1268,10 +1254,9 @@ index 092893d757..1cecdbc3b5 100755
  
  subdirs="$subdirs testsuite"
 diff --git a/gdb/configure.ac b/gdb/configure.ac
-index d4133ea71e..e232c1adcb 100644
 --- a/gdb/configure.ac
 +++ b/gdb/configure.ac
-@@ -167,6 +167,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escape_dir,
+@@ -166,6 +166,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escape_dir,
              [Directories safe to hold auto-loaded files.])
  AC_MSG_RESULT([$with_auto_load_safe_path])
  
@@ -1472,10 +1457,9 @@ index d4133ea71e..e232c1adcb 100644
  
  # Check whether to support alternative target configurations
 diff --git a/gdb/corelow.c b/gdb/corelow.c
-index c5b642db81..6e027c12e2 100644
 --- a/gdb/corelow.c
 +++ b/gdb/corelow.c
-@@ -309,7 +309,7 @@ build_id_locate_exec (int from_tty)
+@@ -366,7 +366,7 @@ build_id_locate_exec (int from_tty)
          symfile_objfile->flags |= OBJF_BUILD_ID_CORE_LOADED;
      }
    else
@@ -1485,7 +1469,6 @@ index c5b642db81..6e027c12e2 100644
    do_cleanups (back_to);
  
 diff --git a/gdb/event-top.c b/gdb/event-top.c
-index 0c1528e5eb..0d668f35e0 100644
 --- a/gdb/event-top.c
 +++ b/gdb/event-top.c
 @@ -40,6 +40,7 @@
@@ -1518,10 +1501,9 @@ index 0c1528e5eb..0d668f35e0 100644
  }
  
 diff --git a/gdb/symfile.h b/gdb/symfile.h
-index 0d51f46d78..82c76431e1 100644
 --- a/gdb/symfile.h
 +++ b/gdb/symfile.h
-@@ -546,6 +546,8 @@ void map_symbol_filenames (symbol_filename_ftype *fun, void *data,
+@@ -540,6 +540,8 @@ void map_symbol_filenames (symbol_filename_ftype *fun, void *data,
  /* build-id support.  */
  extern struct bfd_build_id *build_id_addr_get (CORE_ADDR addr);
  extern void debug_print_missing (const char *binary, const char *debug);
@@ -1530,6 +1512,3 @@ index 0d51f46d78..82c76431e1 100644
  
  /* From dwarf2read.c */
  
--- 
-2.14.3
-
This page took 0.038408 seconds and 4 git commands to generate.