]> git.pld-linux.org Git - packages/gdb.git/blame_incremental - gdb.spec
rediff patches
[packages/gdb.git] / gdb.spec
... / ...
CommitLineData
1# NOTE: -lib package is used by fpc.spec
2
3# TODO
4# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6# - reenable guile after https://sourceware.org/bugzilla/show_bug.cgi?id=21104 is fixed
7#
8# Conditional build:
9%bcond_with guile # Guile embedded scripting
10%bcond_without python # build without python support
11
12Summary: A GNU source-level debugger for C, C++ and Fortran
13Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
14Summary(es.UTF-8): Depurador de programas C y otras lenguajes
15Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
16Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
17Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
18Summary(ru.UTF-8): Символический отладчик для C и других языков
19Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
20Summary(uk.UTF-8): Символьний відладчик для С та інших мов
21Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
22Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
23Name: gdb
24Version: 9.1
25Release: 2
26License: GPL v3+
27Group: Development/Debuggers
28Source0: http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
29# Source0-md5: f7e9f6236c425097d9e5f18a6ac40655
30Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
31# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
32Source3: %{name}-gstack.man
33Patch100: gdb-6.6-buildid-locate.patch
34Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
35Patch102: gdb-6.6-buildid-locate-rpm.patch
36Patch103: gdb-6.6-buildid-locate-core-as-arg.patch
37Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
38Patch105: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
39Patch106: gdb-6.6-buildid-locate-rpm-scl.patch
40Patch110: gdb-6.3-gstack-20050411.patch
41
42Patch112: gdb-archer-vla-tests.patch
43Patch113: gdb-vla-intel-fortran-strides.patch
44Patch114: gdb-vla-intel-stringbt-fix.patch
45Patch115: gdb-vla-intel-fortran-vla-strings.patch
46Patch116: gdb-vla-intel-tests.patch
47Patch1000: %{name}-readline.patch
48Patch1001: %{name}-info.patch
49Patch1002: %{name}-passflags.patch
50Patch1005: %{name}-pretty-print-by-default.patch
51Patch1006: buildid-locate-rpm-pld.patch
52URL: http://www.gnu.org/software/gdb/
53BuildRequires: autoconf >= 2.69
54BuildRequires: automake
55BuildRequires: bison
56BuildRequires: babeltrace-devel >= 1.1.0
57BuildRequires: expat-devel
58BuildRequires: flex >= 2.6.4
59BuildRequires: gettext-tools >= 0.12.1
60%if %{with guile}
61BuildRequires: guile-devel >= 2.0
62BuildRequires: guile-devel < 2.2
63%endif
64%ifarch %{ix86} %{x8664}
65BuildRequires: libipt-devel
66%endif
67BuildRequires: libselinux-devel
68BuildRequires: libstdc++-devel >= 6:4.8
69BuildRequires: libtool
70BuildRequires: make >= 3.81
71BuildRequires: mpfr-devel
72BuildRequires: ncurses-devel >= 5.2
73BuildRequires: pkgconfig
74BuildRequires: readline-devel
75BuildRequires: rpmbuild(macros) >= 1.219
76BuildRequires: source-highlight-devel >= 3.0
77BuildRequires: tar >= 1:1.22
78BuildRequires: texinfo >= 4.4
79BuildRequires: xxHash-devel
80BuildRequires: xz
81BuildRequires: xz-devel
82BuildRequires: zlib-devel
83%if %{with python}
84BuildRequires: python-devel
85BuildRequires: rpm-pythonprov
86Obsoletes: python-gdb
87# for traceback module
88Requires: python-modules
89%endif
90%{?with_guile:Requires: guile >= 2.0.12}
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93%description
94Gdb is a full featured, command driven debugger. Gdb allows you to
95trace the execution of programs and examine their internal state at
96any time. Gdb works for C and C++ compiled with the GNU C compiler
97gcc.
98
99%description -l de.UTF-8
100dem Sie die Ausführung von Programmen verfolgen und jederzeit den
101inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
102kompiliertes C++.
103
104%description -l es.UTF-8
105Este es un debugger orientado a comandos repleto de características.
106Te permite rastrear la ejecución de programas y examinar su estado
107interno a cualquier momento. Funciona para C y C++ compilado con el
108compilador GNU C.
109
110%description -l fr.UTF-8
111Débugger complet, piloté par commandes. Permet de tracer l'exécution
112des programmes et d'examiner à tout moment leur état interne.
113Fonctionne avec les binaires C et C++ compilés avec le compilateur C
114de GNU, gcc.
115
116%description -l pl.UTF-8
117Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
118śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
119umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
120przy pomocy kompilatora GNU (gcc).
121
122%description -l pt_BR.UTF-8
123Este é um debugger orientado a comandos repleto de características.
124Ele permite à você rastrear a execução de programas e examinar o seu
125estado interno a qualquer momento. Ele funciona para para C e C++
126compilado com o compilador GNU C.
127
128%description -l ru.UTF-8
129Это полноценный отладчик, управляемый командами. Он позволяет
130трассировать исполнение программ и изучать их внутреннее состояние в
131любой момент времени. Работает с программами на C и C++,
132скомпилированными GNU компилятором C (gcc, egcs, pgcc).
133
134%description -l tr.UTF-8
135Bir komut arayüzü üzerinden programcıya programını adım adım izleme
136(trace) ve herhangi bir anda programın durumunu inceleme olanağı
137verir.
138
139%description -l uk.UTF-8
140Це повноцінний відладчик, що керується командами. Він дозволяє
141трасувати виконання програм та вивчати їх внутрішній стан в довільний
142момент часу. Працює з програмами на C та C++, зкомпільованими
143компіляторами GNU C (gcc, egcs, pgcc).
144
145%package gdbserver
146Summary: A standalone server for GDB (the GNU source-level debugger)
147Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
148Group: Development/Debuggers
149
150%description gdbserver
151GDB, the GNU debugger, allows you to debug programs written in C, C++,
152Java, and other languages, by executing them in a controlled fashion
153and printing their data.
154
155This package provides a program that allows you to run GDB on a
156different machine than the one which is running the program being
157debugged.
158
159%description gdbserver -l pl.UTF-8
160GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
161innych językach programowania poprzez wykonywanie ich w sposób
162kontrolowany oraz wypisywanie ich danych.
163
164Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
165maszynie niż ta, na której działa śledzony program.
166
167%package lib
168Summary: GDB in the form of a static library
169Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
170Group: Development/Debuggers
171# libraries that needs to be linked to fulfill libgdb.a symbol requirements
172Requires: binutils-devel >= 2.17.50
173Requires: expat-devel
174Requires: libselinux-devel
175Requires: libsepol-devel
176Requires: ncurses-devel
177Requires: python-devel
178Requires: readline-devel
179Requires: xz-devel
180Requires: zlib-devel
181
182%description lib
183GDB in the form of a static library.
184
185%description lib -l pl.UTF-8
186GDB w postaci biblioteki statycznej.
187
188%prep
189%setup -q
190
191# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
192%{__rm} gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
193%{__rm} gdb/m2-exp.c gdb/p-exp.c
194
195%patch100 -p1
196%patch101 -p1
197%patch102 -p1
198%patch103 -p1
199%patch104 -p1
200%patch105 -p1
201%patch106 -p1
202%patch110 -p1
203
204%patch112 -p1
205%patch113 -p1
206%patch114 -p1
207%patch115 -p1
208%patch116 -p1
209
210%patch1000 -p1
211%patch1001 -p1
212%patch1002 -p1
213%patch1005 -p1
214%patch1006 -p1
215
216# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
217cat > gdb/version.in << EOF
218%{version}-%{release} (PLD Linux)
219EOF
220
221sed -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
222 contrib/dg-extract-results.py \
223 gdb/contrib/test_pubnames_and_indexes.py \
224 gdb/testsuite/analyze-racy-logs.py \
225 gdb/testsuite/print-ts.py
226
227sed -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
228 gdb/copyright.py
229
230sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
231 gdb/contrib/cc-with-tweaks.sh \
232 gdb/gcore \
233 gdb/gcore.in \
234 src-release.sh
235
236%build
237# omit hand-written gdb/testsuite aclocal.m4
238for dir in gdb gdb/gdbserver ; do
239 olddir=$(pwd)
240 cd $dir
241 %{__rm} aclocal.m4
242 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
243 cd $olddir
244done
245for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
246 dir=$(dirname "$dir")
247 olddir=$(pwd)
248 cd $dir
249 %{__autoconf}
250 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
251 cd $olddir
252done
253cp -f /usr/share/automake/config.* .
254install -d build && cd build
255# don't --enable-shared here, there would be libs version mismatch with binutils
256../%configure \
257 --disable-gdbtk \
258 --disable-shared \
259 --disable-silent-rules \
260 --enable-gdbcli \
261 --enable-gdbmi \
262 --enable-multi-ice \
263 --enable-netrom \
264 --enable-nls \
265 --enable-tui \
266 --with-cpu=%{_target_cpu} \
267 --with-gdb-datadir=%{_datadir}/gdb \
268 --with-guile%{!?with_guile:=no} \
269%ifnarch alpha
270 --with-mmalloc \
271%endif
272%if %{with python}
273 --with-python \
274 --with-pythondir=%{py_sitescriptdir} \
275%else
276 --without-python \
277%endif
278 --with-separate-debug-dir=/usr/lib/debug \
279 --with-system-readline \
280 --without-included-gettext \
281 --without-included-regex \
282 --without-x
283
284# V=1 because only some subdirs honour --enable-silent-rules
285%{__make} \
286 V=1
287
288%{__make} -j1 info
289
290# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
291%{__make} -C gdb libgdb.a \
292 V=1
293
294%install
295rm -rf $RPM_BUILD_ROOT
296install -d $RPM_BUILD_ROOT%{_infodir}
297
298%{__make} -C build -j1 install install-info \
299 DESTDIR=$RPM_BUILD_ROOT
300
301cp -a build/gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
302
303# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
304# window is created too.
305echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
306ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
307
308bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
309%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
310
311rm -f $RPM_BUILD_ROOT%{_infodir}/dir
312
313%if %{with python}
314# Temporarily now:
315for LIB in lib lib64 libx32; do
316 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
317 install -d $LIBPATH
318done
319
320%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
321%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
322%py_postclean
323%endif
324
325cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
326
327cp -p build/libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
328
329# Remove the files that are part of a gdb build but that are owned and provided by other packages.
330# These are part of binutils:
331%{__rm} $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd,opcodes}.mo
332%{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
333%{__rm} $RPM_BUILD_ROOT%{_includedir}/{ansidecl,bfd,bfd_stdint,bfdlink,diagnostics,dis-asm,symcat,plugin-api}.h
334%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.la
335%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{bfd,opcodes}.a
336
337%clean
338rm -rf $RPM_BUILD_ROOT
339
340%post -p /sbin/postshell
341-/usr/sbin/fix-info-dir -c %{_infodir}
342
343%postun -p /sbin/postshell
344-/usr/sbin/fix-info-dir -c %{_infodir}
345
346%files
347%defattr(644,root,root,755)
348%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
349%attr(755,root,root) %{_bindir}/gdb
350%attr(755,root,root) %{_bindir}/gdbtui
351%attr(755,root,root) %{_bindir}/gdb-add-index
352%attr(755,root,root) %{_bindir}/gstack
353%attr(755,root,root) %{_bindir}/gcore
354%dir %{_datadir}/gdb
355%dir %{_datadir}/gdb/auto-load
356%dir %{_datadir}/gdb/auto-load%{_prefix}
357%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
358%ifarch %{x8664} x32
359%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
360%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
361%endif
362%{?with_guile:%{_datadir}/gdb/guile}
363%{_datadir}/gdb/syscalls
364%{_datadir}/gdb/system-gdbinit
365%{_datadir}/gdb/python
366%{_mandir}/man1/gdb.1*
367%{_mandir}/man1/gdbtui.1*
368%{_mandir}/man1/gdb-add-index.1*
369%{_mandir}/man1/gstack.1*
370%{_mandir}/man1/gcore.1*
371%{_mandir}/man5/gdbinit.5*
372%lang(es) %{_mandir}/es/man1/*
373%lang(fr) %{_mandir}/fr/man1/*
374%lang(hu) %{_mandir}/hu/man1/*
375%lang(ja) %{_mandir}/ja/man1/*
376%lang(pl) %{_mandir}/pl/man1/*
377%{_infodir}/annotate.info*
378%{_infodir}/gdb.info*
379%{_infodir}/stabs.info*
380
381%files gdbserver
382%defattr(644,root,root,755)
383%attr(755,root,root) %{_bindir}/gdbserver
384%{_mandir}/man1/gdbserver.1*
385%ifnarch %{arm}
386%attr(755,root,root) %{_libdir}/libinproctrace.so
387%endif
388
389%files lib
390%defattr(644,root,root,755)
391%{_libdir}/libdecnumber.a
392%{_libdir}/libgdb.a
393%{_includedir}/gdb
This page took 0.093193 seconds and 4 git commands to generate.