]> git.pld-linux.org Git - packages/firefox.git/blobdiff - mozilla-firefox.spec
- initial, NFY
[packages/firefox.git] / mozilla-firefox.spec
index 3367a6b6e4501214f5555f4786035041165ca3b6..034c70d394a73849c7c8a04d447e263f4f62d11f 100644 (file)
@@ -1,27 +1,41 @@
+#
+# Conditional build:
+%bcond_with    tests   # enable tests (whatever they check)
+#
 Summary:       Mozilla Firefox web browser
 Summary(pl):   Mozilla Firefox - przegl±darka WWW
 Name:          mozilla-firefox
-Version:       0.8
-Release:       1.2
+Version:       0.9.2
+Release:       1
 License:       MPL/LGPL
 Group:         X11/Applications/Networking
-Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-source-%{version}.tar.bz2
-# Source0-md5: cdc85152f4219bf3e3f1a8dc46e04654
+Source0:       http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/firefox-%{version}-source.tar.bz2
+# Source0-md5: eb6edaa488fb596b08d4ba50072546e1
 Source1:       %{name}.desktop
 Patch0:                %{name}-alpha-gcc3.patch
+Patch1:                %{name}-nspr.patch
+Patch2:                %{name}-nss.patch
+Patch3:                %{name}-lib_path.patch
 URL:           http://www.mozilla.org/projects/firefox/
+BuildRequires: automake
 BuildRequires: gtk+2-devel >= 2.0.0
-BuildRequires:  libIDL-devel >= 0.8.0
+BuildRequires: libIDL-devel >= 0.8.0
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.2.0
 BuildRequires: libstdc++-devel
+BuildRequires: nspr-devel >= 1:4.5.0
+BuildRequires: nss-devel >= 3.8
 BuildRequires: pango-devel >= 1.1.0
 BuildRequires: zip
+Requires:      %{name}-lang-resources = %{version}
+Requires:      nspr >= 1:4.5.0
+Requires:      nss >= 3.8
 Obsoletes:     mozilla-firebird
-Requires:      %{name}-lang-resources
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        _firefoxdir     %{_libdir}/%{name}
+%define                _firefoxdir     %{_libdir}/%{name}
+# mozilla and firefox provide their own versions
+%define                _noautoreqdep   libgkgfx.so libgtkembedmoz.so libgtkxtbin.so libjsj.so libmozjs.so libxpcom.so libxpcom_compat.so
 
 %description
 Mozilla Firefox is an open-source web browser, designed for standards
@@ -35,11 +49,10 @@ my
 Summary:       English resources for Mozilla-firefox
 Summary(pl):   Anglojêzyczne zasoby dla Mozilla-FireFox
 Group: X11/Applications/Networking
-Requires(post,postun): mozilla-firefox >= %{version}-1.1
+Requires(post,postun): %{name} = %{version}-%{release}
 Requires(post,postun): textutils
-Requires:      mozilla-firefox >= %{version}-1.1
-Provides:      %{name}-lang-resources
-Obsoletes:     %{name}-lang-resources
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-lang-resources = %{version}-%{release}
 
 %description lang-en
 English resources for Mozilla-firefox
@@ -50,52 +63,56 @@ Angloj
 %prep
 %setup -q -n mozilla
 %patch0 -p1
-
-### FIXME: Shouldn't the default firefox config be part of original source ?
-cat <<EOF >.mozconfig
-export MOZ_PHOENIX="1"
-mk_add_options MOZ_PHOENIX="1"
-ac_add_options --with-system-jpeg
-ac_add_options --with-system-zlib
-ac_add_options --with-system-png
-ac_add_options --with-system-mng
-ac_add_options --with-pthreads
-ac_add_options --disable-tests
-ac_add_options --disable-debug
-ac_add_options --disable-debug-modules
-ac_add_options --disable-xprint
-ac_add_options --disable-mailnews
-ac_add_options --disable-composer
-ac_add_options --disable-ldap
-ac_add_options --disable-jsd
-ac_add_options --disable-dtd-debug
-ac_add_options --disable-gtktest
-ac_add_options --disable-freetypetest
-ac_add_options --disable-installer
-ac_add_options --enable-plaintext-editor-only
-ac_add_options --enable-optimize="%{optflags}"
-ac_add_options --enable-crypto
-ac_add_options --enable-strip
-ac_add_options --enable-strip-libs
-ac_add_options --enable-reorder
-ac_add_options --enable-mathml
-ac_add_options --enable-xinerama
-ac_add_options --enable-extensions="pref,cookie,wallet"
-ac_add_options --enable-freetype2
-ac_add_options --enable-xft
-ac_add_options --enable-default-toolkit="gtk2"
-EOF
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-#export MOZ_PHOENIX="1"
-#configure
-#{__make} %{?_smp_mflags}
-
-export CFLAGS="%{optflags}"
-export CXXFLAGS="%{optflags}"
+export CFLAGS="%{rpmcflags}"
+export CXXFLAGS="%{rpmcflags}"
 export MOZ_PHOENIX="1"
 
-%{__make} -f client.mk build
+cp -f /usr/share/automake/config.* build/autoconf
+cp -f /usr/share/automake/config.* nsprpub/build/autoconf
+cp -f /usr/share/automake/config.* directory/c-sdk/config/autoconf
+%configure2_13 \
+%if %{?debug:1}0
+       --enable-debug \
+       --enable-debug-modules \
+%else
+       --disable-debug \
+       --disable-debug-modules \
+%endif
+       --disable-composer \
+       --disable-dtd-debug \
+       --disable-installer \
+       --disable-jsd \
+       --disable-ldap \
+       --disable-mailnews \
+%if %{with tests}
+       --enable-tests \
+%else
+       --disable-tests \
+%endif
+       --disable-xprint \
+       --enable-crypto \
+       --enable-freetype2 \
+       --enable-mathml \
+       --enable-optimize="%{rpmcflags}" \
+       --enable-plaintext-editor-only \
+       --enable-reorder \
+       --enable-strip \
+       --enable-strip-libs \
+       --enable-xinerama \
+       --enable-xft \
+       --enable-default-toolkit="gtk2" \
+       --with-pthreads \
+       --with-system-jpeg \
+       --with-system-nspr \
+       --with-system-png \
+       --with-system-zlib
+
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -103,7 +120,8 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_pixmapsdir},%{_desktopdir}}
 
 %{__make} -C xpinstall/packager \
        MOZ_PKG_APPNAME="mozilla-firefox" \
-       MOZILLA_BIN="\$(DIST)/bin/firefox-bin"
+       MOZILLA_BIN="\$(DIST)/bin/firefox-bin" \
+       EXCLUDE_NSPR_LIBS=1
 
 #install -m0755 %{name}.sh $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
 ln -sf %{_firefoxdir}/firefox $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
@@ -129,6 +147,26 @@ rm -rf $RPM_BUILD_ROOT
 umask 022
 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
 
+cat << EOF
+
+ ****************************************************
+ *                                                  *
+ *  NOTE:                                           *
+ *  After upgrade from 0.9 you have to              *
+ *  manually remove ~/.phoenix dir, and answer:     *
+ *  "don't import anything" when asked about        *
+ *  importing settings                              *
+ *                                                  *
+ ****************************************************
+
+EOF
+
+%postun
+if [ "$1" != "0" ]; then
+       umask 022
+       cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
+fi
+
 %post lang-en
 umask 022
 cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installed-chrome.txt
@@ -142,7 +180,11 @@ cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installe
 %attr(755,root,root) %{_bindir}/*
 %dir %{_firefoxdir}
 %{_firefoxdir}/res
-%{_firefoxdir}/components
+%dir %{_firefoxdir}/components
+%attr(755,root,root) %{_firefoxdir}/components/*.so
+%{_firefoxdir}/components/*.js
+%{_firefoxdir}/components/*.xpt
+%{_firefoxdir}/components/myspell
 %{_firefoxdir}/plugins
 %{_firefoxdir}/searchplugins
 %{_firefoxdir}/icons
@@ -158,16 +200,21 @@ cat %{_firefoxdir}/chrome/*-installed-chrome.txt >%{_firefoxdir}/chrome/installe
 %ifarch %{ix86}
 %attr(755,root,root) %{_firefoxdir}/elf-dynstr-gc
 %endif
-%attr(755,root,root) %{_firefoxdir}/libsoftokn3.chk
-%attr(755,root,root) %{_firefoxdir}/shlibsign
 %{_firefoxdir}/bloaturls.txt
 %{_pixmapsdir}/*
 %{_desktopdir}/*
 
 %dir %{_firefoxdir}/chrome
 %{_firefoxdir}/chrome/browser.jar
+# -chat subpackage?
+#%{_firefoxdir}/chrome/chatzilla.jar
 %{_firefoxdir}/chrome/classic.jar
 %{_firefoxdir}/chrome/comm.jar
+%{_firefoxdir}/chrome/content-packs.jar
+%{_firefoxdir}/chrome/help.jar
+# -dom-inspector subpackage?
+#%{_firefoxdir}/chrome/inspector.jar
+%{_firefoxdir}/chrome/modern.jar
 %{_firefoxdir}/chrome/pip*.jar
 %{_firefoxdir}/chrome/toolkit.jar
 %{_firefoxdir}/chrome/mozilla-firefox-misc-installed-chrome.txt
This page took 0.033268 seconds and 4 git commands to generate.