]> git.pld-linux.org Git - packages/ffms2.git/blame - ffms2.spec
- fix building with ffmpeg 4.0
[packages/ffms2.git] / ffms2.spec
CommitLineData
8d93948c
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
ffd255af 4%bcond_without avresample # avresample support via libavresample
8d93948c 5
f99faf48
JB
6Summary: FFmpegSource - FFmpeg wrapper library
7Summary(pl.UTF-8): FFmpegSource - biblioteka obudowująca FFmpeg
8d93948c
ER
8Name: ffms2
9Version: 2.20
5ccd3511 10Release: 5
f99faf48
JB
11License: MIT (ffmpegsource itself), GPL v3+ (forced by ffmpeg)
12Group: Libraries
8d93948c
ER
13Source0: https://github.com/FFMS/ffms2/archive/%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: d6f2faa9e0ffed2e2d8d926592a87744
15Patch0: ffmpegsource-ffmpeg011.patch
b76871bb 16Patch1: ffmpeg3.patch
5ccd3511 17Patch2: ffmpeg4.patch
8d93948c 18URL: https://github.com/FFMS/ffms2
f99faf48 19BuildRequires: autoconf >= 2.58
ffd255af 20BuildRequires: automake >= 1:1.11
ce23f194 21# PKG_CHECK_MODULES(LIBAV, [libavformat >= 53.20.0 libavcodec >= 53.24.0 libswscale >= 0.7.0 libavutil >= 51.21.0 ])
7d6fea5e 22BuildRequires: ffmpeg-devel >= 0.9
ffd255af
JB
23# libavresample >= 1.0.0
24%{?with_avresample:BuildRequires: ffmpeg-devel >= 1.1}
f99faf48
JB
25BuildRequires: libstdc++-devel
26BuildRequires: libtool >= 2:2.0
f99faf48 27BuildRequires: pkgconfig >= 1:0.22
f36cd6f2
JB
28BuildRequires: rpmbuild(macros) >= 1.566
29BuildRequires: sed >= 4.0
f99faf48 30BuildRequires: zlib-devel
8d93948c 31Obsoletes: ffmpegsource < 2.20
f99faf48
JB
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35FFmpegSource (usually known as FFMS or FFMS2) is a cross-platform
36wrapper library around FFmpeg, plus some additional components to deal
37with file formats FFmpeg's libavformat has (or used to have) problems
38with. It gives you an easy, convenient way to say "open and decompress
39this media file for me, I don't care how you do it" and get frame- and
40sample-accurate access (usually), without having to bother with the
41sometimes less than straightforward and less than perfectly documented
42FFmpeg API.
43
44%description -l pl.UTF-8
45FFmpegSource (zwykle zwana FFMS lub FFMS2) to wieloplatformowa
46biblioteka obudowująca FFmpeg wraz z paroma dodatkowymi komponentami
47mającymi radzić sobie z formatami plików, z którymi libavformat z
48FFmpeg ma (lub miał) problemy. Umożliwia w łatwy sposób zażądanie
49"otwórz i zdekompresuj ten plik, nieważne jak" i uzyskanie dostępu
8d93948c
ER
50(zwykle) z dokładnością do ramek i próbek, bez potrzeby zajmowania się
51często złożonym, nie najlepiej udokumentowanym API FFmpeg.
f99faf48
JB
52
53%package devel
54Summary: Header files for FFmpegSource library
55Summary(pl.UTF-8): Pliki nagłówkowe biblioteki FFmpegSource
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
ffd255af
JB
58%if %{with avresample}
59Requires: ffmpeg-devel >= 1.1
60%else
7d6fea5e 61Requires: ffmpeg-devel >= 0.9
ffd255af 62%endif
f99faf48
JB
63Requires: libstdc++-devel
64Requires: zlib-devel
8d93948c
ER
65Provides: ffmpegsource-devel = %{version}-%{release}
66Obsoletes: ffmpegsource-devel < 2.20
f99faf48
JB
67
68%description devel
69Header files for FFmpegSource library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki FFmpegSource.
73
74%package static
75Summary: Static FFmpegSource library
76Summary(pl.UTF-8): Statyczna biblioteka FFmpegSource
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
8d93948c 79Obsoletes: ffmpegsource-static < 2.20
f99faf48
JB
80
81%description static
82Static FFmpegSource library.
83
84%description static -l pl.UTF-8
85Statyczna biblioteka FFmpegSource.
86
87%prep
8d93948c 88%setup -q
da3072ef 89%patch0 -p0
b76871bb 90%patch1 -p1
5ccd3511 91%patch2 -p1
f36cd6f2 92%undos src/core/{indexing,lavfindexer,utils}.cpp
f99faf48
JB
93%{__rm} configure
94
95%build
b76871bb 96CXXFLAGS="%{rpmcxxflags} -Wall -Wextra -Wno-missing-field-initializers"
f99faf48
JB
97%{__libtoolize}
98%{__aclocal} -I m4
99%{__autoconf}
100%{__autoheader}
101%{__automake}
102%configure \
ffd255af 103 --enable-avresample%{!?with_avresample:=no} \
8d93948c 104 --disable-silent-rules \
ffd255af
JB
105 --enable-shared \
106 %{__enable_disable static_libs static}
cf17c716 107
8d93948c 108%{__make}
f99faf48
JB
109
110%install
111rm -rf $RPM_BUILD_ROOT
f99faf48
JB
112%{__make} install \
113 DESTDIR=$RPM_BUILD_ROOT
114
8d93948c
ER
115%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
116
f99faf48
JB
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(644,root,root,755)
ffd255af 125%doc COPYING README.md
f99faf48
JB
126%attr(755,root,root) %{_bindir}/ffmsindex
127%attr(755,root,root) %{_libdir}/libffms2.so.*.*.*
8d93948c 128%attr(755,root,root) %ghost %{_libdir}/libffms2.so.3
f99faf48
JB
129
130%files devel
131%defattr(644,root,root,755)
132%doc doc/*.{html,css}
133%attr(755,root,root) %{_libdir}/libffms2.so
134%{_libdir}/libffms2.la
135%{_includedir}/ffms.h
136%{_includedir}/ffmscompat.h
137%{_pkgconfigdir}/ffms2.pc
138
8d93948c 139%if %{with static_libs}
f99faf48
JB
140%files static
141%defattr(644,root,root,755)
142%{_libdir}/libffms2.a
8d93948c 143%endif
This page took 0.116484 seconds and 4 git commands to generate.