]> git.pld-linux.org Git - packages/evolution-data-server.git/blobdiff - evolution-data-server.spec
- added kerberos5 and ldap bconds
[packages/evolution-data-server.git] / evolution-data-server.spec
index 47260bac782e11fc3d1e68fa762380aa6456fadf..a764372814550876cecaf53b2e2540dc8d6632af 100644 (file)
@@ -1,36 +1,46 @@
-
 #
 # todo:
 # - system libical
 #
-
-%define                mver            1.0
+%define                mver            1.2
+%bcond_without kerberos5       # build without kerberos5 support
+%bcond_without ldap            # build without ldap support
 
 Summary:       Evolution data server
 Summary(pl):   Serwer danych Evolution
 Name:          evolution-data-server
-Version:       0.0.91
-Release:       1
+Version:       1.2.1
+Release:       2.1
 License:       GPL
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/gnome/sources/%{name}/0.0/%{name}-%{version}.tar.gz
-# Source0-md5: f4ec7c5ca9046cdf82a00c7bf141f846
+Source0:       http://ftp.gnome.org/pub/gnome/sources/evolution-data-server/1.2/%{name}-%{version}.tar.bz2
+# Source0-md5: c86cc41c1563f552015aebb563018936
 Patch0:                %{name}-system_db.patch
-Patch1:                %{name}-locale-names.patch
+Patch1:                %{name}-GG-IM.patch
+Patch2:                %{name}-workaround-cal-backend-leak.patch
+Patch3:                %{name}-bonobo.patch
 URL:           http://www.ximian.com/products/ximian_evolution/
-BuildRequires: ORBit2-devel >= 1:2.10.0
+BuildRequires: ORBit2-devel >= 1:2.12.1
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: db-devel
+BuildRequires: gnome-common >= 2.8.0
+BuildRequires: howl-devel >= 0.9.10
 BuildRequires: intltool
-BuildRequires: libgnome-devel >= 2.6.0
-BuildRequires: libsoup-devel >= 2.1.9
+BuildRequires: libglade2-devel >= 1:2.5.0
+BuildRequires: libgnomeui-devel >= 2.10.0
+BuildRequires: libsoup-devel >= 2.2.2
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: openldap-devel
+BuildRequires: nspr-devel
+Buildrequires: nss-devel
 BuildRequires: pkgconfig
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
+%{?with_ldap:BuildRequires:    openldap-devel >= 2.0.0}
 Requires(post,postun): /sbin/ldconfig
 Requires(post,postun): /usr/bin/scrollkeeper-update
 Requires(post):                GConf2
+Requires:      libsoup >= 2.2.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -44,11 +54,15 @@ Summary:    Evolution data server development files
 Summary(pl):   Pliki programistyczne serwera danych evolution
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      GConf2-devel >= 2.6.0
-Requires:      ORBit2-devel >= 1:2.10.0
-Requires:      glib2-devel >= 1:2.4.0
-Requires:      libbonobo-devel >= 2.6.0
+# for all but libegroupwise
+Requires:      GConf2-devel >= 2.10.0
+Requires:      ORBit2-devel >= 1:2.12.1
+Requires:      glib2-devel >= 1:2.6.2
+Requires:      libbonobo-devel >= 2.8.1
+Requires:      libgnome-devel >= 2.10.0
 Requires:      libxml2-devel
+# for libegroupwise
+Requires:      libsoup-devel >= 2.2.2
 
 %description devel
 This package contains the files necessary to develop applications
@@ -74,15 +88,16 @@ Statyczne biblioteki serwera danych Evolution.
 %setup -q 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
-mv po/{no,nb}.po
 rm -rf libdb
 
 %build
 glib-gettextize --copy --force
 intltoolize --copy --force
 %{__libtoolize}
-%{__aclocal} -I %{_aclocaldir}/gnome2-macros
+%{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
@@ -96,10 +111,16 @@ cd calendar/libical
 cd ../..
 
 %configure \
+       %{?with_kerberos5:--with-krb5=%{_prefix}} \
+       %{!?with_kerberos5:--with-krb5=no} \
+       %{?with_ldap:--with-openldap=yes} \
+       %{!?with_ldap:--with-openldap=no} \
        --enable-gtk-doc \
        --enable-static \
-       --with-openldap=yes
-
+       --with-nspr-includes=%{_includedir}/nspr \
+       --with-nspr-libs=%{_libdir} \
+       --with-nss-includes=%{_includedir}/nss \
+       --with-nss-libs=%{_libdir}
 %{__make} \
        HTML_DIR=%{_gtkdocdir} \
        GTKHTML_DATADIR=%{_datadir}/idl 
@@ -113,6 +134,10 @@ rm -rf $RPM_BUILD_ROOT
        HTML_DIR=%{_gtkdocdir} \
        pkgconfigdir=%{_pkgconfigdir}
 
+rm $RPM_BUILD_ROOT%{_libdir}/%{name}-%{mver}/{camel-providers,extensions}/*.{,l}a
+
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
+
 %find_lang %{name} --all-name
 
 %clean
@@ -130,13 +155,24 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS* README
-%attr(755,root,root) %{_libdir}/%{name}-1.0
+%attr(755,root,root) %{_libdir}/camel-index-control-%{mver}
+%attr(755,root,root) %{_libdir}/camel-lock-helper-%{mver}
 %attr(755,root,root) %{_libdir}/*.so.*.*
+%dir %{_libdir}/%{name}-%{mver}
+%attr(755,root,root) %{_libdir}/%{name}-%{mver}/%{name}
+%dir %{_libdir}/%{name}-%{mver}/camel-providers
+%attr(755,root,root) %{_libdir}/%{name}-%{mver}/camel-providers/*.so
+%{_libdir}/%{name}-%{mver}/camel-providers/*.urls
+%dir %{_libdir}/%{name}-%{mver}/extensions
+%attr(755,root,root) %{_libdir}/%{name}-%{mver}/extensions/*.so
 %{_libdir}/bonobo/servers/*
 %{_datadir}/idl/*
 %dir %{_datadir}/%{name}-%{mver}
+%{_datadir}/%{name}-%{mver}/glade
+%{_datadir}/%{name}-%{mver}/weather
 %{_datadir}/%{name}-%{mver}/zoneinfo
 %{_datadir}/%{name}-%{mver}/*.schema
+%{_pixmapsdir}/%{name}-%{mver}
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.033591 seconds and 4 git commands to generate.