]> git.pld-linux.org Git - packages/ecryptfs-utils.git/blame_incremental - ecryptfs-utils.spec
- rel 4; suid for mount.ecryptfs_private
[packages/ecryptfs-utils.git] / ecryptfs-utils.spec
... / ...
CommitLineData
1Summary: The eCryptfs mount helper and support libraries
2Summary(pl.UTF-8): Narzędzie pomocnicze i biblioteki do montowania eCryptfs
3Name: ecryptfs-utils
4Version: 85
5Release: 4
6License: GPL v2+
7Group: Base
8Source0: http://launchpad.net/ecryptfs/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
9# Source0-md5: eacf9488681d99651da544a4c261f784
10Patch0: %{name}-sh.patch
11Patch1: %{name}-83-fixsalt.patch
12Patch2: %{name}-83-splitnss.patch
13Patch3: %{name}-84-fgetc.patch
14Patch4: %{name}-84-fixsigness.patch
15Patch5: %{name}-75-werror.patch
16URL: http://ecryptfs.sourceforge.net/
17BuildRequires: autoconf >= 2.59
18BuildRequires: automake
19BuildRequires: gpgme-devel
20BuildRequires: intltool >= 0.41.0
21BuildRequires: keyutils-devel >= 1.0
22BuildRequires: libtool
23BuildRequires: nss-devel >= 3
24BuildRequires: openssl-devel >= 0.9.7
25BuildRequires: pam-devel
26BuildRequires: perl-tools-pod
27BuildRequires: pkcs11-helper-devel >= 1.04
28BuildRequires: pkgconfig
29BuildRequires: python-devel >= 1:2.5
30BuildRequires: rpmbuild(macros) >= 1.219
31BuildRequires: swig >= 1.3.31
32BuildRequires: trousers-devel
33Requires: uname(release) >= 2.6.19
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36# python module
37%define skip_post_check_so _libecryptfs.so.0.0.0
38
39%description
40eCryptfs is a stacked cryptographic filesystem that ships in Linux
41kernel versions 2.6.19 and above. This package provides the mount
42helper and supporting libraries to perform key management and mount
43functions.
44
45Install ecryptfs-utils if you would like to mount eCryptfs.
46
47%description -l pl.UTF-8
48eCryptfs to stakowalny kryptograficzny system plików dostępny w jądrze
49Linuksa od wersji 2.6.19. Ten pakiet udostępnia narzędzie pomocnicze
50dla programu mount oraz wspierające je biblioteki wykonujące
51zarządzanie kluczami i funkcje związane z montowaniem.
52
53Pakiet ecryptfs-utils należy zainstalować, aby montować eCryptfs.
54
55%package devel
56Summary: The eCryptfs userspace development package
57Summary(pl.UTF-8): Pakiet programistyczny przestrzeni użytkownika dla eCryptfs
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: keyutils-devel >= 1.0
61Requires: nss-devel >= 3
62
63%description devel
64Userspace development files for eCryptfs.
65
66%description devel -l pl.UTF-8
67Pliki programistyczne przestrzeni użytkownika dla eCryptfs.
68
69%package static
70Summary: Static eCryptfs library
71Summary(pl.UTF-8): Statyczna biblioteka eCryptfs
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74
75%description static
76Static eCryptfs library.
77
78%description static -l pl.UTF-8
79Statyczna biblioteka eCryptfs.
80
81%package -n pam-pam_ecryptfs
82Summary: eCryptfs PAM module
83Summary(pl.UTF-8): Moduł PAM eCryptfs
84Group: Base
85Requires: %{name} = %{version}-%{release}
86
87%description -n pam-pam_ecryptfs
88eCryptfs PAM module.
89
90%description -n pam-pam_ecryptfs -l pl.UTF-8
91Moduł PAM eCryptfs.
92
93%package -n python-ecryptfs
94Summary: Python bindings for the eCryptfs utils
95Summary(pl.UTF-8): Wiązania Pythona do narzędzi eCryptfs
96Group: Libraries/Python
97Requires: %{name} = %{version}-%{release}
98Obsoletes: ecryptfs-utils-python
99
100%description -n python-ecryptfs
101This package contains a module that permits applications written in
102the Python programming language to use the interface supplied by the
103ecryptfs-utils library.
104
105%description -n python-ecryptfs -l pl.UTF-8
106Ten pakiet zawiera moduł pozwalający aplikacjom napisanym w Pythonie
107na korzystanie z interfejsu dostarczanego przez bibliotekę
108ecryptfs-utils.
109
110%prep
111%setup -q
112%patch0 -p1
113%patch1 -p1
114%patch2 -p1
115%patch3 -p1
116%patch4 -p1
117%patch5 -p1
118
119%build
120%{__libtoolize}
121%{__aclocal} -I m4
122%{__autoconf}
123%{__autoheader}
124%{__automake}
125%configure \
126 --enable-gpg \
127 --enable-openssl \
128 --enable-pam \
129 --enable-pkcs11-helper \
130 --enable-tspi \
131 --enable-static
132
133%{__make}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%{__make} -j1 install \
139 DESTDIR=$RPM_BUILD_ROOT
140
141%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.{la,a}
142%py_postclean
143
144%find_lang %{name}
145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%pre
150%groupadd -g 260 ecryptfs
151
152%postun
153/sbin/ldconfig
154if [ "$1" = "0" ]; then
155 %groupremove ecryptfs
156fi
157
158%post -p /sbin/ldconfig
159
160%files -f %{name}.lang
161%defattr(644,root,root,755)
162%doc AUTHORS ChangeLog NEWS README THANKS doc/{ecryptfs-faq.html,ecryptfs-pkcs11-helper-doc.txt}
163%attr(755,root,root) /sbin/mount.ecryptfs
164%attr(4750,root,ecryptfs) /sbin/mount.ecryptfs_private
165%attr(755,root,root) /sbin/umount.ecryptfs_private
166%attr(755,root,root) /sbin/umount.ecryptfs
167%attr(755,root,root) %{_bindir}/ecryptfs-*
168%attr(755,root,root) %{_bindir}/ecryptfsd
169%attr(755,root,root) %{_libdir}/libecryptfs.so.*.*.*
170%attr(755,root,root) %ghost %{_libdir}/libecryptfs.so.0
171%dir %{_libdir}/ecryptfs
172%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_gpg.so
173%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_openssl.so
174%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_passphrase.so
175%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_pkcs11_helper.so
176%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_tspi.so
177%{_datadir}/%{name}
178%{_mandir}/man1/ecryptfs-*.1*
179%{_mandir}/man1/mount.ecryptfs_private.1*
180%{_mandir}/man1/umount.ecryptfs_private.1*
181%{_mandir}/man7/ecryptfs.7*
182%{_mandir}/man8/ecryptfs-*.8*
183%{_mandir}/man8/ecryptfsd.8*
184%{_mandir}/man8/mount.ecryptfs.8*
185%{_mandir}/man8/umount.ecryptfs.8*
186
187%files devel
188%defattr(644,root,root,755)
189%attr(755,root,root) %{_libdir}/libecryptfs.so
190%{_libdir}/libecryptfs.la
191%{_includedir}/ecryptfs.h
192%{_pkgconfigdir}/libecryptfs.pc
193
194%files static
195%defattr(644,root,root,755)
196%{_libdir}/libecryptfs.a
197
198%files -n pam-pam_ecryptfs
199%defattr(644,root,root,755)
200%doc doc/ecryptfs-pam-doc.txt
201%attr(755,root,root) /%{_lib}/security/pam_ecryptfs.so
202%{_mandir}/man8/pam_ecryptfs.8*
203
204%files -n python-ecryptfs
205%defattr(644,root,root,755)
206%dir %{py_sitedir}/%{name}
207%attr(755,root,root) %{py_sitedir}/%{name}/_libecryptfs.so*
208%dir %{py_sitescriptdir}/%{name}
209%{py_sitescriptdir}/%{name}/*.py[co]
This page took 0.081889 seconds and 4 git commands to generate.