]> git.pld-linux.org Git - packages/ecryptfs-utils.git/blame_incremental - ecryptfs-utils.spec
rebuild with openssl 3.0.0
[packages/ecryptfs-utils.git] / ecryptfs-utils.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with gui # GTK+ GUI components (non-existing as of 111)
4%bcond_without static_libs # static library
5#
6Summary: The eCryptfs mount helper and support libraries
7Summary(pl.UTF-8): Narzędzie pomocnicze i biblioteki do montowania eCryptfs
8Name: ecryptfs-utils
9Version: 111
10Release: 4
11License: GPL v2+
12Group: Base
13#Source0Download: https://launchpad.net/ecryptfs/+download
14Source0: https://launchpad.net/ecryptfs/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
15# Source0-md5: 83513228984f671930752c3518cac6fd
16Patch0: %{name}-sh.patch
17Patch1: %{name}-83-fixsalt.patch
18Patch2: %{name}-83-splitnss.patch
19Patch3: %{name}-84-fixsigness.patch
20Patch4: openssl.patch
21URL: http://ecryptfs.org/
22BuildRequires: autoconf >= 2.59
23BuildRequires: automake
24BuildRequires: gettext-tools
25BuildRequires: glib2-devel >= 2.0
26BuildRequires: gpgme-devel
27%{?with_gui:BuildRequires: gtk+2-devel >= 2.0}
28BuildRequires: intltool >= 0.41.0
29BuildRequires: keyutils-devel >= 1.0
30BuildRequires: libtool
31BuildRequires: nss-devel >= 3
32BuildRequires: openssl-devel >= 0.9.7
33BuildRequires: pam-devel
34BuildRequires: perl-tools-pod
35BuildRequires: pkcs11-helper-devel >= 1.04
36BuildRequires: pkgconfig
37BuildRequires: python-devel >= 1:2.5
38BuildRequires: python-modules >= 1:2.5
39BuildRequires: rpm-pythonprov
40BuildRequires: rpmbuild(macros) >= 1.219
41BuildRequires: swig >= 1.3.31
42BuildRequires: swig-python >= 1.3.31
43BuildRequires: trousers-devel
44Requires: uname(release) >= 2.6.19
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47# python module
48%define skip_post_check_so _libecryptfs.so.0.0.0
49
50%description
51eCryptfs is a stacked cryptographic filesystem that ships in Linux
52kernel versions 2.6.19 and above. This package provides the mount
53helper and supporting libraries to perform key management and mount
54functions.
55
56Install ecryptfs-utils if you would like to mount eCryptfs.
57
58%description -l pl.UTF-8
59eCryptfs to stakowalny kryptograficzny system plików dostępny w jądrze
60Linuksa od wersji 2.6.19. Ten pakiet udostępnia narzędzie pomocnicze
61dla programu mount oraz wspierające je biblioteki wykonujące
62zarządzanie kluczami i funkcje związane z montowaniem.
63
64Pakiet ecryptfs-utils należy zainstalować, aby montować eCryptfs.
65
66%package devel
67Summary: The eCryptfs userspace development package
68Summary(pl.UTF-8): Pakiet programistyczny przestrzeni użytkownika dla eCryptfs
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: keyutils-devel >= 1.0
72Requires: nss-devel >= 3
73
74%description devel
75Userspace development files for eCryptfs.
76
77%description devel -l pl.UTF-8
78Pliki programistyczne przestrzeni użytkownika dla eCryptfs.
79
80%package static
81Summary: Static eCryptfs library
82Summary(pl.UTF-8): Statyczna biblioteka eCryptfs
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85
86%description static
87Static eCryptfs library.
88
89%description static -l pl.UTF-8
90Statyczna biblioteka eCryptfs.
91
92%package -n pam-pam_ecryptfs
93Summary: eCryptfs PAM module
94Summary(pl.UTF-8): Moduł PAM eCryptfs
95Group: Base
96Requires: %{name} = %{version}-%{release}
97
98%description -n pam-pam_ecryptfs
99eCryptfs PAM module.
100
101%description -n pam-pam_ecryptfs -l pl.UTF-8
102Moduł PAM eCryptfs.
103
104%package -n python-ecryptfs
105Summary: Python bindings for the eCryptfs utils
106Summary(pl.UTF-8): Wiązania Pythona do narzędzi eCryptfs
107Group: Libraries/Python
108Requires: %{name} = %{version}-%{release}
109Obsoletes: ecryptfs-utils-python
110
111%description -n python-ecryptfs
112This package contains a module that permits applications written in
113the Python programming language to use the interface supplied by the
114ecryptfs-utils library.
115
116%description -n python-ecryptfs -l pl.UTF-8
117Ten pakiet zawiera moduł pozwalający aplikacjom napisanym w Pythonie
118na korzystanie z interfejsu dostarczanego przez bibliotekę
119ecryptfs-utils.
120
121%prep
122%setup -q
123%patch0 -p1
124%patch1 -p1
125%patch2 -p1
126%patch3 -p1
127%patch4 -p1
128
129%build
130%{__libtoolize}
131%{__aclocal} -I m4
132%{__autoconf}
133%{__autoheader}
134%{__automake}
135%configure \
136 --enable-gpg \
137 %{?with_gui:--enable-gui} \
138 --enable-nss \
139 --enable-openssl \
140 --enable-pam \
141 --enable-pkcs11-helper \
142 --enable-tspi \
143 %{?with_static_libs:--enable-static}
144
145%{__make}
146
147%install
148rm -rf $RPM_BUILD_ROOT
149
150%{__make} -j1 install \
151 DESTDIR=$RPM_BUILD_ROOT
152
153# obsoleted by pkg-config
154%{__rm} $RPM_BUILD_ROOT%{_libdir}/libecryptfs.la
155
156%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.la \
157 %{?with_static_libs:$RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.a}
158%py_postclean
159
160%find_lang %{name}
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165%pre
166%groupadd -g 260 ecryptfs
167
168%postun
169/sbin/ldconfig
170if [ "$1" = "0" ]; then
171 %groupremove ecryptfs
172fi
173
174%post -p /sbin/ldconfig
175
176%files -f %{name}.lang
177%defattr(644,root,root,755)
178%doc AUTHORS ChangeLog NEWS README THANKS doc/{ecryptfs-faq.html,ecryptfs-pkcs11-helper-doc.txt}
179%attr(755,root,root) /sbin/mount.ecryptfs
180%attr(4754,root,ecryptfs) /sbin/mount.ecryptfs_private
181%attr(755,root,root) /sbin/umount.ecryptfs_private
182%attr(755,root,root) /sbin/umount.ecryptfs
183%attr(755,root,root) %{_bindir}/ecryptfs-*
184%attr(755,root,root) %{_bindir}/ecryptfsd
185%attr(755,root,root) %{_libdir}/libecryptfs.so.*.*.*
186%attr(755,root,root) %ghost %{_libdir}/libecryptfs.so.1
187%dir %{_libdir}/ecryptfs
188%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_gpg.so
189%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_openssl.so
190%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_passphrase.so
191%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_pkcs11_helper.so
192%attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_tspi.so
193%{_datadir}/%{name}
194%{_mandir}/man1/ecryptfs-*.1*
195%{_mandir}/man1/mount.ecryptfs_private.1*
196%{_mandir}/man1/umount.ecryptfs_private.1*
197%{_mandir}/man7/ecryptfs.7*
198%{_mandir}/man8/ecryptfs-*.8*
199%{_mandir}/man8/ecryptfsd.8*
200%{_mandir}/man8/mount.ecryptfs.8*
201%{_mandir}/man8/umount.ecryptfs.8*
202
203%files devel
204%defattr(644,root,root,755)
205%attr(755,root,root) %{_libdir}/libecryptfs.so
206%{_includedir}/ecryptfs.h
207%{_pkgconfigdir}/libecryptfs.pc
208
209%if %{with static_libs}
210%files static
211%defattr(644,root,root,755)
212%{_libdir}/libecryptfs.a
213%endif
214
215%files -n pam-pam_ecryptfs
216%defattr(644,root,root,755)
217%attr(755,root,root) /%{_lib}/security/pam_ecryptfs.so
218%{_mandir}/man8/pam_ecryptfs.8*
219
220%files -n python-ecryptfs
221%defattr(644,root,root,755)
222%dir %{py_sitedir}/%{name}
223%attr(755,root,root) %{py_sitedir}/%{name}/_libecryptfs.so*
224%dir %{py_sitescriptdir}/%{name}
225%{py_sitescriptdir}/%{name}/*.py[co]
This page took 0.0727 seconds and 4 git commands to generate.