]> git.pld-linux.org Git - packages/dtc.git/blobdiff - dtc.spec
- versioned Obsoletes
[packages/dtc.git] / dtc.spec
index e17cee63a12e43b8079d7f22e28fae8a467ed759..85b775011ecf66edeea7c01425f9488e2ec2b20b 100644 (file)
--- a/dtc.spec
+++ b/dtc.spec
@@ -1,23 +1,52 @@
 #
 # Conditional build:
+%bcond_without python          # Python module (any)
+%bcond_without python2         # CPython 2.x module
+%bcond_without python3         # CPython 3.x module
 %bcond_without verbose         # verbose build (V=1)
 
+%if %{without python}
+%undefine      with_python2
+%undefine      with_python3
+%endif
 Summary:       The Device Tree Compiler
 Summary(pl.UTF-8):     Kompilator drzewiastej struktury urządzeń
 Name:          dtc
-Version:       1.3.0
-Release:       2
-License:       GPL v2 (dtc), GPL/BSD (fdt library)
+Version:       1.7.0
+Release:       1
+License:       GPL v2+ (dtc), GPL v2+ or BSD (fdt library)
 Group:         Libraries
-Source0:       http://www.jdl.com/software/%{name}-v%{version}.tgz
-# Source0-md5: 0b94ed452ed3d3b5c1546c27788c416f
-URL:           http://git.jdl.com/gitweb/
+Source0:       https://www.kernel.org/pub/software/utils/dtc/%{name}-%{version}.tar.xz
+# Source0-md5: 228576aceed3aa89f54283aa0f1eb820
+Patch0:                %{name}-python.patch
+Patch1:                python2.patch
+URL:           https://www.devicetree.org/
 BuildRequires: bison
 BuildRequires: flex
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.714
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+BuildRequires: yaml-devel
+%if %{with python}
+%if %{with python2}
+BuildRequires: python-devel >= 2
+BuildRequires: python-setuptools
+BuildRequires: python-setuptools_scm
+%endif
+%if %{with python3}
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+%endif
+BuildRequires: swig-python >= 2.0.10
+%endif
 Requires:      libfdt = %{version}-%{release}
 Obsoletes:     dtc-doc < 1.3.0-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                abi_ver %{version}
+
 %{?debug:%define with_verbose 1}
 
 %description
@@ -36,6 +65,7 @@ inaczej format binarny.
 %package -n libfdt
 Summary:       Device tree library
 Summary(pl.UTF-8):     Biblioteka drzewiastej struktury urządzeń
+License:       GPL v2+ or BSD
 Group:         Libraries
 Obsoletes:     dtc-doc < 1.3.0-2
 # does not require base. see README.license
@@ -49,11 +79,11 @@ Biblioteka drzewiastej struktury urządzeń.
 %package -n libfdt-devel
 Summary:       Header files for fdt library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki fdt
+License:       GPL v2+ or BSD
 Group:         Development/Libraries
 Requires:      libfdt = %{version}-%{release}
-Obsoletes:     dtc-devel
+Obsoletes:     dtc-devel < 1.3.0
 Obsoletes:     dtc-doc < 1.3.0-2
-# does not require base. see README.license
 
 %description -n libfdt-devel
 Header files for fdt library.
@@ -64,9 +94,10 @@ Pliki nagłówkowe biblioteki fdt.
 %package -n libfdt-static
 Summary:       Static fdt library
 Summary(pl.UTF-8):     Statyczna biblioteka fdt
+License:       GPL v2+ or BSD
 Group:         Development/Libraries
 Requires:      libfdt-devel = %{version}-%{release}
-Obsoletes:     dtc-static
+Obsoletes:     dtc-static < 1.3.0
 
 %description -n libfdt-static
 Static fdt library.
@@ -74,22 +105,74 @@ Static fdt library.
 %description -n libfdt-static -l pl.UTF-8
 Statyczna biblioteka fdt.
 
+%package -n python-libfdt
+Summary:       Python 2 binding for fdt library
+Summary(pl.UTF-8):     Wiązanie Pythona 2 do biblioteki fdt
+License:       GPL v2+ or BSD
+Group:         Libraries/Python
+
+%description -n python-libfdt
+Python 2 binding for fdt library.
+
+%description -n python-libfdt -l pl.UTF-8
+Wiązanie Pythona 2 do biblioteki fdt.
+
+%package -n python3-libfdt
+Summary:       Python 3 binding for fdt library
+Summary(pl.UTF-8):     Wiązanie Pythona 3 do biblioteki fdt
+License:       GPL v2+ or BSD
+Group:         Libraries/Python
+
+%description -n python3-libfdt
+Python 3 binding for fdt library.
+
+%description -n python3-libfdt -l pl.UTF-8
+Wiązanie Pythona 3 do biblioteki fdt.
+
 %prep
-%setup -q -n %{name}-v%{version}
+%setup -q
+%patch0 -p1
+%patch1 -p1
 
 %build
-%{__make} \
+%{__make} -j1 \
        %{?with_verbose:V=1} \
        CC="%{__cc}" \
-       CFLAGS="%{rpmcflags} -fPIC"
+       CFLAGS="%{rpmcflags} -fPIC" \
+       NO_PYTHON=1
+
+%if %{with python}
+export SETUPTOOLS_SCM_PRETEND_VERSION=%{version}
+%if %{with python2}
+%py_build
+%endif
+%if %{with python3}
+%py3_build
+%endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
        %{?with_verbose:V=1} \
        PREFIX=%{_prefix} \
-       LIBDIR=%{_libdir}
+       LIBDIR=%{_libdir} \
+       NO_PYTHON=1 \
+       SETUP_PREFIX=%{_prefix}
+
+%if %{with python}
+export SETUPTOOLS_SCM_PRETEND_VERSION=%{version}
+%if %{with python2}
+%py_install
+
+%py_postclean
+%endif
+%if %{with python3}
+%py3_install
+%endif
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -99,15 +182,18 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.license
+%doc README.license README.md
 %attr(755,root,root) %{_bindir}/convert-dtsv0
 %attr(755,root,root) %{_bindir}/dtc
 %attr(755,root,root) %{_bindir}/dtdiff
-%attr(755,root,root) %{_bindir}/ftdump
+%attr(755,root,root) %{_bindir}/fdtdump
+%attr(755,root,root) %{_bindir}/fdtget
+%attr(755,root,root) %{_bindir}/fdtoverlay
+%attr(755,root,root) %{_bindir}/fdtput
 
 %files -n libfdt
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libfdt-%{version}.so
+%attr(755,root,root) %{_libdir}/libfdt-%{abi_ver}.so
 %attr(755,root,root) %ghost %{_libdir}/libfdt.so.1
 
 %files -n libfdt-devel
@@ -116,7 +202,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libfdt.so
 %{_includedir}/fdt.h
 %{_includedir}/libfdt.h
+%{_includedir}/libfdt_env.h
 
 %files -n libfdt-static
 %defattr(644,root,root,755)
 %{_libdir}/libfdt.a
+
+%if %{with python2}
+%files -n python-libfdt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/_libfdt.so
+%{py_sitedir}/libfdt.py[co]
+%{py_sitedir}/libfdt-%{abi_ver}*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-libfdt
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py3_sitedir}/_libfdt.cpython-*.so
+%{py3_sitedir}/libfdt.py
+%{py3_sitedir}/__pycache__/libfdt.cpython-*.py[co]
+%{py3_sitedir}/libfdt-%{abi_ver}*.egg-info
+%endif
This page took 0.109586 seconds and 4 git commands to generate.