]> git.pld-linux.org Git - packages/domoticz.git/blame_incremental - domoticz.spec
suggest python3-libs for python plugin (dynamically loaded libpython3*.so*)
[packages/domoticz.git] / domoticz.spec
... / ...
CommitLineData
1Summary: Open source Home Automation System
2Name: domoticz
3Version: 2021.1
4Release: 1
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
8Source0: https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 28349806fc3ddb0514ea7d9255ceecd0
10Source1: %{name}.service
11Source2: %{name}.conf
12# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
13Patch0: %{name}-tinyxpath.patch
14# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
15Patch1: %{name}-python.patch
16Patch2: no-git.patch
17Patch3: %{name}-gpio.patch
18Patch4: %{name}-no_updates.patch
19BuildRequires: boost-devel >= 1.66.0
20BuildRequires: cereal-devel
21BuildRequires: cmake >= 3.16.0
22BuildRequires: curl-devel
23BuildRequires: jsoncpp-devel
24BuildRequires: libfmt-devel
25BuildRequires: libmosquitto-devel
26BuildRequires: libopenzwave-devel >= 1.5.0
27BuildRequires: libstdc++-devel >= 6:4.9
28BuildRequires: libusb-compat-devel
29BuildRequires: linux-libc-headers
30BuildRequires: lua53-devel
31BuildRequires: minizip-devel
32BuildRequires: openssl-devel
33BuildRequires: pkgconfig
34BuildRequires: python3 >= 1:3.4
35BuildRequires: python3-devel >= 1:3.4
36BuildRequires: rpmbuild(macros) >= 1.644
37BuildRequires: sqlite3-devel
38BuildRequires: tinyxml-devel
39BuildRequires: tinyxpath-devel
40BuildRequires: zlib-devel
41Requires(pre): /usr/sbin/groupadd
42Requires(pre): /usr/sbin/useradd
43Requires(post,preun,postun): systemd-units >= 38
44Requires: fonts-TTF-Google-Droid
45Requires: fonts-TTF-OpenSans
46Requires: libopenzwave >= 1.5.0
47Requires: setup >= 2.10.1
48Suggests: python3-libs
49Provides: group(domoticz)
50Provides: user(domoticz)
51
52%description
53Domoticz is a Home Automation System that lets you monitor and
54configure various devices like: Lights, Switches, various
55sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
56and much more. Notifications/Alerts can be sent to any mobile device
57
58%prep
59%setup -q
60%patch0 -p1
61%patch1 -p1
62%patch2 -p1
63%patch3 -p1
64%patch4 -p1
65
66APPVERSION="%{version}"
67echo "#define APPVERSION ${APPVERSION##*.}" > appversion.h
68echo '#define APPHASH "%{snap}"' >> appversion.h
69APPDATE=$(date --date="%{date}" "+%s")
70echo "#define APPDATE ${APPDATE}" >> appversion.h
71
72%{__rm} -r extern tinyxpath
73
74%build
75install -d build && cd build
76export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
77%cmake \
78 -DUSE_BUILTIN_JSONCPP=NO \
79 -DUSE_BUILTIN_LIBFMT=NO \
80 -DUSE_BUILTIN_MINIZIP=NO \
81 -DUSE_BUILTIN_MQTT=NO \
82 -DUSE_BUILTIN_SQLITE=NO \
83 -DUSE_BUILTIN_TINYXPATH=NO \
84 -DUSE_LUA_STATIC=NO \
85 -DUSE_OPENSSL_STATIC=NO \
86 -DUSE_STATIC_BOOST=NO \
87 -DUSE_STATIC_LIBSTDCXX=NO \
88 -DUSE_STATIC_OPENZWAVE=NO \
89 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
90 ..
91
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} -C build install \
98 DESTDIR=$RPM_BUILD_ROOT
99
100install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/sysconfig,%{systemdunitdir},%{_sharedstatedir}/%{name}}
101
102# remove docs, we grab them in files below
103%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
104
105# move binary to standard directory
106mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}
107
108cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
109cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
110
111# Unbundle DroidSans.ttf
112%{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element{al,-light,-dark}/fonts/{Droid,Open}Sans.ttf
113ln -s %{_fontsdir}/TTF/DroidSans.ttf \
114 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts
115ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
116 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/OpenSans.ttf
117ln -s %{_fontsdir}/TTF/DroidSans.ttf \
118 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts
119ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
120 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/OpenSans.ttf
121ln -s %{_fontsdir}/TTF/DroidSans.ttf \
122 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts
123ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
124 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
125
126# OpenZWave Control Panel temp file
127ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
128 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%pre
134%groupadd -g 342 domoticz
135%useradd -u 342 -r -d %{_datadir} -s /bin/false -c "Domoticz Home Automation Server" -G dialout,i2c -g domoticz domoticz
136
137%post
138%systemd_post %{name}.service
139
140%preun
141%systemd_preun %{name}.service
142
143%postun
144if [ "$1" = "0" ]; then
145 %userremove mpd
146 %groupremove mpd
147fi
148%systemd_reload
149
150%files
151%defattr(644,root,root,755)
152%doc License.txt README.md History.txt
153%attr(755,root,root) %{_bindir}/%{name}
154%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
155%{_datadir}/%{name}
156%dir %attr(750,domoticz,domoticz) %{_sharedstatedir}/%{name}
157%{systemdunitdir}/%{name}.service
This page took 0.082315 seconds and 4 git commands to generate.