]> git.pld-linux.org Git - packages/domoticz.git/blame - domoticz.spec
- up to 4.9700; patches from FC
[packages/domoticz.git] / domoticz.spec
CommitLineData
9dda6696
AM
1Summary: Open source Home Automation System
2Name: domoticz
9ee4483e
AM
3Version: 4.9700
4Release: 1
9dda6696
AM
5License: GPLv3+ and ASL 2.0 and Boost and BSD and MIT
6Group: Base
7URL: http://www.domoticz.com
8Source0: https://github.com/domoticz/domoticz/archive/%{version}.tar.gz
9ee4483e 9# Source0-md5: 726d838d5d80eed4335b0dfeefb2af6c
9dda6696
AM
10Source1: %{name}.service
11Source2: %{name}.conf
12# Source says its version 3.5876, but it's really 3.8153
13Patch1: %{name}-version.patch
14# Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
15Patch2: %{name}-tinyxpath.patch
16# Use system openzwave includes
17Patch3: %{name}-openzwave.patch
18# Work against Dev branch of OpenZWave upstream
19Patch4: %{name}-openzwave-Dev.patch
20# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
21Patch5: %{name}-python.patch
9ee4483e
AM
22Patch6: domoticz-ozw-barrier-support-0002.patch
23Patch7: domoticz-cp-js.patch
9dda6696
AM
24BuildRequires: boost-devel
25BuildRequires: cmake
26BuildRequires: curl-devel
27BuildRequires: libmosquitto-devel
28BuildRequires: libmosquittopp-devel
29BuildRequires: libopenzwave-devel >= 1.5.0
30BuildRequires: libstdc++-devel
31BuildRequires: libusb-devel
32BuildRequires: lua-devel
33BuildRequires: openssl-devel
34BuildRequires: python3-devel
35BuildRequires: sqlite-devel
36BuildRequires: systemd-devel
37BuildRequires: tinyxpath-devel
38BuildRequires: zlib-devel
06cb1c68
AM
39Requires(pre): /usr/sbin/groupadd
40Requires(pre): /usr/sbin/useradd
9dda6696
AM
41Requires(post): systemd
42Requires(postun): systemd
43Requires(preun): systemd
06cb1c68 44Requires: fonts-TTF-Google-Droid
9dda6696
AM
45Provides: bundled(js-ace)
46Provides: bundled(js-angular-ui-bootstrap) = 0.13.4
47Provides: bundled(js-angularamd) = 0.2.1
48Provides: bundled(js-angularjs) = 1.5.8
49Provides: bundled(js-blockly)
50Provides: bundled(js-bootbox)
51Provides: bundled(js-bootstrap) = 3.2.0
52Provides: bundled(js-colpick)
53Provides: bundled(js-d3)
54Provides: bundled(js-datatables-datatools) = 2.2.3
55Provides: bundled(js-dateformat) = 1.2.3
56Provides: bundled(js-filesaver) = 0.0-git20140725
57Provides: bundled(js-highcharts) = 4.2.6
58Provides: bundled(js-html5shiv) = 3.6.2
59Provides: bundled(js-i18next) = 1.8.0
60Provides: bundled(js-ion-sound) = 3.0.6
61Provides: bundled(js-jquery) = 1.12.0
62Provides: bundled(js-jquery-noty) = 2.1.0
63Provides: bundled(js-less) = 1.3.0
64Provides: bundled(js-ngdraggable)
65Provides: bundled(js-nggrid)
66Provides: bundled(js-ozwcp)
67Provides: bundled(js-require) = 2.1.14
68Provides: bundled(js-respond) = 1.1.0
69Provides: bundled(js-wow) = 0.1.9
70Provides: bundled(js-zeroclipboard) = 1.0.4
71
72%description
73Domoticz is a Home Automation System that lets you monitor and
74configure various devices like: Lights, Switches, various
75sensors/meters like Temperature, Rain, Wind, UV, Electra, Gas, Water
76and much more. Notifications/Alerts can be sent to any mobile device
77
78%prep
79%setup -q
80%patch1 -p1 -b.version
81%patch2 -p1 -b.tinyxpath
82%patch3 -p1 -b.openzwave
83%patch4 -p1 -b.openzwave-Dev
84%patch5 -p1 -b.python
9ee4483e
AM
85%patch6 -p1
86%patch7 -p1
9dda6696
AM
87rm -f hardware/openzwave/*.h
88rm -rf hardware/openzwave/aes
89rm -rf hardware/openzwave/command_classes
90rm -rf hardware/openzwave/platform
91rm -rf hardware/openzwave/value_classes
92rm -rf sqlite/
93rm -rf tinyxpath/
94
95%build
96install -d build && cd build
97%cmake \
98 -DUSE_STATIC_LIBSTDCXX=NO \
99 -DUSE_STATIC_OPENZWAVE=NO \
100 -DUSE_BUILTIN_LUA=NO \
101 -DUSE_BUILTIN_MQTT=NO \
102 -DUSE_BUILTIN_SQLITE=NO \
103 -DUSE_BUILTIN_TINYXPATH=NO \
104 -DUSE_STATIC_BOOST=NO \
105 -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
106 ..
00bce45c 107
9dda6696
AM
108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
00bce45c
AM
112%{__make} -C build install \
113 DESTDIR=$RPM_BUILD_ROOT
9dda6696
AM
114
115# remove docs, we grab them in files below
116rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/*.txt
117
118# move binary to standard directory
119install -d $RPM_BUILD_ROOT%{_bindir}/
120mv $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/
121
122# install systemd service and config
123install -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
124install -d $RPM_BUILD_ROOT%{systemdunitdir}/
125cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/
126cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
127
128# create database/ssl cert directory
129install -d $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}/
130
131# Disable the app's self-update script
132
133# Unbundle DroidSans.ttf
134rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/DroidSans.ttf
06cb1c68 135ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
136 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/elemental/fonts/
137rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/DroidSans.ttf
06cb1c68 138ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
139 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-light/fonts/
140rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/DroidSans.ttf
06cb1c68 141ln -s /usr/share/fonts/TTF/DroidSans.ttf \
9dda6696
AM
142 $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/
143
144# OpenZWave Control Panel temp file
145ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
146 $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%pre
152getent group domoticz >/dev/null || groupadd -r domoticz
153getent passwd domoticz >/dev/null || \
154useradd -r -g domoticz -d %{_datadir}/%{name} -s /sbin/nologin \
155-c "Domoticz Home Automation Server" domoticz
156# For OpenZWave USB access (/dev/ttyACM#)
157usermod -G domoticz,dialout domoticz
158
159%post
160%systemd_post %{name}.service
161
162%preun
163%systemd_preun %{name}.service
164
165%postun
166%systemd_postun_with_restart %{name}.service
167
168%files
169%defattr(644,root,root,755)
170%doc License.txt
171%doc README.md History.txt
172%attr(755,root,root) %{_bindir}/%{name}
173%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
174%{_datadir}/%{name}/
175%attr(755,domoticz,domoticz) %{_sharedstatedir}/%{name}/
176%{systemdunitdir}/%{name}.service
This page took 0.043886 seconds and 4 git commands to generate.