]> git.pld-linux.org Git - packages/dislocker.git/blame - dislocker.spec
- release 4 (mbedtls 3.4)
[packages/dislocker.git] / dislocker.spec
CommitLineData
b805eade
JB
1#
2# Conditional build:
3%bcond_without ruby # Ruby binding in library, dislocker-find utility
4
5Summary: Read BitLocker encrypted volumes under Linux
6Summary(pl.UTF-8): Odczyt wolumenów szyfrowanych BitLockerem spod Linuksa
7Name: dislocker
688de21e 8Version: 0.7.3
faa36a5e 9Release: 4
b805eade
JB
10License: GPL v2+
11Group: Applications/File
faa36a5e 12#Source0Download: https://github.com/Aorimn/dislocker/tags
b805eade 13Source0: https://github.com/Aorimn/dislocker/archive/v%{version}/%{name}-%{version}.tar.gz
688de21e 14# Source0-md5: ff1a5a0120cedf04c6146da91dfbd27c
1110c435 15Patch0: mbedtls.patch
b805eade
JB
16URL: https://github.com/Aorimn/dislocker
17BuildRequires: cmake >= 2.6
18BuildRequires: libfuse-devel
19BuildRequires: mbedtls-devel
20%{?with_ruby:BuildRequires: ruby-devel >= 1:1.8}
21BuildRequires: rpmbuild(macros) >= 1.605
22BuildRequires: sed >= 4.0
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This software has been designed to read BitLocker encrypted partitions
27under a Linux system. The driver has the capability to read/write on:
28- Windows Vista, 7, 8, 8.1 and 10 encrypted partitions - that's
29 AES-CBC, AES-XTS, 128 or 256 bits, with or without the Elephant
30 diffuser, encrypted partitions;
31- BitLocker-To-Go encrypted partitions - that's USB/FAT32 partitions.
32
33%description -l pl.UTF-8
34To oprogramowanie powstało w celu odczytu spod systemu Linux partycji
35zaszyfrowanych BitLockerem. Sterownik potrafi czytać i zapisywać na
36partycjach szyfrowanych:
37- Windows Vista, 7, 8, 8.1 oraz 10 - czyli AES-CBC, AES-XTS, 128 lub 256
38 bitów, z lub bez dyfuzora Elephant
39- BitLocker-To-Go, czyli USB/FAT32
40
41%package fuse
42Summary: Read/write BitLocker encrypted volumes under Linux
43Summary(pl.UTF-8): Odczyt/zapis wolumenów szyfrowanych BitLockerem spod Linuksa
44Group: Applications/File
45Requires: %{name} = %{version}-%{release}
46
47%description fuse
48FUSE driver to mount BitLocker volume and create a virtual NTFS
49partition, which can be mounted as any other NTFS partition.
50
51%description fuse -l pl.UTF-8
52Sterownik FUSE do montowania wolumenów BitLockera i tworzenia
53wirtualnych partycji NTFS, które można zamontować tak, jak inne
54partycje NTFS.
55
56%prep
57%setup -q
1110c435 58%patch0 -p1
b805eade
JB
59
60%{__sed} -i -e '1s,/usr/bin/env ruby,/usr/bin/ruby,' src/dislocker-find.rb.in
61
62%build
63install -d build
64cd build
65%cmake .. \
bb2d534e 66 -DLIB_INSTALL_DIR=%{_libdir} \
b805eade
JB
67 %{!?with_ruby:-DRUBY_OLD_VERSION=ON}
68
69%{__make}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%{__make} -C build install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77# workaround race during recompression/symlink conversion
78%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dislocker.1.gz
79echo '.so dislocker-fuse.1' > $RPM_BUILD_ROOT%{_mandir}/man1/dislocker.1
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85%postun -p /sbin/ldconfig
86
87%files
88%defattr(644,root,root,755)
89%doc CHANGELOG.md README.md
90%attr(755,root,root) %{_bindir}/dislocker-bek
91%attr(755,root,root) %{_bindir}/dislocker-file
92%attr(755,root,root) %{_bindir}/dislocker-metadata
93%attr(755,root,root) %{_libdir}/libdislocker.so.*.*.*
94%attr(755,root,root) %ghost %{_libdir}/libdislocker.so.0.7
95# symlink required for ruby
96%attr(755,root,root) %{_libdir}/libdislocker.so
97%{_mandir}/man1/dislocker-file.1*
98%if %{with ruby}
99%attr(755,root,root) %{_bindir}/dislocker-find
100%{_mandir}/man1/dislocker-find.1*
101%endif
102
103%files fuse
104%defattr(644,root,root,755)
105%attr(755,root,root) %{_bindir}/dislocker
106%attr(755,root,root) %{_bindir}/dislocker-fuse
107%{_mandir}/man1/dislocker.1*
108%{_mandir}/man1/dislocker-fuse.1*
This page took 0.300584 seconds and 4 git commands to generate.