]> git.pld-linux.org Git - packages/deltarpm.git/blame_incremental - deltarpm.spec
- updated to 3.6.3
[packages/deltarpm.git] / deltarpm.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without python3 # CPython3 module
4%bcond_with rpm5 # build with rpm5
5#
6Summary: Create deltas between rpms
7Summary(pl.UTF-8): Generowanie różnic między pakietami rpm
8Name: deltarpm
9Version: 3.6.3
10Release: 1
11License: BSD
12Group: Base
13#Source0Download: https://github.com/rpm-software-management/deltarpm/tags
14Source0: https://github.com/rpm-software-management/deltarpm/archive/%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: 8788682eaa329e467f00f096ced03051
16Patch0: %{name}-3.4-no-skip-doc.patch
17Patch1: %{name}-3.4-pld.patch
18Patch2: %{name}-rpm5.patch
19Patch3: python-install.patch
20URL: https://github.com/rpm-software-management/deltarpm
21BuildRequires: bzip2-devel
22BuildRequires: popt-devel
23BuildRequires: python-devel >= 2
24%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
25BuildRequires: rpm-devel
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.507
28BuildRequires: xz-devel
29BuildRequires: zlib-static
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33A deltarpm contains the difference between an old and a new version of
34a rpm, which makes it possible to recreate the new rpm from the
35deltarpm and the old one. You don't have to have a copy of the old
36rpm, deltarpms can also work with installed rpms.
37
38%description -l pl.UTF-8
39Deltarpm zawiera różnice pomiędzy starą i nową wersją pakietu RPM,
40pozwalając na stworzenie nowej wersji na podstawie delty i starej
41wersji. Nie jest konieczne posiadanie kopii starego pakietu RPM,
42deltarpm obsługuje także już zainstalowane pakiety.
43
44%package -n drpmsync
45Summary: Sync a file tree with deltarpms
46Summary(pl.UTF-8): Synchronizacja drzewa plików deltarpm
47Group: Base
48Requires: %{name} = %{version}-%{release}
49Suggests: deltaiso
50
51%description -n drpmsync
52This package contains a tool to sync a file tree with deltarpms.
53
54%description -n drpmsync -l pl.UTF-8
55Ten pakiet zawiera narzędzie do synchronizacji drzewa plików deltarpm.
56
57%package -n deltaiso
58Summary: Create deltas between isos containing rpms
59Summary(pl.UTF-8): Tworzenie różnic między obrazami ISO zawierającymi pakiety RPM
60Group: Base
61Requires: %{name} = %{version}-%{release}
62
63%description -n deltaiso
64This package contains tools for creating and using deltaisos, a
65difference between an old and a new iso containing rpms.
66
67%description -n deltaiso -l pl.UTF-8
68Ten pakiet zawiera narzędzia do tworzenia i wykorzystywania plików
69deltaiso - różnic między starymi a nowymi obrazami ISO zawierającymi
70pakiety RPM.
71
72%package -n python-deltarpm
73Summary: Python 2 bindings for deltarpm
74Summary(pl.UTF-8): Wiązania Pythona 2 do deltarpm
75Group: Libraries/Python
76# does not require base package
77
78%description -n python-deltarpm
79This package contains Python 2 bindings for deltarpm.
80
81%description -n python-deltarpm -l pl.UTF-8
82Ten pakiet zawiera wiązania Pythona 2 do deltarpm.
83
84%package -n python3-deltarpm
85Summary: Python 3 bindings for deltarpm
86Summary(pl.UTF-8): Wiązania Pythona 3 do deltarpm
87Group: Libraries/Python
88# does not require base package
89
90%description -n python3-deltarpm
91This package contains Python 3 bindings for deltarpm.
92
93%description -n python3-deltarpm -l pl.UTF-8
94Ten pakiet zawiera wiązania Pythona 3 do deltarpm.
95
96%prep
97%setup -q
98%patch0 -p1
99%patch1 -p1
100%{?with_rpm5:%patch2 -p1}
101%patch3 -p1
102
103%if %{without python3}
104%{__sed} -i -e 's/python3//' Makefile
105%endif
106
107%build
108%{__make} \
109 CC="%{__cc}" \
110 CFLAGS="%{rpmcflags} -I/usr/include/rpm -D_GNU_SOURCE" \
111 bindir=%{_bindir} \
112 libdir=%{_libdir} \
113 mandir=%{_mandir} \
114 prefix=%{_prefix} \
115 zlibbundled='' \
116 zlibldflags='-lz' \
117 zlibcppflags=''
118
119%{__make} python \
120 CC="%{__cc}" \
121 CFLAGS="%{rpmcflags}" \
122 bindir=%{_bindir} \
123 libdir=%{_libdir} \
124 mandir=%{_mandir} \
125 prefix=%{_prefix} \
126 zlibbundled='' \
127 zlibldflags='-lz' \
128 zlibcppflags=''
129
130%install
131rm -rf $RPM_BUILD_ROOT
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
136%py_comp $RPM_BUILD_ROOT%{py_sitedir}
137%py_postclean
138%if %{with python3}
139%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
140%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
141%endif
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(644,root,root,755)
148%doc LICENSE.BSD README
149%attr(755,root,root) %{_bindir}/applydeltarpm
150%attr(755,root,root) %{_bindir}/combinedeltarpm
151%attr(755,root,root) %{_bindir}/makedeltarpm
152%attr(755,root,root) %{_bindir}/rpmdumpheader
153%{_mandir}/man8/applydeltarpm.8*
154%{_mandir}/man8/combinedeltarpm.8*
155%{_mandir}/man8/makedeltarpm.8*
156
157%files -n deltaiso
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/applydeltaiso
160%attr(755,root,root) %{_bindir}/fragiso
161%attr(755,root,root) %{_bindir}/makedeltaiso
162%{_mandir}/man8/applydeltaiso.8*
163%{_mandir}/man8/fragiso.8*
164%{_mandir}/man8/makedeltaiso.8*
165
166%files -n drpmsync
167%defattr(644,root,root,755)
168%attr(755,root,root) %{_bindir}/drpmsync
169%{_mandir}/man8/drpmsync.8*
170
171%files -n python-deltarpm
172%defattr(644,root,root,755)
173%attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
174%{py_sitedir}/deltarpm.py[co]
175
176%if %{with python3}
177%files -n python3-deltarpm
178%defattr(644,root,root,755)
179%attr(755,root,root) %{py3_sitedir}/_deltarpmmodule.so
180%{py3_sitedir}/deltarpm.py
181%{py3_sitedir}/__pycache__/deltarpm.cpython-*.py[co]
182%endif
This page took 0.082757 seconds and 4 git commands to generate.