]> git.pld-linux.org Git - packages/cups.git/blobdiff - cups.spec
- up to 2.2.5
[packages/cups.git] / cups.spec
index b88da0d588770b507303245326a643a98d24f3e4..e4bded5c7400b4c1e549a6b7871059ca8d59b76a 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -3,20 +3,22 @@
 %bcond_without gnutls          # use GNU TLS for SSL/TLS support
 %bcond_with    dnssd           # DNS Service Discovery support via dns_sd API (obsoleted by Avahi patch)
 %bcond_without avahi           # DNS Service Discovery support via Avahi
-%bcond_without gssapi          # do not include GSSAPI support
-%bcond_without python          # don't build Python support in web interface
-%bcond_without static_libs     # don't build static library
+%bcond_without gssapi          # GSSAPI support
+%bcond_with    lspp            # audit and SELinux label support (lspp patch)
+%bcond_with    tcp_wrappers    # tcp_wrappers/libwrap support
+%bcond_without python          # Python support in web interface
+%bcond_without static_libs     # static library
 
 Summary(pl.UTF-8):     Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
-Version:       2.1.4
+Version:       2.2.5
 Release:       1
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest)
 Group:         Applications/Printing
-Source0:       https://github.com/apple/cups/archive/release-%{version}.tar.gz
-# Source0-md5: 5a9b778799f3d43f8be9c3b7ac69d012
+Source0:       https://github.com/apple/cups/releases/download/v%{version}/%{name}-%{version}-source.tar.gz
+# Source0-md5: 76294dff74c3baf3fdf7c626cd48b873
 Source1:       %{name}.init
 Source2:       %{name}.pamd
 Source3:       %{name}.logrotate
@@ -43,8 +45,25 @@ Patch18:     %{name}-final-content-type.patch
 # avahi patches from fedora
 Patch100:      %{name}-avahi-address.patch
 Patch101:      %{name}-avahi-no-threaded.patch
+Patch102:      cups-banners.patch
+Patch103:      cups-pid.patch
+Patch104:      cups-eggcups.patch
+Patch105:      cups-driverd-timeout.patch
+Patch106:      cups-logrotate.patch
+Patch107:      cups-res_init.patch
+Patch108:      cups-filter-debug.patch
+Patch109:      cups-hp-deviceid-oid.patch
+Patch110:      cups-dnssd-deviceid.patch
+Patch111:      cups-ricoh-deviceid-oid.patch
+
+Patch113:      cups-dymo-deviceid.patch
+Patch114:      cups-freebind.patch
+Patch115:      cups-ipp-multifile.patch
+Patch116:      cups-web-devices-timeout.patch
+Patch117:      cups-lspp.patch
 URL:           http://www.cups.org/
 BuildRequires: acl-devel
+%{?with_lspp:BuildRequires:    audit-libs-devel}
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 %{?with_dnssd:BuildRequires:   avahi-compat-libdns_sd-devel}
@@ -54,8 +73,10 @@ BuildRequires:       glibc-headers
 %{?with_gnutls:BuildRequires:  gnutls-devel}
 %{?with_gssapi:BuildRequires:  heimdal-devel}
 BuildRequires: libpaper-devel
+%{?with_lspp:BuildRequires:    libselinux-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: libusb-devel >= 1.0
+%{?with_tcp_wrappers:BuildRequires:    libwrap-devel}
 BuildRequires: pam-devel
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.641
@@ -232,7 +253,7 @@ LPD compatibility support for CUPS print server.
 Wsparcie dla LPD w serwerze wydruków CUPS.
 
 %prep
-%setup -q -n %{name}-release-%{version}
+%setup -q
 %patch0 -p1
 %patch2 -p1
 %patch3 -p1
@@ -257,6 +278,23 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 %patch101 -p1
 %endif
 
+%patch102 -p1
+%patch103 -p1
+%patch104 -p1
+%patch105 -p1
+%patch106 -p1
+%patch107 -p1
+%patch108 -p1
+%patch109 -p1
+%patch110 -p1
+%patch111 -p1
+
+%patch113 -p1
+%patch114 -p1
+%patch115 -p1
+%patch116 -p1
+%patch117 -p1
+
 %build
 %{__aclocal} -I config-scripts
 %{__autoconf}
@@ -272,9 +310,11 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
        --enable-gssapi%{!?with_gssapi:=no} \
        --enable-libpaper \
        --enable-libusb \
+       %{?with_lspp:--enable-lspp} \
        --enable-shared \
        --enable-ssl \
        %{?with_static_libs:--enable-static} \
+       %{?with_tcp_wrappers:--enable-tcp-wrappers} \
        --with-cups-group=lp \
        --with-cups-user=lp \
        --with-system-groups=sys \
@@ -316,7 +356,7 @@ ln -s %{_ulibdir}/cups/backend/dnssd $RPM_BUILD_ROOT%{_ulibdir}/cups/backend/mdn
 %endif
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/%{name}
+cp -pf %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/%{name}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/cups/mailto.conf
 sed -e 's|__ULIBDIR__|%{_ulibdir}|g' %{SOURCE5} > $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/cups-lpd
@@ -415,7 +455,6 @@ fi
 %attr(600,root,lp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/snmp.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.cups
 %dir %attr(700,root,lp) %{_sysconfdir}/%{name}/ssl
-%dir %{_sysconfdir}/%{name}/interfaces
 %dir %attr(755,root,lp) %{_sysconfdir}/%{name}/ppd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 %attr(755,root,root) %{_bindir}/cupstestppd
@@ -508,6 +547,7 @@ fi
 %{_datadir}/cups/templates/*.tmpl
 %lang(de) %{_datadir}/cups/templates/de
 %lang(es) %{_datadir}/cups/templates/es
+%lang(fr) %{_datadir}/cups/templates/fr
 %lang(ja) %{_datadir}/cups/templates/ja
 %lang(pt_BR) %{_datadir}/cups/templates/pt_BR
 %lang(ru) %{_datadir}/cups/templates/ru
@@ -572,6 +612,7 @@ fi
 %lang(ja) %{_localedir}/ja/cups_ja.po
 %lang(pt_BR) %{_localedir}/pt_BR/cups_pt_BR.po
 %lang(ru) %{_localedir}/ru/cups_ru.po
+%lang(zh_CN) %{_localedir}/zh_CN/cups_zh_CN.po
 
 %files clients
 %defattr(644,root,root,755)
This page took 0.110177 seconds and 4 git commands to generate.