]> git.pld-linux.org Git - packages/cups.git/blobdiff - cups.spec
- fix empty output of lpstat if LANG=pl; part of 10321 in cups cvn
[packages/cups.git] / cups.spec
index 35314b95a2abefbcc85418e0eebfc8b8529325d3..7e859375c6135d828b63ca7f60e0adef91d978b4 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -1,7 +1,8 @@
 #
 # Conditional build:
 %bcond_with    gnutls          # use GNU TLS for SSL/TLS support (instead of OpenSSL)
-%bcond_without dnssd           # DNS Service Discovery support
+%bcond_with    dnssd           # DNS Service Discovery support (obsoleted by Avahi patch)
+%bcond_without avahi           # DNS Service Discovery support via Avahi
 %bcond_without ldap            # do not include LDAP support
 %bcond_without gssapi          # do not include GSSAPI support
 %bcond_without php             # don't build PHP extension/support in web interface
 %bcond_without python          # don't build Python support in web interface
 %bcond_without slp             # do not include SLP support
 %bcond_without static_libs     # don't build static library
-#
-%include       /usr/lib/rpm/macros.perl
-%define                pdir CUPS
 
+%define                pdir CUPS
+%include       /usr/lib/rpm/macros.perl
 Summary(pl.UTF-8):     Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
-Version:       1.5.0
+Version:       1.5.2
 Release:       5
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest) + openssl exception
 Group:         Applications/Printing
 Source0:       http://ftp.easysw.com/pub/cups/%{version}/%{name}-%{version}-source.tar.bz2
-# Source0-md5: e54ed09ede2340fc3014913333520fe4
+# Source0-md5: 9471d2a7c920cfbb17133c32d2e6866f
 Source1:       %{name}.init
 Source2:       %{name}.pamd
 Source3:       %{name}.logrotate
 Source4:       %{name}.mailto.conf
 Source5:       %{name}-lpd.inetd
 Source6:       %{name}-modprobe.conf
+Source7:       %{name}.tmpfiles
 # svn diff http://svn.easysw.com/public/cups/tags/release-1.4.3/ http://svn.easysw.com/public/cups/branches/branch-1.4/ > cups-branch.diff
 # + drop config-scripts/cups-common.m4 change
 Patch0:                %{name}-config.patch
@@ -42,13 +43,22 @@ Patch9:             %{name}-verbose-compilation.patch
 Patch10:       %{name}-peercred.patch
 Patch11:       %{name}-usb.patch
 Patch12:       %{name}-desktop.patch
-Patch13:       %{name}-ssl-segfault.patch
-Patch14:       %{name}-auth.patch
+Patch13:       %{name}-systemd-socket.patch
+# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638521
+Patch14:       ipp-revert-1.4.patch
+Patch15:       %{name}-locale.patch
+# avahi patches from fedora
+Patch100:      %{name}-avahi-1-config.patch
+Patch101:      %{name}-avahi-2-backend.patch
+Patch102:      %{name}-avahi-3-timeouts.patch
+Patch103:      %{name}-avahi-4-poll.patch
+Patch104:      %{name}-avahi-5-services.patch
 URL:           http://www.cups.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
-%{?with_dnssd:BuildRequires:   avahi-compat-libdns_sd-devel}
+%{?with_dnssd:BuildRequires:    avahi-compat-libdns_sd-devel}
+%{?with_avahi:BuildRequires: avahi-devel}
 BuildRequires: dbus-devel
 BuildRequires: glibc-headers
 %{?with_gnutls:BuildRequires:  gnutls-devel}
@@ -67,13 +77,16 @@ BuildRequires:      pam-devel
 %{?with_php:BuildRequires:     php-devel >= 4:5.0.0}
 BuildRequires: pkgconfig
 BuildRequires: rpm-perlprov
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 1.641
+BuildRequires: systemd-devel
 Requires(post,preun):  /sbin/chkconfig
+Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      openssl-tools
 Requires:      pam >= 0.77.3
 Requires:      perl-modules
 Requires:      rc-scripts
+Requires:      systemd-units >= 38
 Suggests:      ImageMagick-coder-pdf
 Suggests:      cups-filter-pstoraster
 Suggests:      ghostscript-cups
@@ -313,8 +326,17 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 # why it hasn't been merged for so long (and why no other distro uses it)
 #%patch11 -p1
 %patch12 -p1
-%patch13 -p0
-%patch14 -p0
+%patch13 -p1
+%patch14 -p1
+%patch15 -p0
+
+%if %{with avahi}
+%patch100 -p1
+%patch101 -p1
+%patch102 -p1
+%patch103 -p1
+%patch104 -p1
+%endif
 
 %build
 %{__aclocal} -I config-scripts
@@ -332,6 +354,7 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
        --enable-shared \
        --enable-ssl \
        %{?debug:--enable-debug} \
+       --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi \
        --%{!?with_dnssd:dis}%{?with_dnssd:en}able-dnssd \
        --%{!?with_ldap:dis}%{?with_ldap:en}able-ldap \
        --%{!?with_gssapi:dis}%{?with_gssapi:en}able-gssapi \
@@ -352,7 +375,8 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
        %{?with_dnssd:--with-dnssd-includes=x} \
        %{?with_perl:--with-perl=%{_bindir}/perl} \
        %{?with_php:--with-php=%{_bindir}/php} \
-       %{?with_python:--with-python=%{_bindir}/python}
+       %{?with_python:--with-python=%{_bindir}/python} \
+       --with-systemdsystemunitdir=%{systemdunitdir}
 
 %{__make} %{?debug:OPTIONS="-DDEBUG"}
 
@@ -376,7 +400,8 @@ cd ../..
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,logrotate.d,modprobe.d,security,sysconfig/rc-inetd} \
        $RPM_BUILD_ROOT/var/run/cups \
-       $RPM_BUILD_ROOT/var/log/{,archive/}cups
+       $RPM_BUILD_ROOT/var/log/{,archive/}cups \
+       $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
 
 %{__make} install \
        BUILDROOT=$RPM_BUILD_ROOT \
@@ -406,12 +431,13 @@ EOF
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
-install %{SOURCE1}     $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2}     $RPM_BUILD_ROOT/etc/pam.d/%{name}
-install %{SOURCE3}     $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/%{name}
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/cups/mailto.conf
 sed -e 's|__ULIBDIR__|%{_ulibdir}|g' %{SOURCE5} > $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/cups-lpd
-install %{SOURCE6}     $RPM_BUILD_ROOT/etc/modprobe.d/cups.conf
+install %{SOURCE6} $RPM_BUILD_ROOT/etc/modprobe.d/cups.conf
+install %{SOURCE7} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 touch $RPM_BUILD_ROOT/var/log/cups/{access_log,error_log,page_log}
 touch $RPM_BUILD_ROOT/etc/security/blacklist.cups
@@ -449,12 +475,20 @@ rm -rf $RPM_BUILD_ROOT
 /sbin/chkconfig --add cups
 %service cups restart "cups daemon"
 /sbin/rmmod usblp > /dev/null 2>&1 || :
+%systemd_post cups.service cups.socket cups.path
 
 %preun
 if [ "$1" = "0" ]; then
        %service cups stop
        /sbin/chkconfig --del cups
 fi
+%systemd_preun cups.service cups.socket cups.path
+
+%postun
+%systemd_reload
+
+%triggerpostun -- cups < 1.5.2-1
+%systemd_trigger cups.service cups.socket cups.path
 
 %post  lib -p /sbin/ldconfig
 %postun        lib -p /sbin/ldconfig
@@ -484,6 +518,10 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/cups
 /etc/dbus-1/system.d/cups.conf
 /etc/modprobe.d/cups.conf
+%{systemdunitdir}/cups.service
+%{systemdunitdir}/cups.socket
+%{systemdunitdir}/cups.path
+%{systemdtmpfilesdir}/%{name}.conf
 %attr(600,root,lp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/classes.conf
 %attr(640,root,lp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/cupsd.conf
 %attr(600,root,lp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/printers.conf
@@ -513,16 +551,23 @@ fi
 %lang(de) %{_ulibdir}/cups/cgi-bin/de
 %lang(es) %{_ulibdir}/cups/cgi-bin/es
 %lang(eu) %{_ulibdir}/cups/cgi-bin/eu
+%lang(fr) %{_ulibdir}/cups/cgi-bin/fr
+%lang(hu) %{_ulibdir}/cups/cgi-bin/hu
 %lang(id) %{_ulibdir}/cups/cgi-bin/id
 %lang(it) %{_ulibdir}/cups/cgi-bin/it
 %lang(ja) %{_ulibdir}/cups/cgi-bin/ja
 %lang(pl) %{_ulibdir}/cups/cgi-bin/pl
 %lang(ru) %{_ulibdir}/cups/cgi-bin/ru
 
-%exclude %{_ulibdir}/cups/backend/usb
-%exclude %{_ulibdir}/cups/backend/serial
-%exclude %{_ulibdir}/cups/backend/parallel
-%attr(755,root,root) %{_ulibdir}/cups/backend/*
+%attr(755,root,root) %{_ulibdir}/cups/backend/dnssd
+%attr(755,root,root) %{_ulibdir}/cups/backend/http
+%attr(755,root,root) %{_ulibdir}/cups/backend/https
+%attr(755,root,root) %{_ulibdir}/cups/backend/ipp
+%attr(755,root,root) %{_ulibdir}/cups/backend/ipps
+%attr(755,root,root) %{_ulibdir}/cups/backend/lpd
+%attr(755,root,root) %{_ulibdir}/cups/backend/mdns
+%attr(755,root,root) %{_ulibdir}/cups/backend/snmp
+%attr(755,root,root) %{_ulibdir}/cups/backend/socket
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-deviced
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-driverd
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-exec
@@ -556,6 +601,8 @@ fi
 %lang(de) %{_datadir}/cups/templates/de
 %lang(es) %{_datadir}/cups/templates/es
 %lang(eu) %{_datadir}/cups/templates/eu
+%lang(fr) %{_datadir}/cups/templates/fr
+%lang(hu) %{_datadir}/cups/templates/hu
 %lang(id) %{_datadir}/cups/templates/id
 %lang(it) %{_datadir}/cups/templates/it
 %lang(ja) %{_datadir}/cups/templates/ja
@@ -611,6 +658,7 @@ fi
 %lang(eu) %{_datadir}/locale/eu/cups_eu.po
 %lang(fi) %{_datadir}/locale/fi/cups_fi.po
 %lang(fr) %{_datadir}/locale/fr/cups_fr.po
+%lang(hu) %{_datadir}/locale/hu/cups_hu.po
 %lang(id) %{_datadir}/locale/id/cups_id.po
 %lang(it) %{_datadir}/locale/it/cups_it.po
 %lang(ko) %{_datadir}/locale/ko/cups_ko.po
This page took 0.123006 seconds and 4 git commands to generate.