]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blame_incremental - crossmingw32-fontconfig.spec
- disable debug packages
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
... / ...
CommitLineData
1%define realname fontconfig
2Summary: Font configuration and customization tools - cross MinGW32 version
3Summary(pl.UTF-8): Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
4Name: crossmingw32-%{realname}
5Version: 2.14.0
6Release: 1
7License: MIT
8Group: Development/Libraries
9Source0: https://www.freedesktop.org/software/fontconfig/release/%{realname}-%{version}.tar.xz
10# Source0-md5: e12700a9d522bdfec06b6b7e72646987
11Patch0: %{realname}-bitstream-cyberbit.patch
12URL: http://fontconfig.org/
13BuildRequires: autoconf >= 2.61
14BuildRequires: automake >= 1:1.11
15BuildRequires: crossmingw32-expat
16BuildRequires: crossmingw32-freetype >= 2.8.1
17BuildRequires: crossmingw32-gcc
18BuildRequires: gettext-tools >= 0.19.8
19BuildRequires: libtool >= 2:2.2
20BuildRequires: pkgconfig >= 1:0.15
21BuildRequires: sed >= 4.0
22Requires: crossmingw32-expat
23Requires: crossmingw32-freetype >= 2.8.1
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define no_install_post_strip 1
27%define _enable_debug_packages 0
28
29%define target i386-mingw32
30%define target_platform i386-pc-mingw32
31
32%define _sysprefix /usr
33%define _prefix %{_sysprefix}/%{target}
34%define _libdir %{_prefix}/lib
35%define _pkgconfigdir %{_prefix}/lib/pkgconfig
36%define _dlldir /usr/share/wine/windows/system
37%define __cc %{target}-gcc
38%define __cxx %{target}-g++
39%define __pkgconfig_provides %{nil}
40%define __pkgconfig_requires %{nil}
41
42%ifnarch %{ix86}
43# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
44%define optflags -O2
45%endif
46# -z options are invalid for mingw linker, most of -f options are Linux-specific
47%define filterout_ld -Wl,-z,.*
48%define filterout_c -f[-a-z0-9=]*
49
50%description
51Fontconfig is designed to locate fonts within the system and select
52them according to requirements specified by applications.
53
54This package contains the cross version for Win32.
55
56%description -l pl.UTF-8
57Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
58systemie i wybierania ich w zależności od potrzeb aplikacji.
59
60Paket ten zawiera wersję skrośną dla Win32.
61
62%package static
63Summary: Static freetype library (cross MinGW32 version)
64Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67
68%description static
69Static freetype library (cross MinGW32 version).
70
71%description static -l pl.UTF-8
72Statyczna biblioteka freetype (wersja skrośna MinGW32).
73
74%package dll
75Summary: DLL freetype library for Windows
76Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
77Group: Applications/Emulators
78Requires: crossmingw32-expat-dll
79Requires: crossmingw32-freetype-dll >= 2.8.1
80Requires: wine
81
82%description dll
83DLL freetype library for Windows.
84
85%description dll -l pl.UTF-8
86Biblioteka DLL freetype dla Windows.
87
88%prep
89%setup -q -n %{realname}-%{version}
90%patch0 -p1
91
92%build
93export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
94%{__gettextize}
95%{__libtoolize}
96%{__aclocal} -I m4
97%{__autoconf}
98%{__autoheader}
99%{__automake}
100%configure \
101 --target=%{target} \
102 --host=%{target} \
103 --with-arch=%{target} \
104 --with-freetype-config="pkg-config freetype2" \
105 --disable-docs \
106 --disable-silent-rules \
107 --enable-static
108
109%{__make}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114# fc_cachedir=/dummy is to avoid creating ${DESTDIR}LOCAL_APPDATA_FONTCONFIG_CACHE dir
115%{__make} -j1 install \
116 DESTDIR=$RPM_BUILD_ROOT \
117 fc_cachedir=/dummy
118
119install -d $RPM_BUILD_ROOT%{_dlldir}
120%{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122%if 0%{!?debug:1}
123%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125%endif
126
127# runtime
128%{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
129 $RPM_BUILD_ROOT%{_datadir}/{fontconfig,locale,xml/fontconfig}
130%{__rm} $RPM_BUILD_ROOT%{_bindir}/fc-*.exe
131# if needed, use ITS data from native package
132%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gettext/its
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
139%doc AUTHORS COPYING ChangeLog README
140%{_libdir}/libfontconfig.dll.a
141%{_libdir}/libfontconfig.la
142%{_libdir}/fontconfig.def
143%dir %{_includedir}/fontconfig
144%{_includedir}/fontconfig/*.h
145%{_pkgconfigdir}/fontconfig.pc
146
147%files static
148%defattr(644,root,root,755)
149%{_libdir}/libfontconfig.a
150
151%files dll
152%defattr(644,root,root,755)
153%{_dlldir}/libfontconfig-*.dll
This page took 0.194844 seconds and 4 git commands to generate.