]> git.pld-linux.org Git - packages/createrepo_c.git/blame - createrepo_c.spec
up to 1.0.3
[packages/createrepo_c.git] / createrepo_c.spec
CommitLineData
cb0b4095 1# TODO:
cb0b4095 2# - drpm support?
eb85e3be
JB
3#
4# Conditional build:
d04b5509
JR
5%bcond_with rpm5 # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6%bcond_without tests # make tests
7ab42891 7
eb85e3be
JB
8Summary: Creates a common metadata repository
9Summary(pl.UTF-8): Tworzenie wspólnego repozytorium metadanych
10Name: createrepo_c
845faf14 11Version: 1.0.3
6c555e93 12Release: 1
eb85e3be
JB
13License: GPL v2+
14Group: Applications/System
807f0e8d
JB
15#Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16Source0: https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
845faf14 17# Source0-md5: fef459cd69f83b282c4053befcee9206
eb85e3be 18Patch0: %{name}-rpm5.patch
807f0e8d 19URL: https://github.com/rpm-software-management/createrepo_c
e2180175 20BuildRequires: bash-completion-devel >= 1:2.0
eb85e3be 21BuildRequires: bzip2-devel
6c555e93 22BuildRequires: cmake >= 2.8.12
eb85e3be
JB
23BuildRequires: curl-devel
24BuildRequires: doxygen
cb0b4095 25#BuildRequires: drpm-devel
eb85e3be 26BuildRequires: glib2-devel >= 1:2.22.0
e2180175 27BuildRequires: libmodulemd-devel
eb85e3be
JB
28BuildRequires: libxml2-devel >= 2
29BuildRequires: openssl-devel
6c555e93 30BuildRequires: pkgconfig
eb85e3be 31%{?with_tests:BuildRequires: python-nose}
807f0e8d 32BuildRequires: python3-devel >= 1:3.2
6a19adf5 33BuildRequires: python3-modules
807f0e8d 34%{?with_tests:BuildRequires: python3-nose}
88265fc4 35BuildRequires: rpm-build >= 4.6
d04b5509 36BuildRequires: rpm-devel
eb85e3be 37BuildRequires: rpm-pythonprov
7fe79feb 38BuildRequires: rpmbuild(macros) >= 1.673
e2180175 39BuildRequires: sphinx-pdg
845faf14 40BuildRequires: sqlite3-devel >= 3.6.18
eb85e3be 41BuildRequires: xz-devel
e2180175 42BuildRequires: zchunk-devel
eb85e3be 43BuildRequires: zlib-devel
1cd780f3 44BuildRequires: zstd-devel
317621c2 45%{?with_tests:BuildRequires: zchunk}
eb85e3be
JB
46Requires: %{name}-libs = %{version}-%{release}
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
50C implementation of Createrepo. This utility will generate a common
51metadata repository from a directory of RPM packages.
52
53%description -l pl.UTF-8
54Implementacja w C programu Createrepo. To narzędzie generuje wspólne
55repozytorium metadanych z katalogu pakietów RPM.
56
57%package libs
58Summary: Library for repodata manipulation
59Summary(pl.UTF-8): Biblioteka do operacji na danych repozytorium
60Group: Libraries
61Requires: glib2 >= 1:2.22.0
845faf14 62Requires: sqlite3-libs >= 3.6.18
eb85e3be
JB
63
64%description libs
65This package contains the createrepo_c library for applications to
66easy manipulate with a repodata.
67
68%description libs -l pl.UTF-8
69Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
70łatwe operowanie na danych repozytorium (repodata).
71
72%package devel
73Summary: Header files for createrepo_c library
74Summary(pl.UTF-8): Pliki nagłówkowe biblioteki createrepo_c
75Group: Development/Libraries
76Requires: %{name}-libs = %{version}-%{release}
77Requires: bzip2-devel
78Requires: curl-devel
79Requires: expat-devel
80Requires: glib2-devel >= 1:2.22.0
eb85e3be 81Requires: libxml2-devel >= 2
d04b5509 82Requires: rpm-devel
845faf14 83Requires: sqlite3-devel >= 3.6.18
eb85e3be
JB
84Requires: xz-devel
85Requires: zlib-devel
1cd780f3 86Requires: zstd-devel
eb85e3be
JB
87
88%description devel
89This package contains the createrepo_c C header files. These
90development files are for easy manipulation with a repodata.
91
92%description devel -l pl.UTF-8
7ab42891
ER
93Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
94celu łatwe operowanie na danych repozytorium (repodata).
eb85e3be
JB
95
96%package apidocs
97Summary: API documentation for createrepo_c library
98Summary(pl.UTF-8): Dokumentacja API biblioteki createrepo_c
99Group: Documentation
88265fc4 100BuildArch: noarch
eb85e3be
JB
101
102%description apidocs
103API documentation for createrepo_c library.
104
105%description apidocs -l pl.UTF-8
106Dokumentacja API biblioteki createrepo_c.
107
807f0e8d
JB
108%package -n python3-createrepo_c
109Summary: Python 3 bindings for the createrepo_c library
110Summary(pl.UTF-8): Wiązania Pythona 3 do biblioteki createrepo_c
111Group: Development/Languages/Python
112Requires: %{name}-libs = %{version}-%{release}
317621c2 113Obsoletes: python-createrepo_c < 0.17.6
807f0e8d
JB
114
115%description -n python3-createrepo_c
116Python 3 bindings for the createrepo_c library.
117
118%description -n python3-createrepo_c -l pl.UTF-8
119Wiązania Pythona 3 do biblioteki createrepo_c.
eb85e3be
JB
120
121%package -n bash-completion-createrepo_c
122Summary: Bash completion for createrepo_c commands
123Summary(pl.UTF-8): Bashowe uzupełnianie dla poleceń createrepo_c
124Group: Applications/Shells
125Requires: %{name} = %{version}-%{release}
b5b52576 126Requires: bash-completion >= 1:2.0
88265fc4 127BuildArch: noarch
eb85e3be
JB
128
129%description -n bash-completion-createrepo_c
130Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
131modifyrepo_c).
132
133%description -n bash-completion-createrepo_c -l pl.UTF-8
134Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
135mergerepo_c, modifyrepo_c).
136
137%prep
807f0e8d 138%setup -q
d04b5509 139%{?with_rpm5:%patch0 -p1}
eb85e3be
JB
140
141%build
317621c2 142install -d build
807f0e8d 143cd build
807f0e8d 144%cmake .. \
7fe79feb 145 -DBASHCOMP_DIR=%{bash_compdir} \
807f0e8d
JB
146 -DPYTHON_DESIRED=3
147
148%{__make}
317621c2 149%{__make} doc
807f0e8d
JB
150
151%if %{with tests}
152%{__make} tests
153%{__make} test \
154 ARGS="-V"
155%endif
eb85e3be
JB
156
157%install
158rm -rf $RPM_BUILD_ROOT
159
317621c2 160%{__make} -C build install \
807f0e8d 161 DESTDIR=$RPM_BUILD_ROOT
9aa7d4d3 162
807f0e8d
JB
163%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
164%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
eb85e3be
JB
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post libs -p /sbin/ldconfig
170%postun libs -p /sbin/ldconfig
171
172%files
173%defattr(644,root,root,755)
174%attr(755,root,root) %{_bindir}/createrepo_c
175%attr(755,root,root) %{_bindir}/mergerepo_c
176%attr(755,root,root) %{_bindir}/modifyrepo_c
807f0e8d 177%attr(755,root,root) %{_bindir}/sqliterepo_c
eb85e3be
JB
178%{_mandir}/man8/createrepo_c.8*
179%{_mandir}/man8/mergerepo_c.8*
7ab42891 180%{_mandir}/man8/modifyrepo_c.8*
807f0e8d 181%{_mandir}/man8/sqliterepo_c.8*
eb85e3be
JB
182
183%files libs
184%defattr(644,root,root,755)
185%doc AUTHORS README.md
186%attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
1cd780f3 187%attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.1
eb85e3be
JB
188
189%files devel
190%defattr(644,root,root,755)
191%attr(755,root,root) %{_libdir}/libcreaterepo_c.so
192%{_pkgconfigdir}/createrepo_c.pc
193%{_includedir}/createrepo_c
194
195%files apidocs
196%defattr(644,root,root,755)
807f0e8d 197%doc build/doc/html
eb85e3be 198
807f0e8d
JB
199%files -n python3-createrepo_c
200%defattr(644,root,root,755)
201%dir %{py3_sitedir}/createrepo_c
202%attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
203%{py3_sitedir}/createrepo_c/__init__.py
204%{py3_sitedir}/createrepo_c/__pycache__
317621c2 205%{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
807f0e8d 206
eb85e3be
JB
207%files -n bash-completion-createrepo_c
208%defattr(644,root,root,755)
bd7532a4
JB
209%{bash_compdir}/createrepo_c
210%{bash_compdir}/mergerepo_c
211%{bash_compdir}/modifyrepo_c
212%{bash_compdir}/sqliterepo_c
This page took 0.344029 seconds and 4 git commands to generate.