]> git.pld-linux.org Git - packages/coreutils.git/blobdiff - coreutils.spec
up to 9.5
[packages/coreutils.git] / coreutils.spec
index cad8a6f8c558c68998729296ddafd7c2bcd523e8..9d5ef5b6e948c6a961b8aafa378545628da6b1ef 100644 (file)
@@ -1,18 +1,19 @@
 #
 # Conditional build:
-%bcond_with    advcopy # progress bar in cp (orphaned patch)
+%bcond_with    advcopy         # progress bar in cp (orphaned patch)
 %bcond_with    multicall       # Compile all the tools in a single binary
-%bcond_without tests   # do not perform "make test check"
+%bcond_with    tests           # unit tests running
+%bcond_without y2038           # Y2038 support for 32-bit archs
 
 Summary:       GNU Core-utils - basic command line utilities
 Summary(pl.UTF-8):     GNU Core-utils - podstawowe narzędzia działające z linii poleceń
 Name:          coreutils
-Version:       8.25
+Version:       9.5
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 Source0:       http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
-# Source0-md5: 070e43ba7f618d747414ef56ab248a48
+# Source0-md5: e99adfa059a63db3503cc71f3d151e31
 Source1:       %{name}-non-english-man-pages.tar.bz2
 # Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
 Source2:       DIR_COLORS
@@ -28,23 +29,23 @@ Patch3:             %{name}-date-man.patch
 
 Patch6:                %{name}-fmt-wchars.patch
 Patch7:                %{name}-sparc64.patch
-# http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
-Patch8:                %{name}-pl.po-update.patch
-# from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
+# https://github.com/jarun/advcpmv
 Patch9:                %{name}-advcopy.patch
 Patch10:       tests.patch
 URL:           http://www.gnu.org/software/coreutils/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
-BuildRequires: autoconf >= 2.64
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake >= 1:1.11.2
 BuildRequires: gcc >= 5:3.2
-BuildRequires: gettext-tools >= 0.18.1
+BuildRequires: gettext-tools >= 0.19.2
 BuildRequires: gmp-devel
 BuildRequires: help2man
 BuildRequires: libcap-devel
 BuildRequires: libselinux-devel
+BuildRequires: perl-base
 BuildRequires: rpmbuild(find_lang) >= 1.24
+BuildRequires: smack-devel
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo >= 4.2
 BuildRequires: xz
@@ -57,11 +58,11 @@ Provides:   mktemp = %{version}-%{release}
 Provides:      sh-utils
 Provides:      stat
 Provides:      textutils
-Obsoletes:     fileutils
-Obsoletes:     mktemp
-Obsoletes:     sh-utils
-Obsoletes:     stat
-Obsoletes:     textutils
+Obsoletes:     fileutils < 4.2
+Obsoletes:     mktemp < 1.6
+Obsoletes:     sh-utils < 2.1
+Obsoletes:     stat < 3.4
+Obsoletes:     textutils < 1:2.2
 Conflicts:     shadow < 1:4.0.3-6
 Conflicts:     tetex < 1:2.0.2
 # ensure util-linux has su included
@@ -106,7 +107,6 @@ Programy zawarte w tym pakiecie to:
 
 %prep
 %setup -q -a1
-%patch8 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -122,7 +122,7 @@ Programy zawarte w tym pakiecie to:
 %endif
 %patch10 -p1
 
-mv man/pt_BR man/pt
+%{__mv} man/pt_BR man/pt
 
 %{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
 
@@ -140,8 +140,8 @@ mv man/pt_BR man/pt
 # getgid needs to be fixed:
 # getgid: missing operand
 # Try `getgid --help' for more information.
-%{__rm} tests/misc/help-version.sh
-%{__sed} -i -e '/misc\/help-version/d' tests/local.mk
+%{__rm} tests/help/help-version.sh
+%{__sed} -i -e '/help\/help-version/d' tests/local.mk
 
 # fails on some filesystems (like XFS), where readdir returns d_type=DT_UNKNOWN
 %{__rm} tests/ls/stat-free-color.sh
@@ -153,8 +153,8 @@ mv man/pt_BR man/pt
 
 # mksh is too smart for those, won't let programs fail on ulimit
 # would need bash here
-%{__rm} tests/misc/sort-merge-fdlimit.sh
-%{__sed} -i -e '/misc\/sort-merge-fdlimit/d' tests/local.mk
+%{__rm} tests/sort/sort-merge-fdlimit.sh
+%{__sed} -i -e '/sort\/sort-merge-fdlimit/d' tests/local.mk
 %{__rm} tests/split/r-chunk.sh
 %{__sed} -i -e '/split\/r-chunk/d' tests/local.mk
 
@@ -168,13 +168,13 @@ build-aux/gen-lists-of-programs.sh --automake > src/cu-progs.mk
 %{__automake}
 %configure \
        CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
-       DEFAULT_POSIX2_VERSION=199209 \
        %{?with_multicall:--enable-single-binary=symlinks} \
        --disable-silent-rules \
        --enable-install-program=arch \
-       --enable-no-install-program=hostname,kill,uptime
+       --enable-no-install-program=hostname,kill,uptime \
+       %{!?with_y2038:--disable-year2038}
 
-%{__make}
+%{__make} -j1
 
 %if %{with tests}
 sed -i -e 's#COLUMNS##g' tests/envvar-check
@@ -188,16 +188,16 @@ install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
 df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,readlink,rm,rmdir,\
 sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
 
 %if %{with multicall}
-mv $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
+%{__mv} $RPM_BUILD_ROOT{%{_bindir},/bin}/coreutils
 ln -s ../../bin/coreutils $RPM_BUILD_ROOT%{_bindir}
 %endif
 
-mv $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
 
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
@@ -263,8 +263,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) /bin/uname
 %attr(755,root,root) /bin/unlink
 %attr(755,root,root) %{_bindir}/[
+%attr(755,root,root) %{_bindir}/b2sum
 %attr(755,root,root) %{_bindir}/base32
 %attr(755,root,root) %{_bindir}/base64
+%attr(755,root,root) %{_bindir}/basenc
 %attr(755,root,root) %{_bindir}/chcon
 %attr(755,root,root) %{_bindir}/cksum
 %attr(755,root,root) %{_bindir}/comm
@@ -341,11 +343,13 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) /etc/shrc.d/colorls.csh
 %config(noreplace) /etc/shrc.d/colorls.sh
 %config(noreplace) /etc/shrc.d/%{name}.sh
-%dir %{_libdir}/coreutils
-%attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
+%dir %{_libexecdir}/coreutils
+%attr(755,root,root) %{_libexecdir}/coreutils/libstdbuf.so
 %{_mandir}/man1/arch.1*
+%{_mandir}/man1/b2sum.1*
 %{_mandir}/man1/base32.1*
 %{_mandir}/man1/base64.1*
+%{_mandir}/man1/basenc.1*
 %{_mandir}/man1/basename.1*
 %{_mandir}/man1/cat.1*
 %{_mandir}/man1/chcon.1*
This page took 0.838473 seconds and 4 git commands to generate.