]> git.pld-linux.org Git - packages/colord-gtk.git/blame_incremental - colord-gtk.spec
- updated to 0.2.0, uses meson now
[packages/colord-gtk.git] / colord-gtk.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4%bcond_without static_libs # static libraries
5%bcond_without gtk2 # additional GTK+ 2.x version of library
6%bcond_without vala # Vala API
7
8%define colord_ver 0.1.27
9Summary: GTK helper library for colord
10Summary(pl.UTF-8): Biblioteka pomocniczna GTK dla colord
11Name: colord-gtk
12Version: 0.2.0
13Release: 1
14License: LGPL v2.1+ (library), GPL v2+ (cd-convert utility)
15Group: X11/Libraries
16Source0: https://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
17# Source0-md5: 66d048803c8b89e5e63da4b461484933
18URL: https://www.freedesktop.org/software/colord/
19BuildRequires: colord-devel >= %{colord_ver}
20BuildRequires: gettext-tools >= 0.17
21BuildRequires: glib2-devel >= 1:2.28.0
22BuildRequires: gobject-introspection-devel >= 0.9.8
23%{?with_gtk2:BuildRequires: gtk+2-devel >= 2.0}
24BuildRequires: gtk+3-devel >= 3.0
25BuildRequires: gtk-doc >= 1.9
26BuildRequires: lcms2-devel >= 2.2
27BuildRequires: meson >= 0.46.0
28BuildRequires: ninja >= 1.5
29BuildRequires: pkgconfig
30BuildRequires: rpmbuild(macros) >= 1.736
31BuildRequires: sed >= 4.0
32%if %{with vala}
33BuildRequires: vala
34BuildRequires: vala-colord >= %{colord_ver}
35%endif
36Requires: colord-libs >= %{colord_ver}
37Requires: glib2 >= 1:2.28.0
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41GTK helper library for colord.
42
43%description -l pl.UTF-8
44Biblioteka pomocniczna GTK dla colord.
45
46%package devel
47Summary: Header files for colord-gtk library
48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki colord-gtk
49Group: X11/Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: colord-devel >= %{colord_ver}
52Requires: glib2-devel >= 1:2.28.0
53Requires: gtk+3-devel >= 3.0
54
55%description devel
56Header files for colord-gtk library.
57
58%description devel -l pl.UTF-8
59Pliki nagłówkowe biblioteki colord-gtk.
60
61%package static
62Summary: Static colord-gtk library
63Summary(pl.UTF-8): Statyczna biblioteka colord-gtk
64Group: X11/Development/Libraries
65Requires: %{name}-devel = %{version}-%{release}
66
67%description static
68Static colord-gtk library.
69
70%description static -l pl.UTF-8
71Statyczna biblioteka colord-gtk.
72
73%package apidocs
74Summary: colord-gtk API documentation
75Summary(pl.UTF-8): Dokumentacja API colord-gtk
76Group: Documentation
77Requires: gtk-doc-common
78%if "%{_rpmversion}" >= "5"
79BuildArch: noarch
80%endif
81
82%description apidocs
83colord-gtk API documentation.
84
85%description apidocs -l pl.UTF-8
86Dokumentacja API colord-gtk.
87
88%package -n vala-colord-gtk
89Summary: colord-gtk API for Vala language
90Summary(pl.UTF-8): API colord-gtk dla języka Vala
91Group: X11/Development/Libraries
92Requires: %{name}-devel = %{version}-%{release}
93Requires: vala-colord >= %{colord_ver}
94%if "%{_rpmversion}" >= "5"
95BuildArch: noarch
96%endif
97
98%description -n vala-colord-gtk
99colord-gtk API for Vala language.
100
101%description -n vala-colord-gtk -l pl.UTF-8
102API colord-gtk dla języka Vala.
103
104%package -n colord-gtk2
105Summary: GTK 2 helper library for colord
106Summary(pl.UTF-8): Biblioteka pomocniczna GTK 2 dla colord
107Group: X11/Libraries
108Requires: colord-libs >= %{colord_ver}
109Requires: glib2 >= 1:2.28.0
110
111%description -n colord-gtk2
112GTK 2 helper library for colord.
113
114%description -n colord-gtk2 -l pl.UTF-8
115Biblioteka pomocniczna GTK 2 dla colord.
116
117%package -n colord-gtk2-devel
118Summary: Development files for colord-gtk2 library
119Summary(pl.UTF-8): Pliki programistyczne biblioteki colord-gtk2
120Group: X11/Development/Libraries
121Requires: %{name}-devel = %{version}-%{release}
122Requires: colord-gtk2 = %{version}-%{release}
123Requires: gtk+2-devel >= 2.0
124
125%description -n colord-gtk2-devel
126Development files for colord-gtk2 library.
127
128%description -n colord-gtk2-devel -l pl.UTF-8
129Pliki programistyczne biblioteki colord-gtk2.
130
131%package -n colord-gtk2-static
132Summary: Static colord-gtk2 library
133Summary(pl.UTF-8): Statyczna biblioteka colord-gtk2
134Group: X11/Development/Libraries
135Requires: colord-gtk2-devel = %{version}-%{release}
136
137%description -n colord-gtk2-static
138Static colord-gtk2 library.
139
140%description -n colord-gtk2-static -l pl.UTF-8
141Statyczna biblioteka colord-gtk2.
142
143%prep
144%setup -q
145
146%if %{with static_libs}
147%{__sed} -i -e 's/ = shared_library/ = library/' libcolord-gtk/meson.build
148%endif
149
150%build
151%meson build \
152 -Dgtk2=true \
153 -Dvapi=true
154
155%ninja_build -C build
156
157%install
158rm -rf $RPM_BUILD_ROOT
159
160%ninja_install -C build
161
162# only empty translation exists atm. (as of 0.1.26)
163#find_lang %{name}
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
168%post -p /sbin/ldconfig
169%postun -p /sbin/ldconfig
170
171%post -n colord-gtk2 -p /sbin/ldconfig
172%postun -n colord-gtk2 -p /sbin/ldconfig
173
174%files
175%defattr(644,root,root,755)
176# -f %{name}.lang
177%defattr(644,root,root,755)
178%doc AUTHORS MAINTAINERS NEWS README TODO
179%attr(755,root,root) %{_bindir}/cd-convert
180%attr(755,root,root) %{_libdir}/libcolord-gtk.so.*.*.*
181%attr(755,root,root) %ghost %{_libdir}/libcolord-gtk.so.1
182%{_libdir}/girepository-1.0/ColordGtk-1.0.typelib
183%{_mandir}/man1/cd-convert.1*
184
185%files devel
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_libdir}/libcolord-gtk.so
188%{_includedir}/colord-1/colord-gtk.h
189%{_includedir}/colord-1/colord-gtk
190%{_datadir}/gir-1.0/ColordGtk-1.0.gir
191%{_pkgconfigdir}/colord-gtk.pc
192
193%if %{with static_libs}
194%files static
195%defattr(644,root,root,755)
196%{_libdir}/libcolord-gtk.a
197%endif
198
199%if %{with apidocs}
200%files apidocs
201%defattr(644,root,root,755)
202%{_gtkdocdir}/colord-gtk
203%endif
204
205%if %{with vala}
206%files -n vala-colord-gtk
207%defattr(644,root,root,755)
208%{_datadir}/vala/vapi/colord-gtk.deps
209%{_datadir}/vala/vapi/colord-gtk.vapi
210%endif
211
212%if %{with gtk2}
213%files -n colord-gtk2
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libcolord-gtk2.so.*.*.*
216%attr(755,root,root) %ghost %{_libdir}/libcolord-gtk2.so.1
217
218%files -n colord-gtk2-devel
219%defattr(644,root,root,755)
220%attr(755,root,root) %{_libdir}/libcolord-gtk2.so
221%{_pkgconfigdir}/colord-gtk2.pc
222
223%if %{with static_libs}
224%files -n colord-gtk2-static
225%defattr(644,root,root,755)
226%{_libdir}/libcolord-gtk2.a
227%endif
228%endif
This page took 0.032507 seconds and 4 git commands to generate.