]> git.pld-linux.org Git - packages/chromaprint.git/blame - chromaprint.spec
- updated to 1.5.1
[packages/chromaprint.git] / chromaprint.spec
CommitLineData
3c0e7068
JB
1#
2# Conditional build:
3%bcond_without ffmpeg # fpcalc build + libchromaprint using avfft
4%bcond_with fftw3 # libchromaprint using fftw3 instead of avfft
5#
6%if %{without ffmpeg}
7%define with_fftw3 1
8%endif
042a8798 9Summary: Library implementing the AcoustID fingerprinting
93381a8e 10Summary(pl.UTF-8): Biblioteka implementująca odciski AcoustID
042a8798 11Name: chromaprint
bfa832a0 12Version: 1.5.1
60b4586a 13Release: 1
93381a8e 14License: LGPL v2.1+
042a8798 15Group: Libraries
60b4586a
JB
16#Source0Download: https://github.com/acoustid/chromaprint/releases
17Source0: https://github.com/acoustid/chromaprint/releases/download/v%{version}/%{name}-%{version}.tar.gz
bfa832a0 18# Source0-md5: 54e71f86bcf1d34989db639044ba9628
dd097dae 19URL: https://acoustid.org/chromaprint
6142e94f 20BuildRequires: cmake >= 3.3
3c0e7068
JB
21%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.6}
22%{?with_fftw3:BuildRequires: fftw3-devel >= 3}
6142e94f 23BuildRequires: libstdc++-devel >= 6:4.7
93381a8e 24BuildRequires: taglib-devel
3c0e7068 25Requires: libchromaprint = %{version}-%{release}
042a8798
ER
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Chromaprint library is the core component of the AcoustID project.
30It's a client-side library that implements a custom algorithm for
31extracting fingerprints from raw audio sources.
32
93381a8e
JB
33The library exposes a simple C API and the Python language binding is
34also available. The documentation for the C API can be found in the
35main header file.
36
37%description -l pl.UTF-8
38Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
39biblioteka kliencka implementująca własny algorytm wydobywania
40odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
41
42Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
43Pythona. Dokumentację dla API C można znaleźć w głównym pliku
44nagłówkowym.
042a8798
ER
45
46%package -n libchromaprint
47Summary: Library implementing the AcoustID fingerprinting
93381a8e
JB
48Summary(pl.UTF-8): Biblioteka implementująca odciski AcoustID
49Group: Libraries
042a8798
ER
50
51%description -n libchromaprint
52Chromaprint library is the core component of the AcoustID project.
53It's a client-side library that implements a custom algorithm for
54extracting fingerprints from raw audio sources.
55
93381a8e
JB
56The library exposes a simple C API and the Python language binding
57is also available. The documentation for the C API can be found in the
58main header file.
59
60%description -n libchromaprint -l pl.UTF-8
61Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
62biblioteka kliencka implementująca własny algorytm wydobywania
63odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
64
65Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
66Pythona. Dokumentację dla API C można znaleźć w głównym pliku
67nagłówkowym.
042a8798
ER
68
69%package -n libchromaprint-devel
93381a8e
JB
70Summary: Headers for developing programs that will use libchromaprint
71Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
042a8798
ER
72Group: Development/Libraries
73Requires: libchromaprint = %{version}-%{release}
042a8798
ER
74
75%description -n libchromaprint-devel
76This package contains the headers that programmers will need to
93381a8e 77develop applications which will use libchromaprint.
042a8798 78
93381a8e
JB
79%description -n libchromaprint-devel -l pl.UTF-8
80Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
81tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
042a8798
ER
82
83%prep
bfa832a0 84%setup -q
042a8798
ER
85
86%build
60b4586a
JB
87install -d build
88cd build
89%cmake .. \
e281636f 90 %{?with_ffmpeg:-DBUILD_TOOLS=ON} \
3c0e7068
JB
91 %{!?with_fftw3:-DWITH_AVFFT=ON} \
92 %{?with_fftw3:-DWITH_FFTW3=ON}
042a8798
ER
93
94%{__make}
95
042a8798
ER
96%install
97rm -rf $RPM_BUILD_ROOT
60b4586a
JB
98
99%{__make} -C build install \
042a8798
ER
100 DESTDIR=$RPM_BUILD_ROOT
101
042a8798
ER
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -n libchromaprint -p /sbin/ldconfig
106%postun -n libchromaprint -p /sbin/ldconfig
107
3c0e7068
JB
108%if %{with ffmpeg}
109%files
110%defattr(644,root,root,755)
111%attr(755,root,root) %{_bindir}/fpcalc
112%endif
113
042a8798
ER
114%files -n libchromaprint
115%defattr(644,root,root,755)
dd097dae 116%doc NEWS.txt README.md
042a8798 117%attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
3c0e7068 118%attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
042a8798
ER
119
120%files -n libchromaprint-devel
121%defattr(644,root,root,755)
93381a8e 122%attr(755,root,root) %{_libdir}/libchromaprint.so
042a8798 123%{_includedir}/chromaprint.h
042a8798 124%{_pkgconfigdir}/libchromaprint.pc
This page took 0.083256 seconds and 4 git commands to generate.