]> git.pld-linux.org Git - packages/ccnet.git/blame - ccnet.spec
rebuild with openssl 3.0.0
[packages/ccnet.git] / ccnet.spec
CommitLineData
c66db58f
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5Summary: A framework for writing networked applications in C
6Name: ccnet
358d3cae 7Version: 6.1.8
1d1b740f 8Release: 3
c66db58f
ER
9License: GPL v3
10Group: Libraries
11Source0: https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz
358d3cae 12# Source0-md5: 4bab2537f68070d5af226fc80b79c859
c66db58f
ER
13Patch0: codegen.patch
14URL: https://github.com/haiwen/ccnet
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: glib2-devel
18BuildRequires: libevent-devel
19BuildRequires: libsearpc-devel
20BuildRequires: libtool
21BuildRequires: libuuid-devel
22BuildRequires: libzdb-devel >= 2.10.2
23BuildRequires: openssl-devel
24BuildRequires: python-devel
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27BuildRequires: sqlite-devel
28BuildRequires: vala >= 0.8
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Ccnet is a framework for writing networked applications in C. It
33provides the following basic services:
34
35- Peer identification
36- Connection Management
37- Service invocation
38- Message sending
39
40In ccnet network, there are two types of nodes, i.e., client and
41server. Server has the following functions:
42
43- User management
44- Group management
45- Cluster management
46
47%package devel
48Summary: Development files for %{name}
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: glib2-devel
52Requires: libevent-devel
53Requires: libsearpc-devel
54
55%description devel
56The %{name}-devel package contains libraries and header files for
57developing applications that use %{name}.
58
59%prep
60%setup -q
61%patch0 -p1
62
63# meh is this?
64sed -i -e 's/(DESTDIR)//' libccnet.pc.in
65
66%build
67%{__libtoolize}
68%{__aclocal} -I m4
69%{__autoheader}
70%{__automake} --gnu
71%{__autoconf}
72%configure \
73 --disable-static \
74 --disable-compile-demo \
75
76%{__make}
77
78%if %{with tests}
79%{__make} check
80%endif
81
82%install
83rm -rf $RPM_BUILD_ROOT
84%{__make} install \
85 DESTDIR=$RPM_BUILD_ROOT
86
87%py_postclean
88
89%{__rm} $RPM_BUILD_ROOT%{_libdir}/libccnet.la
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%defattr(644,root,root,755)
358d3cae 99%doc README.markdown HACKING LICENSE.txt
c66db58f
ER
100%attr(755,root,root) %{_libdir}/libccnet.so.*.*.*
101%ghost %{_libdir}/libccnet.so.0
102%attr(755,root,root) %{_bindir}/ccnet
103%attr(755,root,root) %{_bindir}/ccnet-init
c66db58f
ER
104%{py_sitedir}/ccnet
105
106%files devel
107%defattr(644,root,root,755)
358d3cae 108%doc LICENSE.txt
c66db58f
ER
109%{_includedir}/ccnet.h
110%{_includedir}/ccnet
111%{_libdir}/libccnet.so
112%{_pkgconfigdir}/libccnet.pc
This page took 0.061383 seconds and 4 git commands to generate.