]> git.pld-linux.org Git - packages/ccache.git/blobdiff - ccache.spec
updated %doc files
[packages/ccache.git] / ccache.spec
index 5095d7dd4d1269b1bb309bb4dbd20530950585ab..c32407eae14cd27816eb44a085d53118462fb8fa 100644 (file)
@@ -1,16 +1,18 @@
 Summary:       Compiler cache
-Summary(pl.UTF-8):     Przyspieszacz kompilowania
+Summary(pl.UTF-8):     Pamięć podręczna dla kompilatora
 Summary(pt_BR.UTF-8):  Cache para compiladores C/C++
 Name:          ccache
-Version:       3.1.3
+Version:       3.3.3
 Release:       1
 License:       GPL v3
 Group:         Development/Tools
-Source0:       http://samba.org/ftp/ccache/%{name}-%{version}.tar.bz2
-# Source0-md5: 1fd1cde402ebd6d3404981ffb0394528
-Patch0:                %{name}-nohash_size_mtime.patch
+Source0:       https://www.samba.org/ftp/ccache/%{name}-%{version}.tar.xz
+# Source0-md5: 6918b36301a0b8ffdc96549f609a4ebc
 URL:           http://ccache.samba.org/
 BuildRequires: automake
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+BuildRequires: zlib-devel >= 1.2.3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libdir         %{_prefix}/%{_lib}/%{name}
@@ -22,10 +24,11 @@ when a compilation can be satisfied from cache. This often results in
 a 5 to 10 times speedup in common compilations.
 
 %description -l pl.UTF-8
-ccache działa jako cachujący preprocesor dla kompilatorów C/C++. Przy
-użyciu opcji kompilatora -E oraz tablicy haszującej do wykrywania, czy
-do kompilacji wystarczy zawartość cache. Daje to zazwyczaj
-przyspieszenie kompilacji 5 do 10 razy.
+ccache to pamięć podręczna dla kompilatora - działa jako cachujący
+preprocesor dla kompilatorów C/C++, wykorzystujący opcję kompilatora
+-E oraz tablicę haszującą do wykrywania, czy do kompilacji wystarczy
+zawartość pamięci podręcznej. Daje to zazwyczaj przyspieszenie
+kompilacji 5 do 10 razy.
 
 %description -l pt_BR.UTF-8
 ccache é um cache para compiladores. Ele funciona mantendo um cache de
@@ -50,30 +53,24 @@ kompilatora.
 
 %prep
 %setup -q
-%patch0 -p1
+
+# Make sure system zlib is used
+%{__rm} -r zlib
 
 %build
 cp -f /usr/share/automake/config.* .
+CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %configure
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 install -d $RPM_BUILD_ROOT/etc/env.d
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
-       CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
-       CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
-       CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
-do
-       echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
-done
-
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
 for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
        ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
@@ -82,17 +79,21 @@ echo 'export PATH=%{_libdir}:$PATH' > \
        $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
 
 %clean
-rm -fr $RPM_BUILD_ROOT
+rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+%doc AUTHORS.* LICENSE.* MANUAL.* NEWS.* README.md
 %attr(755,root,root) %{_bindir}/ccache
-%{_mandir}/man1/ccache*
-%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
+%{_mandir}/man1/ccache.1.*
 
 %files wrapper
 %defattr(644,root,root,755)
 %attr(755,root,root) /etc/profile.d/%{name}.sh
 %dir %{_libdir}
-%attr(755,root,root) %{_libdir}/*
+%attr(755,root,root) %{_libdir}/c++
+%attr(755,root,root) %{_libdir}/cc
+%attr(755,root,root) %{_libdir}/g++
+%attr(755,root,root) %{_libdir}/gcc
+%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-g++
+%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-gcc
This page took 0.284016 seconds and 4 git commands to generate.