]> git.pld-linux.org Git - packages/cargo-c.git/blobdiff - cargo-c.spec
up to 0.9.32
[packages/cargo-c.git] / cargo-c.spec
index 88f1bcf8a11e87135f718812c1c6585686e34d63..61c05475540c57ae66c6583bbdca98faf39130b0 100644 (file)
@@ -5,25 +5,25 @@
 Summary:       Helper program to build and install C-like libraries
 Summary(pl.UTF-8):     Program pomocniczy do budowania i instalowania bibliotek w stylu C
 Name:          cargo-c
-Version:       0.9.30
+Version:       0.9.32
 Release:       1
 License:       MIT
 Group:         Development/Tools
 #Source0Download: https://github.com/lu-zero/cargo-c/releases
 Source0:       https://github.com/lu-zero/cargo-c/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c2ce187e06603f9fb2e150df7f280ef6
+# Source0-md5: db2957cb8033cf0ee8d925847b7114ab
 # cd %{name}-%{version}
 # cargo vendor
 # cd ..
 # tar cJf cargo-c-crates-%{version}.tar.xz %{name}-%{version}/{vendor,Cargo.lock}
 Source1:       %{name}-crates-%{version}.tar.xz
-# Source1-md5: 71077d84a5365cc382fbf8557fc73a42
+# Source1-md5: 3305874ab8c1fb4e67fda47f12cbc2f8
 URL:           https://github.com/lu-zero/cargo-c
 BuildRequires: cargo >= 0.45
 BuildRequires: curl-devel
 %if %{with system_libgit2}
 BuildRequires: libgit2-devel < 1.8.0
-BuildRequires: libgit2-devel >= 1.7.1
+BuildRequires: libgit2-devel >= 1.7.2
 %endif
 BuildRequires: libssh2-devel
 BuildRequires: openssl-devel
@@ -33,16 +33,11 @@ BuildRequires:      rust
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: zlib-devel
-%{?with_system_libgit2:Requires:       libgit2 >= 1.7.1}
+%{?with_system_libgit2:Requires:       libgit2 >= 1.7.2}
 ExclusiveArch: %{rust_arches}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _debugsource_packages   0
-%ifarch        x32
-%define                target_opt      --target x86_64-unknown-linux-gnux32
-%else
-%define                target_opt      %{nil}
-%endif
+%define                _enable_debug_packages  0
 
 %description
 Cargo subcommands to build and install C-ABI compatible dynamic and
@@ -77,17 +72,15 @@ EOF
 %build
 export CARGO_HOME="$(pwd)/.cargo"
 export LIBSSH2_SYS_USE_PKG_CONFIG=1
-export PKG_CONFIG_ALLOW_CROSS=1
 
-cargo -vv build --release --frozen %{target_opt}
+%cargo_build --frozen
 
 %install
 rm -rf $RPM_BUILD_ROOT
 export CARGO_HOME="$(pwd)/.cargo"
 export LIBSSH2_SYS_USE_PKG_CONFIG=1
-export PKG_CONFIG_ALLOW_CROSS=1
 
-cargo -vv install --frozen %{target_opt} \
+%cargo_install --frozen \
        --path . \
        --root $RPM_BUILD_ROOT%{_prefix}
 
This page took 0.136414 seconds and 4 git commands to generate.