]> git.pld-linux.org Git - packages/btmgr.git/blame - btmgr.spec
- nasm fix
[packages/btmgr.git] / btmgr.spec
CommitLineData
18e6ae86
ER
1#
2# Conditional build:
3%bcond_without doc # build documentation
4
5Summary: Smart Boot Manager is an OS independent boot manager
6Name: btmgr
7Version: 3.7
8Release: 0.1
9License: GPL v2
10Group: Applications/System
11Source0: http://downloads.sourceforge.net/btmgr/%{name}-%{version}-1.tar.gz
12# Source0-md5: 7bfe432821c3cef48df8b3d6be800009
8713c393 13Patch0: nasm.patch
18e6ae86
ER
14URL: http://sourceforge.net/projects/btmgr/
15BuildRequires: nasm
16BuildRequires: sed >= 4.0
23b9ad33
ER
17%if %{with doc}
18BuildRequires: sgml-tools
19BuildRequires: tetex-format-latex
20%endif
18e6ae86
ER
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The main goals of SBM are to be absolutely OS independent, flexible
25and full-featured. It has all of the features needed to boot a variety
26of OSes from several kinds of media, while keeping its size no more
27than 30K bytes. In another words, SBM does NOT touch any of your
28partitions, it totally fits into the first track (the hidden track) of
29your hard disk! SBM now supports booting from floppy, hard disk and
30CD-ROM. There are plans to support ZIP and LS-120 in the near future.
31
32%prep
33%setup -q -n %{name}-%{version}-1
8713c393 34%patch0 -p1
18e6ae86 35
23b9ad33
ER
36# allow passing defaults
37%{__sed} -i -e '/^CC=/ s/gcc/$(HOSTCC)/' Makefile
38%{__sed} -i -e '/^COMMON_FLAGS=/ s/-g/$(CFLAGS)/' Makefile
39%{__sed} -i -e '/^ASM=/ s/$/ $(AFLAGS)/' Makefile
40
41# we run docs in bcond
18e6ae86 42%{__sed} -i -e '/^SUBDIRS=/ s/docs//' Makefile
23b9ad33
ER
43# pipe breaks error handling
44%{__sed} -i -e '/(MAKE)/ s/|tee -a errors.log//' Makefile
18e6ae86
ER
45
46%build
23b9ad33
ER
47%{__make} \
48 HOSTCC="%{__cc}" \
49 CFLAGS="%{rpmcflags}" \
50 AFLAGS="-w-orphan-labels"
18e6ae86
ER
51
52%{?with_doc:%{__make} -C docs}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56%{__make} install \
57 PREFIX=$RPM_BUILD_ROOT%{_prefix}
58
59%files
60%defattr(644,root,root,755)
61%doc AUTHORS ChangeLog CREDITS INSTALL README TODO
62%doc(zh) README-ZH
63%attr(755,root,root) %{_sbindir}/sbminst
64%{_datadir}/btmgr
65
66%clean
67rm -rf $RPM_BUILD_ROOT
This page took 0.431822 seconds and 4 git commands to generate.