]> git.pld-linux.org Git - packages/boomerang.git/blame - boomerang.spec
- initial pld release (still raw and nfy)
[packages/boomerang.git] / boomerang.spec
CommitLineData
cfcf678f
AM
1Summary: An attempt at a general, open source, retargetable decompiler of native executable files
2Name: boomerang
3Version: 0.0.0.20040707
4Release: 0.1
5License: GPL
6Group: Development/Languages
7Source0: %{name}.tar.gz
8# Source0-md5: 97d2b1825b3e2d5bcd85df48eb15a45e
9URL: http://boomerang.sourceforge.net/
10BuildRequires: bison++
11BuildRequires: flexx++
12BuildRequires: cppunit
13BuildRequires: expat-devel
14BuildRequires: libstdc++-devel
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18An attempt to develop a real decompiler through the open source
19community. A decompiler takes as input an executable file, and
20attempts to create a high level, compilable, even maintainable source
21file that does the same thing. It is therefore the opposite of a
22compiler, which of course takes a source file and makes an executable.
23It won't of course recreate the original source file; probably nothing
24like it. It does not matter if the executable file has symbols or not,
25or was compiled from any particular language. (However, languages like
26ML that are usually interpreted are not considered.)
27
28The intent is to create a retargetable decompiler (i.e. one that can
29work with different types of input executable files with modest
30effort, e.g. X86-windows, sparc-solaris, etc). It will be highly
31modular, so that different parts of the decompiler can be replaced
32with experimental modules. It is intended to eventually become
33interactive, a la IDA Pro, because some things (not just variable
34names and comments, though these are obviously very important) require
35expert intervention.
36
37%prep
38%setup -q -n %{name}
39
40%build
41%configure
42
43%{__make} \
44 C="%{__cc}" \
45 CC="%{__cxx}"
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp
50
51%{__make} install \
52 DESTDIR="$RPM_BUILD_ROOT"
53
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
This page took 0.094489 seconds and 4 git commands to generate.