]> git.pld-linux.org Git - packages/bird.git/blobdiff - bird.spec
- switch to https
[packages/bird.git] / bird.spec
index 23c4b9ff907f3aa86ae8a6cdb875a8c7da69c3d8..8e249ff4dbf7eb7a4ae09841a4a05c977e7546d4 100644 (file)
--- a/bird.spec
+++ b/bird.spec
@@ -4,24 +4,28 @@
 # Conditional build:
 %bcond_without ipv6    # disable IPv6 support (and building bird-ipv6 package)
 %bcond_without ipv4    # disable IPv4 support (and building bird-ipv4 package)
+%bcond_with    alien   # enable possibility to import 'alien' routes import into bird's routing table
 #
 Summary:       The BIRD Internet Routing Daemon
 Summary(pl.UTF-8):     Demon BIRD Internetowego Routingu Dynamicznego
 Name:          bird
-Version:       1.2.1
+Version:       1.6.8
 Release:       1
 License:       GPL v2+
 Group:         Networking/Daemons
-Source0:       ftp://bird.network.cz/pub/bird/%{name}-%{version}.tar.gz
-# Source0-md5: e158bd0a72e345841e39764975ee1d21
+Source0:       https://bird.network.cz/download/%{name}-%{version}.tar.gz
+# Source0-md5: abe29a927e21a3d7f8092641f06093c2
 Source1:       %{name}-ipv4.init
 Source2:       %{name}-ipv4.sysconfig
 Source3:       %{name}-ipv6.init
 Source4:       %{name}-ipv6.sysconfig
-Source5:       ftp://bird.network.cz/pub/bird/%{name}-doc-%{version}.tar.gz
-# Source5-md5: a82474c87f5c79f29a6c9088f9dfe30a
-Patch0:                %{name}-64bit.patch
-URL:           http://bird.network.cz/
+Source5:       https://bird.network.cz/download/%{name}-doc-%{version}.tar.gz
+# Source5-md5: d5b69caeee629479e0261aba18d35758
+Source6:       %{name}-ipv4.service
+Source7:       %{name}-ipv6.service
+Patch0:                %{name}-allowalien.patch
+Patch1:                gcc.patch
+URL:           https://bird.network.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
@@ -31,6 +35,8 @@ BuildRequires:        rpmbuild(macros) >= 1.268
 Requires(post,preun):  /sbin/chkconfig
 Requires:      bird-daemon
 Requires:      rc-scripts
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /usr/sbin/useradd
 Obsoletes:     gated
 Obsoletes:     mrt
 Obsoletes:     zebra
@@ -103,13 +109,14 @@ filtrów o dużych możliwościach.
 
 %prep
 %setup -q -a 5
-%patch0 -p1
+%{?with_alien:%patch0 -p1}
+%patch1 -p1
 
 %build
 cp -f /usr/share/automake/config.* tools
 %{__autoconf}
 
-export CFLAGS="%{rpmcflags} -I%{_includedir}/ncurses"
+export CFLAGS="%{rpmcflags} -I%{_includedir}/ncursesw -fno-strict-aliasing -fno-strict-overflow"
 
 %if %{with ipv6}
 %configure \
@@ -133,53 +140,87 @@ mv bird bird-6
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_sbindir}}
+install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_sbindir}} \
+       $RPM_BUILD_ROOT%{systemdunitdir}
 
 install birdc $RPM_BUILD_ROOT%{_sbindir}
 
-%if %{with ipv6}
+%if %{with ipv4}
 install bird $RPM_BUILD_ROOT%{_sbindir}
 install doc/bird.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv4
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv4
+install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-ipv4.service
 %endif
 
 %if %{with ipv6}
 install bird-6 $RPM_BUILD_ROOT%{_sbindir}
 cat <<EOF > $RPM_BUILD_ROOT%{_sbindir}/birdc-6
 #!/bin/sh
-exec %{_sbindir}/birdc -s /var/run/bird-6.ctl
+exec %{_sbindir}/birdc -s /var/run/bird6.ctl
 EOF
+:> $RPM_BUILD_ROOT%{_sysconfdir}/%{name}6.conf
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-ipv6
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-ipv6
+install %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}-ipv6.service
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 271 bird
+%useradd -u 271 -d /usr/share/empty -s /bin/false -c "bird routing daemon" -g bird bird
+
+%postun
+if [ "$1" = "0" ]; then
+       %userremove bird
+       %groupremove bird
+fi
+
 %post ipv4
 /sbin/chkconfig --add %{name}-ipv4
 %service %{name}-ipv4 restart "routing daemon"
+%systemd_post %{name}-ipv4.service
 
 %preun ipv4
 if [ "$1" = "0" ]; then
        %service %{name}-ipv4 stop
        /sbin/chkconfig --del %{name}-ipv4
 fi
+%systemd_preun %{name}-ipv4.service
+
+%postun ipv4
+%systemd_reload
 
 %post ipv6
 /sbin/chkconfig --add %{name}-ipv6
 %service %{name}-ipv6 restart "routing daemon"
+%systemd_post %{name}-ipv6.service
 
 %preun ipv6
 if [ "$1" = "0" ]; then
        %service %{name}-ipv6 stop
        /sbin/chkconfig --del %{name}-ipv6
 fi
+%systemd_preun %{name}-ipv6.service
+
+%postun ipv6
+%systemd_reload
+
+%triggerpostun ipv4 -- %{name}-ipv4 < 1.3.4-3
+chmod 0640 /etc/bird.conf
+chgrp bird /etc/bird.conf
+
+%triggerpostun -- %{name}-ipv4 < 1.4.5-2
+%systemd_trigger %{name}-ipv4.service
+
+%triggerpostun -- %{name}-ipv6 < 1.4.5-2
+%systemd_trigger %{name}-ipv6.service
 
 %files
 %defattr(644,root,root,755)
-%doc doc/*.html doc/reply_codes %{name}-doc-%{version}/doc/*.ps ChangeLog NEWS README TODO
+%doc doc/*.html doc/reply_codes %{name}-doc-%{version}/doc/*.pdf ChangeLog NEWS README 
 %attr(755,root,root) %{_sbindir}/birdc
 
 %if %{with ipv4}
@@ -187,8 +228,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird
 %attr(754,root,root) /etc/rc.d/init.d/bird-ipv4
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv4
+%attr(640,root,bird) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird.conf
+%{systemdunitdir}/%{name}-ipv4.service
 %endif
 
 %if %{with ipv6}
@@ -196,7 +238,8 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_sbindir}/bird-6
 %attr(755,root,root) %{_sbindir}/birdc-6
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
-%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rc.d/init.d/bird-ipv6
-#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird-6.conf
+%attr(754,root,root) /etc/rc.d/init.d/bird-ipv6
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bird-ipv6
+%attr(640,root,bird) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bird6.conf
+%{systemdunitdir}/%{name}-ipv6.service
 %endif
This page took 0.122299 seconds and 4 git commands to generate.