]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- typo
[packages/apache.git] / apache.spec
index d259d01f25cb93b8f40deac1f92e8bcad42265aa..a9deb9c87407e313c766675cd42064e505c5cc01 100644 (file)
@@ -1,3 +1,4 @@
+# # TODO:
 # - config examples for mod_*
 # - --with-suexec-uidmin=500 or =1000 ?
 # - subpackages for MPMs
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
 %bcond_without event           # event MPM
+%bcond_without itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
 
 # this is internal macro, don't change to %%apache_modules_api
-%define                _apache_modules_api 20100723
+%define                _apache_modules_api 20051115
 
 %if "%{pld_release}" != "ac"
 %define                openssl_ver     0.9.8i
@@ -39,12 +41,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.3.8
-Release:       0.1
+Version:       2.2.17
+Release:       8.1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
-# Source0-md5: 275b3dea795edb19f74470ff9b591ccd
+# Source0-md5: 66d8e107f85acc039fd5e624e85728a9
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -81,11 +83,10 @@ Patch3:             %{name}-branding.patch
 Patch4:                %{name}-apr.patch
 # what about this? it isn't applied...
 Patch6:                httpd-2.0.40-xfsz.patch
-#Patch7:               %{name}-syslibs.patch
+Patch7:                %{name}-syslibs.patch
 Patch8:                httpd-2.0.45-encode.patch
 Patch9:                %{name}-paths.patch
 Patch10:       httpd-2.0.46-dav401dest.patch
-Patch11:       %{name}-bug-40970.patch
 Patch12:       httpd-2.0.46-sslmutex.patch
 Patch14:       httpd-2.0.48-corelimit.patch
 Patch15:       httpd-2.0.48-debuglog.patch
@@ -97,6 +98,9 @@ Patch24:      %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
 Patch25:       httpd-2.2.x-mod_ssl-sessioncaching.patch
 Patch26:       apache-mod_vhost_alias_docroot.patch
+Patch27:       apache-bug-41743.patch
+# http://mpm-itk.sesse.net/
+Patch28:       apache-mpm-itk.patch
 URL:           http://httpd.apache.org/
 BuildRequires: apr-devel >= 1:1.2
 BuildRequires: apr-util-devel >= 1:1.3
@@ -108,8 +112,8 @@ BuildRequires:      expat-devel
 BuildRequires: gdbm-devel >= 1.8.3
 BuildRequires: libtool >= 2:1.5
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
-%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_version}}
-%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_version}}
+%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_ver}}
+%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_ver}}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -818,20 +822,33 @@ proxy. Dołączono dwa moduły pozwalające magazynować dane w pamięci
 dysku (używane do cache'owania proxy).
 
 %package mod_case_filter
-Summary:       TODO
+Summary:       Apache output filter that converts all output to upper case
+Summary(pl.UTF-8):     Filtr wyjściowy Apache'a zamieniający wszystkie litery na wielkie
 Group:         Networking/Daemons/HTTP
 Requires:      %{name}-base = %{version}-%{release}
 Provides:      apache(mod_case_filter) = %{version}-%{release}
 
 %description mod_case_filter
+Apache output filter that converts all output to upper case.
+
+%description mod_case_filter -l pl.UTF-8
+Filtr wyjściowy Apache'a zamieniający wszystkie litery w wyjściu na
+wielkie.
 
 %package mod_case_filter_in
-Summary:       TODO
+Summary:       Apache input filter that converts all request body to upper case
+Summary(pl.UTF-8):     Filtr wejściowy Apache'a zamieniający wszystkie litery w żądaniu na wielkie
 Group:         Networking/Daemons/HTTP
 Requires:      %{name}-base = %{version}-%{release}
 Provides:      apache(mod_case_filter_in) = %{version}-%{release}
 
 %description mod_case_filter_in
+Apache input filter that converts all request body (not headers) to
+upper case.
+
+%description mod_case_filter_in -l pl.UTF-8
+Filtr wejściowy Apache'a zamieniający wszystkie litery w ciele żądania
+(ale nie nagłówkach) na wielkie.
 
 %package mod_cern_meta
 Summary:       CERN httpd metafile semantics
@@ -954,6 +971,7 @@ URL:                http://httpd.apache.org/docs/2.2/en/mod/mod_dav.html
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      apache-mod_authn_file
 Requires:      apache-mod_setenvif
+Requires:      apr-util-dbm-db
 Provides:      apache(mod_dav) = %{version}-%{release}
 
 %description mod_dav
@@ -1466,7 +1484,7 @@ HTTP/1.0 i HTTP/1.1.
 
 %package mod_reqtimeout
 Summary:       Apache module to set timeout and minimum data rate for receiving requests
-Summary(pl.UTF-8):     Moduł Apache'a pozwalający na ustawianie timeout oraz minimalnego transferu danych
+Summary(pl.UTF-8):     Moduł Apache'a pozwalający na ustawianie limitu czasu oraz minimalnego transferu danych
 Group:         Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.2/mod/mod_reqtimeout.html
 Requires:      %{name}-base = %{version}-%{release}
@@ -1478,7 +1496,7 @@ Apache module to set timeout and minimum data rate for receiving
 requests.
 
 %description mod_reqtimeout -l pl.UTF-8
-Moduł Apache'a pozwalający na ustawianie timeout oraz minimalnego
+Moduł Apache'a pozwalający na ustawianie limitu czasu oraz minimalnego
 transferu danych.
 
 %package mod_rewrite
@@ -1555,7 +1573,7 @@ Epoch:            1
 Group:         Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.2/mod/mod_ssl.html
 Requires:      %{name}-base = %{version}-%{release}
-Requires:      openssl >= %{openssl_version}
+Requires:      openssl >= %{openssl_ver}
 %if "%{pld_release}" != "ac"
 Requires:      apr-util-dbm-db
 %endif
@@ -1758,11 +1776,10 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-#%patch7 -p1
+%patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
 %patch12 -p1
 %patch14 -p1
 %patch15 -p1
@@ -1773,9 +1790,11 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch27 -p0
+%patch28 -p1
 
 # using system apr, apr-util and pcre
-#rm -rf srclib/{apr,apr-util,pcre}
+rm -rf srclib/{apr,apr-util,pcre}
 
 # sanity check
 MODULES_API=`awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' include/ap_mmn.h`
@@ -1806,12 +1825,12 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event}; do
+for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
 install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
 ../%configure \
        --enable-layout=PLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" ] && echo "--enable-exception-hook" ) \
+       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1890,7 +1909,7 @@ cd ..
 
 done
 
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
                echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
                echo "Build failed."
@@ -1910,7 +1929,7 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install other mpm-s
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
 done
 
This page took 0.04054 seconds and 4 git commands to generate.