]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- typo
[packages/apache.git] / apache.spec
index 7655d86869e88f719a9320bd9627495145fb3630..a9deb9c87407e313c766675cd42064e505c5cc01 100644 (file)
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
 %bcond_without event           # event MPM
+%bcond_without itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
-#
-%include       /usr/lib/rpm/macros.perl
+
 # this is internal macro, don't change to %%apache_modules_api
 %define                _apache_modules_api 20051115
 
@@ -31,6 +31,7 @@
 %else
 %define                openssl_ver     0.9.7d
 %endif
+%include       /usr/lib/rpm/macros.perl
 Summary:       The most widely used Web server on the Internet
 Summary(de.UTF-8):     Leading World Wide Web-Server
 Summary(es.UTF-8):     Servidor HTTPD para proveer servicios WWW
@@ -41,7 +42,7 @@ Summary(ru.UTF-8):    Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
 Version:       2.2.17
-Release:       4
+Release:       8.1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -97,6 +98,9 @@ Patch24:      %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
 Patch25:       httpd-2.2.x-mod_ssl-sessioncaching.patch
 Patch26:       apache-mod_vhost_alias_docroot.patch
+Patch27:       apache-bug-41743.patch
+# http://mpm-itk.sesse.net/
+Patch28:       apache-mpm-itk.patch
 URL:           http://httpd.apache.org/
 BuildRequires: apr-devel >= 1:1.2
 BuildRequires: apr-util-devel >= 1:1.3
@@ -108,8 +112,8 @@ BuildRequires:      expat-devel
 BuildRequires: gdbm-devel >= 1.8.3
 BuildRequires: libtool >= 2:1.5
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
-%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_version}}
-%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_version}}
+%{?with_ssl:BuildRequires:     openssl-devel >= %{openssl_ver}}
+%{?with_ssl:BuildRequires:     openssl-tools >= %{openssl_ver}}
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -1569,7 +1573,7 @@ Epoch:            1
 Group:         Networking/Daemons/HTTP
 URL:           http://httpd.apache.org/docs/2.2/mod/mod_ssl.html
 Requires:      %{name}-base = %{version}-%{release}
-Requires:      openssl >= %{openssl_version}
+Requires:      openssl >= %{openssl_ver}
 %if "%{pld_release}" != "ac"
 Requires:      apr-util-dbm-db
 %endif
@@ -1786,6 +1790,8 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch27 -p0
+%patch28 -p1
 
 # using system apr, apr-util and pcre
 rm -rf srclib/{apr,apr-util,pcre}
@@ -1819,12 +1825,12 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event}; do
+for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
 install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
 ../%configure \
        --enable-layout=PLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" ] && echo "--enable-exception-hook" ) \
+       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1903,7 +1909,7 @@ cd ..
 
 done
 
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
                echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
                echo "Build failed."
@@ -1923,7 +1929,7 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install other mpm-s
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
 done
 
This page took 0.064001 seconds and 4 git commands to generate.