]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- allow work without systemd-units
[packages/apache.git] / apache.spec
index 15fff2757631f33c63bd2bf411b8ff50ca3c3386..9b5a84a84ce8a197431d46fcd30e64f7a47f4c8c 100644 (file)
@@ -43,12 +43,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.2.22
-Release:       2
+Version:       2.2.23
+Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
-# Source0-md5: d77fa5af23df96a8af68ea8114fa6ce1
+# Source0-md5: 77246eaa84a54bb7451f68216333750d
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -120,7 +120,7 @@ BuildRequires:      pkgconfig
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpm-build >= 4.4.0
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: rpmbuild(macros) >= 1.639
+BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
 Requires:      %{name}-errordocs = %{version}-%{release}
@@ -144,19 +144,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _libexecdir     %{_libdir}/apache
 %define                _cgibindir      %{_prefix}/lib/cgi-bin/%{name}
 
-%define                httpd_restart \
-       if /bin/systemd_booted; then \
-               /bin/systemctl restart httpd.service \
-       else \
-               %service -q httpd restart \
-       fi
-%define                httpd_reload \
-       if /bin/systemd_booted; then \
-               /bin/systemctl reload httpd.service \
-       else \
-               %service -q httpd reload \
-       fi
-
 %description
 Apache is a powerful, full-featured, efficient and freely-available
 Web server. Apache is also the most popular Web server on the
@@ -210,12 +197,13 @@ Requires(pre):    /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
+Requires(post,preun,postun):   systemd-units >= 38
 Requires:      /sbin/chkconfig
 Requires:      apr >= %{apr_ver}
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.1.23
 Requires:      sed >= 4.0
-Requires:      systemd-units
+Requires:      systemd-units >= 38
 Provides:      apache(modules-api) = %{_apache_modules_api}
 Provides:      group(http)
 Provides:      user(http)
@@ -2253,18 +2241,21 @@ mv -f /var/lock/subsys/httpd{.disabled,} 2>/dev/null
 # main package are very important for all this to work.
 
 # restart webserver at the end of transaction
-%httpd_restart
+%service httpd restart
+%systemd_service_restart httpd.service
 
 # macro called at module post scriptlet
 %define        module_post \
 if [ "$1" = "1" ]; then \
-       %httpd_restart \
+       %service -q httpd restart \
+       %systemd_service_restart httpd.service \
 fi
 
 # macro called at module postun scriptlet
 %define        module_postun \
 if [ "$1" = "0" ]; then \
-       %httpd_restart \
+       %service -q httpd restart \
+       %systemd_service_restart httpd.service \
 fi
 
 # it's sooo annoying to write them
@@ -2343,22 +2334,26 @@ fi
 
 %post cgi_test
 if [ "$1" = "1" ]; then
-       %httpd_reload
+       %service -q httpd reload
+       %systemd_service_reload httpd.service
 fi
 
 %postun cgi_test
 if [ "$1" = "0" ]; then
-       %httpd_reload
+       %service -q httpd reload
+       %systemd_service_reload httpd.service
 fi
 
 %post errordocs
 if [ "$1" = "1" ]; then
-       %httpd_reload
+       %service -q httpd reload
+       %systemd_service_reload httpd.service
 fi
 
 %postun errordocs
 if [ "$1" = "0" ]; then
-       %httpd_reload
+       %service -q httpd reload
+       %systemd_service_reload httpd.service
 fi
 
 %files
@@ -2383,7 +2378,7 @@ fi
 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/vhosts.d/example.net.conf
 %attr(640,root,root) %{_sysconfdir}/magic
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/httpd
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/httpd
 
 %dir %{_libexecdir}
 
@@ -2395,7 +2390,7 @@ fi
 %dir %attr(770,root,http) /var/cache/httpd
 
 /usr/lib/tmpfiles.d/%{name}.conf
-%{systemdunitdir}/*.service
+%{systemdunitdir}/httpd-*.service
 %config(noreplace) %verify(not md5 mtime size) /etc/systemd/system/httpd.service
 
 %{_mandir}/man8/httpd.8*
@@ -2440,10 +2435,10 @@ fi
 %attr(755,root,root) %{_sbindir}/htdigest
 %attr(755,root,root) %{_sbindir}/logresolve
 %attr(755,root,root) %{_sbindir}/rotatelogs
-%{_mandir}/man1/ab.1*
+%{_mandir}/man8/ab.8*
 %{_mandir}/man8/apachectl.8*
 %{_mandir}/man1/htdigest.1*
-%{_mandir}/man1/logresolve.1*
+%{_mandir}/man8/logresolve.8*
 %{_mandir}/man8/rotatelogs.8*
 
 %files devel
@@ -2456,7 +2451,7 @@ fi
 %{_libexecdir}/build/config_vars.mk
 %attr(755,root,root) %{_libexecdir}/build/*.sh
 %{_includedir}
-%{_mandir}/man1/apxs.1*
+%{_mandir}/man8/apxs.8*
 
 %files mod_actions
 %defattr(644,root,root,755)
This page took 0.034476 seconds and 4 git commands to generate.