]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- missingok for vhosts.d/example.net.conf, non-interactive and not forced rm
[packages/apache.git] / apache.spec
index 3de6d9b2a15c048d6ab485af162b51d39e729ceb..77ea03034fe52cc62385237977c3ad6b7f1af84e 100644 (file)
@@ -19,6 +19,7 @@
 %bcond_without ldap            # build without LDAP support
 %bcond_without peruser         # peruser MPM
 %bcond_without event           # event MPM
+%bcond_with    itk             # ITK MPM
 %bcond_with    distcache       # distcache support
 %bcond_with    bucketeer       # debug one
 
@@ -40,12 +41,12 @@ Summary(pt_BR.UTF-8):       Servidor HTTPD para prover serviços WWW
 Summary(ru.UTF-8):     Самый популярный веб-сервер
 Summary(tr.UTF-8):     Lider WWW tarayıcı
 Name:          apache
-Version:       2.2.17
-Release:       8
+Version:       2.2.19
+Release:       2
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
-# Source0-md5: 66d8e107f85acc039fd5e624e85728a9
+# Source0-md5: e9f5453e1e4d7aeb0e7ec7184c6784b5
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
@@ -97,10 +98,12 @@ Patch24:    %{name}-bug-48094.patch
 # http://scripts.mit.edu/trac/browser/trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch?rev=1348
 Patch25:       httpd-2.2.x-mod_ssl-sessioncaching.patch
 Patch26:       apache-mod_vhost_alias_docroot.patch
-Patch27:       apache-bug-41743.patch
+# http://mpm-itk.sesse.net/
+Patch28:       apache-mpm-itk.patch
+Patch29:       libtool-tag.patch
 URL:           http://httpd.apache.org/
-BuildRequires: apr-devel >= 1:1.2
-BuildRequires: apr-util-devel >= 1:1.3
+BuildRequires: apr-devel >= 1:1.4.5
+BuildRequires: apr-util-devel >= 1:1.3.10-2
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: db-devel
@@ -194,7 +197,7 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      /sbin/chkconfig
-Requires:      apr >= 1:1.2
+Requires:      apr >= 1:1.4.5
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.1.23
 Provides:      apache(modules-api) = %{_apache_modules_api}
@@ -1787,10 +1790,11 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
-%patch27 -p0
+%patch28 -p1
+%patch29 -p1
 
 # using system apr, apr-util and pcre
-rm -rf srclib/{apr,apr-util,pcre}
+%{__rm} -r srclib/{apr,apr-util,pcre}
 
 # sanity check
 MODULES_API=`awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' include/ap_mmn.h`
@@ -1821,12 +1825,12 @@ touch ssl_expr_scan.c
 cd ../..
 
 CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
-for mpm in prefork worker %{?with_event:event}; do
+for mpm in prefork worker %{?with_event:event} %{?with_itk:itk}; do
 install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
 ../%configure \
        --enable-layout=PLD \
        --disable-v4-mapped \
-       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" ] && echo "--enable-exception-hook" ) \
+       $( [ "${mpm}" = "prefork" -o "${mpm}" = "worker" -o "${mpm}" = "event" -o "${mpm}" = "itk" ] && echo "--enable-exception-hook" ) \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1905,7 +1909,7 @@ cd ..
 
 done
 
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        if ! cmp -s buildmpm-prefork/modules-inside buildmpm-${mpm}/modules-inside; then
                echo "List of compiled modules is different between prefork-MPM and ${mpm}-MPM!"
                echo "Build failed."
@@ -1925,7 +1929,7 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
        DESTDIR=$RPM_BUILD_ROOT
 
 # install other mpm-s
-for mpm in worker %{?with_event:event}; do
+for mpm in worker %{?with_event:event} %{?with_itk:itk}; do
        install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
 done
 
@@ -2026,7 +2030,7 @@ echo "LoadModule substitute_module        modules/mod_substitute.so" > $CFG/00_mod_subs
 echo "LoadModule reqtimeout_module     modules/mod_reqtimeout.so" >> $CFG/00_mod_reqtimeout.conf
 
 # anything in style dir not ending with .css is trash
-rm -rf $RPM_BUILD_ROOT%{_datadir}/manual/style/{lang,latex,xsl}
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/manual/style/{lang,latex,xsl}
 find $RPM_BUILD_ROOT%{_datadir}/manual/style -type f ! -name '*.css' -print0 | xargs -0r rm -f
 
 # find manual files
@@ -2055,11 +2059,11 @@ EOF
 ln -sf suexec $RPM_BUILD_ROOT%{_sbindir}/suexec.fcgi
 
 # no value
-rm $RPM_BUILD_ROOT%{_libexecdir}/build/config.nice
-rm $RPM_BUILD_ROOT%{_libexecdir}/*.exp
-rm $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
-rm $RPM_BUILD_ROOT%{_sysconfdir}/httpd.prefork.conf
-rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/{extra,original}
+%{__rm} $RPM_BUILD_ROOT%{_libexecdir}/build/config.nice
+%{__rm} $RPM_BUILD_ROOT%{_libexecdir}/*.exp
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
+%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.prefork.conf
+%{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/{extra,original}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2340,7 +2344,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_common.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mpm.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vhosts.d/example.net.conf
+%attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/vhosts.d/example.net.conf
 %attr(640,root,root) %{_sysconfdir}/magic
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/httpd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
This page took 0.036377 seconds and 4 git commands to generate.