]> git.pld-linux.org Git - packages/apache-mod_suphp.git/blobdiff - apache-mod_suphp.spec
update to 0.7.2
[packages/apache-mod_suphp.git] / apache-mod_suphp.spec
index 8cce44fae0b4408972ec3d571e1878dfcff35b0b..7098f79893abca8779661b1d805b4c74be7b5676 100644 (file)
@@ -1,38 +1,39 @@
 #
 # Available build options:
 %bcond_with    checkpath       # enable check if php execution is within DOCUMENT_ROOT of the vhost
-#
+
 %define                mod_name        suphp
 %define        apxs            /usr/sbin/apxs
 Summary:       Apache module: suPHP - execute PHP scripts with the permissions of their owners
 Summary(pl.UTF-8):     Moduł do apache: suPHP - uruchamianie skryptów PHP z uprawnieniami ich właścicieli
 Name:          apache-mod_%{mod_name}
-Version:       0.6.1
+Version:       0.7.2
 Release:       1
 License:       GPL
-Group:         Networking/Daemons
+Group:         Networking/Daemons/HTTP
 Source0:       http://www.suphp.org/download/%{mod_name}-%{version}.tar.gz
-# Source0-md5: 7eb8ae29404392d9eb07c69d5242d716
+# Source0-md5: 852793953eec97f4ae992e366b517e81
 Source1:       %{name}.logrotate
 Source2:       %{name}.conf
 Source3:       %{name}-suphp.conf
-Patch0:                %{name}-apr.patch
-Patch1:                %{name}-compiler-flags.patch
-Patch2:                %{name}-apache_version.patch
+Patch0:                %{name}-compiler-flags.patch
+Patch1:                %{name}-apache_version.patch
+Patch2:                automake-1.13.patch
 URL:           http://www.suphp.org/
-BuildRequires: apache-apxs >= 2.0.52-2
+BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0.52-2
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache(modules-api) = %apache_modules_api
-Requires:      php-cgi
-Conflicts:     logrotate < 3.7.4
+Requires:      php(cgi)
+Conflicts:     logrotate < 3.7-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+%define                apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 
 %description
 suPHP is a tool for executing PHP scripts with the permissions of
@@ -53,20 +54,19 @@ moduł w celu zmiany uid procesu uruchamiającego interpreter PHP.
 %patch2 -p1
 
 %build
+%{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-export APACHE_VERSION=$(rpm -q --qf '%%{version}' apache-apxs)
+APACHE_VERSION=$(rpm -q --qf '%{V}' apache-devel); export APACHE_VERSION
 %configure \
-       %{?with_checkpath: --enable-checkpath} \
-       %{!?with_checkpath: --disable-checkpath} \
+       --%{?with_checkpath:en}%{!?with_checkpath:dis}able-checkpath \
        --with-apache-user=http \
        --with-min-uid=500 \
        --with-min-gid=1000 \
        --with-apxs=%{apxs} \
-       --disable-checkuid \
-       --disable-checkgid \
+       --with-apr=%{_bindir}/apr-1-config \
        --with-setid-mode=owner \
        --with-logfile=/var/log/httpd/suphp_log
 
@@ -74,18 +74,17 @@ export APACHE_VERSION=$(rpm -q --qf '%%{version}' apache-apxs)
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_datadir}/suphp}
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{apachelibdir},%{_datadir}/suphp}
+install -d $RPM_BUILD_ROOT%{apacheconfdir}
 
-install src/suphp $RPM_BUILD_ROOT%{_sbindir}
-install src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
+install -p src/suphp $RPM_BUILD_ROOT%{_sbindir}
+install -p src/apache2/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/70_mod_%{mod_name}.conf
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{mod_name}.conf
 
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
-
-install doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
+cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/apache-mod_suphp
+cp -p doc/suphp.conf-example $RPM_BUILD_ROOT%{_datadir}/suphp
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -101,9 +100,9 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS ChangeLog doc
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{mod_name}.conf
-%attr(755,root,root) %{_pkglibdir}/*.so
+%attr(755,root,root) %{apachelibdir}/*.so
 %attr(4755,root,root) %{_sbindir}/suphp
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
 %dir %{_datadir}/suphp
This page took 0.068783 seconds and 4 git commands to generate.