]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- fix ldflags to link with shared libpython
[packages/apache-mod_python.git] / apache-mod_python.spec
index 99ab24e6fd629514b09fce4a5d403415ebd937fa..c66df8eef0314435a881d8aedd29f7aba4240e08 100644 (file)
@@ -19,7 +19,7 @@ Summary(sl):  Vklju
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
 Version:       3.1.4
-Release:       4
+Release:       5
 License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/modpython/mod_%{mod_name}-%{version}.tgz
@@ -28,6 +28,7 @@ Source1:      %{name}.conf
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-apr-status-is-success.patch
 Patch2:                %{name}-httpd-not-needed.patch
+Patch3:                %{name}-ldflags.patch
 URL:           http://www.modpython.org/
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0.52-7
@@ -38,12 +39,12 @@ BuildRequires:      flex >= 2.5.31
 BuildRequires: python
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache(modules-api) = %apache_modules_api
-Requires:      apache >= 2.0.52-7
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python-devel-tools
-%pyrequires_eq python
+%requires_eq   python-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
@@ -131,16 +132,13 @@ prestandan j
 %endif
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
-
-# new apache needs it
-CFLAGS="-DEAPI %{rpmcflags}"
 %configure \
        --with-apxs=%{apxs}
-
 %{__make} dso
 
 %install
@@ -151,26 +149,24 @@ install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc doc-html/* README COPYRIGHT NEWS CREDITS
-%{_sysconfdir}/httpd.conf/60_mod_python.conf
+%doc examples
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
 %attr(755,root,root) %{py_sitedir}/mod_%{mod_name}/*.so
This page took 0.037594 seconds and 4 git commands to generate.