]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- updated to 2.4
[packages/apache-mod_python.git] / apache-mod_python.spec
index bd70c10e8d5ac6d292ffea4262d0abf5cdb90589..49be525dc15aa83fa3a1c0de1d03fa5affcda630 100644 (file)
@@ -1,7 +1,7 @@
 %define                mod_name        python
 Summary:       A Python for the Apache Web server
 Name:          apache-mod_%{mod_name}
-Version:       2.1
+Version:       2.4
 Release:       1
 License:       distributable
 Group:         Networking/Daemons
@@ -36,12 +36,21 @@ NOTE: This versions should still be considered Beta
 %build
 python %{python_libdir}/compileall.py lib/python/mod_python/
 
-PTHREADS=
+LDFLAGS=
+# RH  
+if [ -f %{python_libdir}/config/libpython%{python_version}.a ]; then 
+       LDFLAGS="$LDFLAGS -L%{python_libdir}/config/ -lpython%{python_version}"
+# PLD 
+else  
+       LDFLAGS="$LDFLAGS -lpython"
+fi  
 if ldd %{python_prefix}/bin/python | grep libpthread >/dev/null; then 
-        PTHREADS=-lpthread
-fi   
+        LDFLAGS="$LDFLAGS -lpthread"
+fi 
+
 cd src
-/usr/sbin/apxs -I%{python_includedir} -lpython $PTHREADS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
+/usr/sbin/apxs -I%{python_includedir} $LDFLAGS -o mod_%{mod_name}.so -c mod_%{mod_name}.c
 cd ..
 gzip -9nf README COPYRIGHT
 
This page took 0.030803 seconds and 4 git commands to generate.