]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- we will compile Python modules manually in spec file - when exception
[packages/apache-mod_python.git] / apache-mod_python.spec
index a8edc75eefe4e541cc5aec15e32927a25671ac26..42a6bc5d0aec2de7960defe920b912a4c8e37fab 100644 (file)
@@ -1,3 +1,9 @@
+
+#
+# todo:
+# - configuration file in /etc/httpd/httpd.conf/ _directory_
+#
+
 %include       /usr/lib/rpm/macros.python
 %define                mod_name        python
 %define        apxs            /usr/sbin/apxs
@@ -19,19 +25,22 @@ Summary(sk):        Interpreter jazyka Perl pre webov
 Summary(sl):   Vkljuèeni pythonski tolmaè za spletni stre¾nik Apache
 Summary(sv):   En inbyggd Python-interpretator för webbservern Apache
 Name:          apache-mod_%{mod_name}
-Version:       2.7.8
-Release:       3
-License:       distributable
+Version:       3.0.1
+Release:       0.2
+License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.modpython.org/dist/mod_%{mod_name}-%{version}.tgz
-Patch0:                %{name}-shared.patch
+#Patch0:               %{name}-shared.patch
 Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-Makefile-in.patch
+Patch2:                %{name}-no-compile.patch
 Patch3:                %{name}-cleanup.patch
+# PLD keeps static libs in /usr/lib default python install stores them in .../config/
+Patch4:                %{name}-static-lib-dir-fix.patch
+
 URL:           http://www.modpython.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: apache-devel
+BuildRequires: apache-devel >= 2.0.44
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
 BuildRequires: %{apxs}
@@ -119,13 +128,16 @@ prestandan j
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
-%patch0 -p1
+# Patch reverted. Dynamic build makes apache segfault on all my i686 machines
+# No working reports collected on IRC/mailing lists.
+#%patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1
+#%patch4 -p1
 
 %build
-aclocal
+%{__aclocal}
 %{__autoconf}
 
 # new apache needs it
@@ -141,20 +153,19 @@ install -d $RPM_BUILD_ROOT{%{apache_moddir},%{py_sitedir}/mod_%{mod_name}}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README COPYRIGHT NEWS CREDITS
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n %{mod_name} %{apache_moddir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
@@ -163,6 +174,7 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc doc-html/*
-%doc {README,COPYRIGHT,NEWS,CREDITS}.gz
+%doc README COPYRIGHT NEWS CREDITS
 %attr(755,root,root) %{apache_moddir}/*
-%{py_sitedir}/mod_%{mod_name}
+%dir %{py_sitedir}/mod_%{mod_name}
+%{py_sitedir}/mod_%{mod_name}/*.py[co]
This page took 0.035393 seconds and 4 git commands to generate.