]> git.pld-linux.org Git - packages/apache-mod_python.git/blobdiff - apache-mod_python.spec
- apache module does not require python binary
[packages/apache-mod_python.git] / apache-mod_python.spec
index 9fead672ab59339782402d87c65e3c95de6f4c55..3ac11be5a93b4753c690762f57afe4b55d4d6b07 100644 (file)
@@ -38,12 +38,12 @@ BuildRequires:      flex >= 2.5.31
 BuildRequires: python
 BuildRequires: python-devel >= 2.2
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apr >= 1:1.0.0
 # apache.py uses pdb module
 Requires:      python-devel-tools
-%pyrequires_eq python
+%requires_eq   python-libs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
@@ -135,12 +135,8 @@ prestandan j
 %build
 %{__aclocal}
 %{__autoconf}
-
-# new apache needs it
-CFLAGS="-DEAPI %{rpmcflags}"
 %configure \
        --with-apxs=%{apxs}
-
 %{__make} dso
 
 %install
@@ -157,20 +153,17 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/60_mod_python.conf
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q httpd restart
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q httpd restart
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc doc-html/* README COPYRIGHT NEWS CREDITS
+%doc examples
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*.so
 %dir %{py_sitedir}/mod_%{mod_name}
This page took 0.028306 seconds and 4 git commands to generate.