ac26 reverted, no longer needed
[packages/akode.git] / kde-common-PLD.patch
index 94a2df13f348dfb2ce55e7aaf8a496d0fef7da07..0828582ef2453aec4d31e8542b3c41433b2b8324 100644 (file)
@@ -1,11 +1,7 @@
-Index: kde-common/admin/acinclude.m4.in
-===================================================================
-RCS file: /home/kde/kde-common/admin/acinclude.m4.in,v
-retrieving revision 2.455
-diff -u -p -r2.455 acinclude.m4.in
---- kde-common/admin/acinclude.m4.in   12 May 2004 08:09:31 -0000      2.455
-+++ kde-common/admin/acinclude.m4.in   3 Jun 2004 10:52:36 -0000
-@@ -428,7 +428,7 @@ AC_DEFUN([KDE_SET_DEFAULT_PATHS],
+diff -urN kdelibs-3.5.3.or/admin/acinclude.m4.in kdelibs-3.5.3/admin/acinclude.m4.in
+--- kdelibs-3.5.3.or/admin/acinclude.m4.in     2006-05-23 13:02:06.000000000 +0000
++++ kdelibs-3.5.3/admin/acinclude.m4.in        2006-07-01 14:55:49.345359250 +0000
+@@ -428,7 +428,7 @@
  if test "$1" = "default"; then
  
    if test -z "$kde_htmldir"; then
@@ -14,14 +10,78 @@ diff -u -p -r2.455 acinclude.m4.in
    fi
    if test -z "$kde_appsdir"; then
      kde_appsdir='\${datadir}/applnk'
-@@ -4276,32 +4276,11 @@ AC_DEFUN([AC_CHECK_UTMP_FILE],
+@@ -2977,41 +2977,6 @@
+ AC_DEFUN([KDE_CHECK_FOR_BAD_COMPILER],
+ [
+-  AC_MSG_CHECKING([whether $CC is blacklisted])
+-
+-  dnl In theory we have tu run this test against $CC and $CXX
+-  dnl in C and in C++ mode, because its perfectly legal for
+-  dnl the user to mix compiler versions, since C has a defined
+-  dnl ABI. 
+-  dnl 
+-  dnl For now, we assume the user is not on crack.
+-
+-  AC_TRY_COMPILE([
+-#ifdef __GNUC__
+-#if __GNUC__ == 4 && __GNUC_MINOR__ == 0 && __GNUC_PATCHLEVEL__ == 0
+-choke me
+-#endif
+-#endif
+-], ,
+-  kde_bad_compiler=no, 
+-  kde_bad_compiler=yes
+-)
+-
+-  AC_MSG_RESULT($kde_bad_compiler)
+-
+-if test "$kde_bad_compiler" = "yes"; then
+-  AC_MSG_ERROR([
+-
+-This particular compiler version is blacklisted because it
+-is known to miscompile KDE. Please use a newer version, or
+-if that is not yet available, choose an older version. 
+-
+-Please do not report a bug or bother us reporting this
+-configure error. We know about it, and we introduced
+-it by intention to avoid untraceable bugs or crashes in KDE.
+-
+-])
+-fi
+ ])
+@@ -3153,8 +3118,6 @@
+   AC_PROG_CXX
+-  KDE_CHECK_FOR_BAD_COMPILER
+-
+   if test "$GXX" = "yes" || test "$CXX" = "KCC"; then
+     if test "$kde_use_debug_code" != "no"; then
+       if test "$CXX" = "KCC"; then
+@@ -4579,9 +4542,9 @@
+   LIBPYTHON=-lpython$version
+ fi
+-AC_FIND_FILE(python$version/copy.py, $python_libdirs, python_moddir)
++AC_FIND_FILE(python$version/copy.pyc, "/usr/share" , python_moddir)
+ python_moddir=$python_moddir/python$version
+-if test ! -r $python_moddir/copy.py; then
++if test ! -r $python_moddir/copy.pyc; then
+   python_moddir=no
+ fi
+@@ -4728,32 +4691,11 @@
  [
      AC_MSG_CHECKING([for utmp file])
  
 -    AC_CACHE_VAL(kde_cv_utmp_file,
 -    [
 -    kde_cv_utmp_file=no
--
++    AC_CACHE_VAL(kde_cv_utmp_file, [kde_cv_utmp_file=/var/run/utmpx])
 -    for ac_file in    \
 -                      \
 -      /var/run/utmp \
@@ -35,8 +95,7 @@ diff -u -p -r2.455 acinclude.m4.in
 -     fi
 -    done
 -    ])
-+    AC_CACHE_VAL(kde_cv_utmp_file, [kde_cv_utmp_file=/var/run/utmpx])
+-
 -    if test "$kde_cv_utmp_file" != "no"; then
 -      AC_DEFINE_UNQUOTED(UTMP, "$kde_cv_utmp_file", [Define the file for utmp entries])
 -      $1
@@ -51,7 +110,7 @@ diff -u -p -r2.455 acinclude.m4.in
  ])
  
  
-@@ -5078,7 +5057,7 @@ if test "${with_qt_dir+set}" = set; then
+@@ -5536,7 +5478,7 @@
    kde_qtdir="$with_qt_dir"
  fi
  
@@ -60,3 +119,4 @@ diff -u -p -r2.455 acinclude.m4.in
  AC_MSG_RESULT($QTDOCDIR)
  
  AC_SUBST(QTDOCDIR)
+
This page took 0.072145 seconds and 4 git commands to generate.