]> git.pld-linux.org Git - packages/aircrack-ng.git/blame - aircrack-ng.spec
disable custom optimization level
[packages/aircrack-ng.git] / aircrack-ng.spec
CommitLineData
8ac129fd 1#
2# TODO:
3# - PLD it more
74b62dd0 4# - sbin/bin - change to bin?
41e6054e
SS
5# - finish ext_scripts bcond:
6# -- check python related BR and R
7# -- fix packaging python releated stuff
8# -- create subpackage for airoscript
9# -- fix directory for airoscript*.conf files
10# -- fix installation of airoscript desktop files
8ac129fd 11#
05fa9722
SS
12# Conditional build:
13%bcond_without sqlite # build without sqlite support
05fa9722 14%bcond_without experimental
9a781134 15%bcond_with ext_scripts # build with extra scripts (NFY)
31226a37 16%define lib_ver 1.7.0
05b22c16 17
8ac129fd 18Summary: Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
1b61970c 19Summary(pl.UTF-8): Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
8ac129fd 20Name: aircrack-ng
31226a37 21Version: 1.7
f8ed0a16 22Release: 2
8ac129fd 23License: GPL
24Group: Applications/Networking
2eaae0e6 25Source0: http://download.aircrack-ng.org/%{name}-%{version}.tar.gz
31226a37 26# Source0-md5: a918ea7146f91d8c799fb770c38f4bec
fdaae083 27URL: http://www.aircrack-ng.org/
652f1d7d
JP
28BuildRequires: autoconf >= 2.52
29BuildRequires: automake >= 1:1.14
4a0a71d0 30BuildRequires: hwloc-devel
4a0a71d0 31BuildRequires: libgcrypt-devel >= 1.2.0
652f1d7d 32BuildRequires: libnl-devel >= 1:3.2
4a0a71d0 33BuildRequires: libpcap-devel
652f1d7d 34BuildRequires: libstdc++-devel >= 6:4.8.1
31226a37 35BuildRequires: libtool
2eaae0e6 36BuildRequires: pcre-devel
05b22c16 37BuildRequires: pkgconfig
652f1d7d 38BuildRequires: python3
84f934ef 39BuildRequires: rpmbuild(macros) >= 2.007
05fa9722 40%{?with_sqlite:BuildRequires: sqlite3-devel}
05b22c16 41BuildRequires: zlib-devel
652f1d7d
JP
42Requires: awk
43Requires: coreutils
ca994d52
SS
44Requires: ethtool
45Requires: grep
652f1d7d 46Requires: iproute2
ca994d52 47Requires: iw
652f1d7d
JP
48Requires: libnl >= 1:3.2
49Requires: pciutils
31226a37 50Requires: usbutils
652f1d7d
JP
51Requires: util-linux
52Requires: virtual(module-tools)
53Suggests: wireless-tools
8ac129fd 54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56%description
57aircrack-ng is a set of tools for auditing wireless networks. It's an
58enhanced/reborn version of aircrack. It consists of airodump-ng (an
59802.11 packet capture program), aireplay-ng (an 802.11 packet
60injection program), aircrack (static WEP and WPA-PSK cracking),
61airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
62capture files (merge, convert, etc.).
63
00504ee3
JR
64%description -l pl.UTF-8
65aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
66Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
67airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
68wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
69WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
70WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
fdaae083 71convert, etc.).
8ac129fd 72
4a0a71d0 73%package devel
31226a37 74Summary: Development files for %{name}
4a0a71d0 75Summary(pl.UTF-8): Pliki deweloperskie dla %{name}
31226a37
KM
76Group: Development/Libraries
77Requires: %{name} = %{version}
4a0a71d0
KM
78
79%description devel
80Development files for %{name}.
81
31226a37 82%description devel -l pl.UTF-8
4a0a71d0
KM
83Pliki deweloperskie dla %{name}
84
8ac129fd 85%prep
2eaae0e6 86%setup -q
4a0a71d0 87# Force python3 interpreter
d18bfee0 88grep -r -l '#!/usr/bin/env python' scripts | xargs sed -i -e 's|#!/usr/bin/env python|#!%{__python3}|g'
eaff7cfd 89
8ac129fd 90%build
4a0a71d0 91# GCC LTO objects must be "fat" to avoid assembly errors
69548d01 92export CFLAGS="%{rpmcflags} -ffat-lto-objects -fcommon"
4a0a71d0 93
2eaae0e6
AM
94%{__libtoolize}
95%{__aclocal} -I build/m4/stubs -I build/m4
96%{__autoconf}
4a0a71d0 97%{__autoheader}
2eaae0e6
AM
98%{__automake}
99%configure \
f8ed0a16 100 PYTHON=%{__python3} \
2eaae0e6 101 ETHTOOL=/sbin/ethtool \
1be77fbc 102 --disable-silent-rules \
4a0a71d0
KM
103 --with-gcrypt \
104 --enable-libnl \
2eaae0e6
AM
105 --with%{!?with_experimental:out}-experimental \
106 --with%{!?with_ext_scripts:out}-ext-scripts \
f63e847d 107 --without-opt \
2eaae0e6
AM
108 --with-%{!?with_sqlite:out}-sqlite3 \
109
110%{__make}
8ac129fd 111
112%install
113rm -rf $RPM_BUILD_ROOT
fdaae083 114install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
8ac129fd 115
74b62dd0 116%{__make} install \
2eaae0e6 117 DESTDIR=$RPM_BUILD_ROOT
8ac129fd 118
4a0a71d0
KM
119find $RPM_BUILD_ROOT -type f \( -name "*.la" -o -name "*.a" \) -delete -print
120
8ac129fd 121%clean
122rm -rf $RPM_BUILD_ROOT
123
2eaae0e6
AM
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
8ac129fd 127%files
128%defattr(644,root,root,755)
69aba94a 129%doc AUTHORS ChangeLog README test patches
a1116914
SS
130%attr(755,root,root) %{_bindir}/aircrack-ng
131%attr(755,root,root) %{_bindir}/airdecap-ng
132%attr(755,root,root) %{_bindir}/airdecloak-ng
05fa9722 133%{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
a1116914
SS
134%attr(755,root,root) %{_bindir}/ivstools
135%attr(755,root,root) %{_bindir}/kstats
136%attr(755,root,root) %{_bindir}/makeivs-ng
137%attr(755,root,root) %{_bindir}/packetforge-ng
138%attr(755,root,root) %{_bindir}/wpaclean
139%attr(755,root,root) %{_sbindir}/airbase-ng
140%attr(755,root,root) %{_sbindir}/aireplay-ng
141%attr(755,root,root) %{_sbindir}/airmon-ng
142%attr(755,root,root) %{_sbindir}/airodump-ng
143%attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
2eaae0e6 144%attr(755,root,root) %{_sbindir}/airventriloquist-ng
a1116914
SS
145%attr(755,root,root) %{_sbindir}/airserv-ng
146%attr(755,root,root) %{_sbindir}/airtun-ng
31226a37
KM
147%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-%{lib_ver}.so
148%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa.so
84f934ef 149%ifarch %{ix86} %{x8664} x32
31226a37
KM
150%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx-%{lib_ver}.so
151%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx2-%{lib_ver}.so
152%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx2.so
153%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-avx.so
154%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-sse2-%{lib_ver}.so
155%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-x86-sse2.so
84f934ef
JP
156%endif
157%ifarch %{arm_with_neon}
158%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-arm-neon-%{lib_ver}.so
159%attr(755,root,root) %{_libdir}/libaircrack-ce-wpa-arm-neon.so
160%endif
31226a37
KM
161%attr(755,root,root) %{_libdir}/libaircrack-osdep-%{lib_ver}.so
162%attr(755,root,root) %{_libdir}/libaircrack-osdep.so
2eaae0e6 163
a1116914
SS
164%{_mandir}/man1/aircrack-ng.1*
165%{_mandir}/man1/airdecap-ng.1*
166%{_mandir}/man1/airdecloak-ng.1*
05fa9722 167%{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
a1116914
SS
168%{_mandir}/man1/besside-ng-crawler.1*
169%{_mandir}/man1/ivstools.1*
170%{_mandir}/man1/kstats.1*
171%{_mandir}/man1/makeivs-ng.1*
172%{_mandir}/man1/packetforge-ng.1*
173%{_mandir}/man1/wpaclean.1*
174%{_mandir}/man8/airbase-ng.8*
175%{_mandir}/man8/aireplay-ng.8*
2eaae0e6 176%{_mandir}/man8/airventriloquist-ng.8*
a1116914
SS
177%{_mandir}/man8/airmon-ng.8*
178%{_mandir}/man8/airodump-ng-oui-update.8*
179%{_mandir}/man8/airodump-ng.8*
180%{_mandir}/man8/airserv-ng.8*
181%{_mandir}/man8/airtun-ng.8*
05fa9722
SS
182
183%if %{with experimental}
a3476d37 184%attr(755,root,root) %{_bindir}/besside-ng-crawler
05fa9722
SS
185%attr(755,root,root) %{_bindir}/buddy-ng
186%attr(755,root,root) %{_sbindir}/besside-ng
187%attr(755,root,root) %{_sbindir}/easside-ng
188%attr(755,root,root) %{_sbindir}/tkiptun-ng
189%attr(755,root,root) %{_sbindir}/wesside-ng
190%{_mandir}/man1/buddy-ng.1*
ee151981 191%{_mandir}/man8/besside-ng.8*
05fa9722
SS
192%{_mandir}/man8/easside-ng.8*
193%{_mandir}/man8/tkiptun-ng.8*
194%{_mandir}/man8/wesside-ng.8*
195%endif
4a0a71d0
KM
196
197%files devel
31226a37 198%defattr(644,root,root,755)
4a0a71d0 199%{_includedir}/%{name}
This page took 0.355634 seconds and 4 git commands to generate.