]> git.pld-linux.org Git - packages/QtKeychain.git/blame_incremental - QtKeychain.spec
drop qt*-build, and qt*-qmake from -devel deps
[packages/QtKeychain.git] / QtKeychain.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without qt4 # build Qt4
4%bcond_without qt5 # build Qt5
5
6Summary: Qt API to store passwords and other secret data securely
7Name: QtKeychain
8Version: 0.4.0
9Release: 2
10License: Modified BSD License
11Group: Libraries
12Source0: https://github.com/frankosterfeld/qtkeychain/archive/v%{version}/%{name}-%{version}.tar.gz
13# Source0-md5: e4e48d8742a9fd2664425d58be236424
14URL: https://github.com/frankosterfeld/qtkeychain
15BuildRequires: cmake
16BuildRequires: libstdc++-devel
17BuildRequires: rpmbuild(find_lang) >= 1.37
18%if %{with qt4}
19BuildRequires: QtCore-devel
20BuildRequires: QtDBus-devel
21BuildRequires: qt4-build
22BuildRequires: qt4-linguist
23BuildRequires: qt4-qmake
24%endif
25%if %{with qt5}
26BuildRequires: Qt5Core-devel
27BuildRequires: Qt5DBus-devel
28BuildRequires: qt5-build
29BuildRequires: qt5-linguist
30BuildRequires: qt5-qmake
31%endif
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35QtKeychain a Qt API to store passwords and other secret data securely.
36
37How the data is stored depends on the platform:
38- Mac OS X: Passwords are stored in the OS X Keychain.
39- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
40 tries to use KWallet (via D-Bus), if available.
41- Windows: Windows does not provide a service for secure storage.
42 QtKeychain uses the Windows API function
43
44%package devel
45Summary: Development files for QtKeychain
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50This package contains libraries and header files for developing
51applications that use QKeychain.
52
53%package -n Qt5Keychain
54Summary: Qt API to store passwords and other secret data securely
55Group: Libraries
56
57%description -n Qt5Keychain
58QtKeychain a Qt API to store passwords and other secret data securely.
59
60How the data is stored depends on the platform:
61- Mac OS X: Passwords are stored in the OS X Keychain.
62- Linux/Unix: If running, GNOME Keyring is used, otherwise qtkeychain
63 tries to use KWallet (via D-Bus), if available.
64- Windows: Windows does not provide a service for secure storage.
65 QtKeychain uses the Windows API function
66
67%package -n Qt5Keychain-devel
68Summary: Development files for QtKeychain
69Group: Development/Libraries
70Requires: Qt5Keychain = %{version}-%{release}
71
72%description -n Qt5Keychain-devel
73This package contains libraries and header files for developing
74applications that use QKeychain.
75
76%prep
77%setup -q -n qtkeychain-%{version}
78
79%build
80%if %{with qt4}
81install -d build-qt4
82cd build-qt4
83%cmake \
84 -DBUILD_WITH_QT4=ON \
85 ..
86%{__make}
87cd ..
88%endif
89
90%if %{with qt5}
91install -d build-qt5
92cd build-qt5
93%cmake \
94 -DBUILD_WITH_QT4=OFF \
95 ..
96%{__make}
97%endif
98
99%install
100rm -rf $RPM_BUILD_ROOT
101%if %{with qt4}
102%{__make} -C build-qt4 install \
103 DESTDIR=$RPM_BUILD_ROOT
104
105%find_lang qtkeychain --with-qm
106%endif
107
108%if %{with qt5}
109%{__make} -C build-qt5 install \
110 DESTDIR=$RPM_BUILD_ROOT
111
112%find_lang qtkeychain --with-qm
113%endif
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119%postun -p /sbin/ldconfig
120
121%if %{with qt4}
122%files -f qtkeychain.lang
123%defattr(644,root,root,755)
124%doc COPYING ReadMe.txt ChangeLog
125%attr(755,root,root) %{_libdir}/libqtkeychain.so.*.*.*
126%ghost %{_libdir}/libqtkeychain.so.0
127
128%files devel
129%defattr(644,root,root,755)
130%{_includedir}/qtkeychain
131%{_libdir}/libqtkeychain.so
132%{_libdir}/cmake/QtKeychain
133%endif
134
135%if %{with qt5}
136%files -n Qt5Keychain
137%defattr(644,root,root,755)
138%attr(755,root,root) %{_libdir}/libqt5keychain.so.*.*.*
139%ghost %{_libdir}/libqt5keychain.so.0
140
141%files -n Qt5Keychain-devel
142%defattr(644,root,root,755)
143%{_includedir}/qt5keychain
144%{_libdir}/libqt5keychain.so
145%{_libdir}/cmake/Qt5Keychain
146%endif
This page took 0.970165 seconds and 4 git commands to generate.