]> git.pld-linux.org Git - packages/OpenAL.git/blame - OpenAL.spec
- rel 3
[packages/OpenAL.git] / OpenAL.spec
CommitLineData
68071dbf 1#
a35955a2 2# Conditional build:
3#
e62907a5
JB
4%bcond_without alsa # without ALSA support
5%bcond_with arts # with aRts support
e62907a5 6%bcond_without esd # without esd support
a26f1dac
JB
7%bcond_without mmx # don't use MMX
8#
9%ifnarch %{ix86} %{x8664}
10%undefine with_mmx
11%endif
12%ifarch i386 i486
13%undefine with_mmx
14%endif
d451b59a 15Summary: Open Audio Library
8be14136 16Summary(pl.UTF-8): Otwarta Biblioteka Dźwięku
6a3db3d8 17Name: OpenAL
f2b62104 18Version: 0.0.8
a3ff4755 19Release: 3
6a3db3d8 20License: LGPL
68071dbf 21Group: Libraries
43b5504a 22Source0: http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
23# Source0-md5: 641cf53761f35ee979f3e888614797a0
827050d4 24URL: http://www.openal.org/
a7443cb5 25Patch0: %{name}-alc.h.patch
b0b40567 26BuildRequires: SDL-devel
e62907a5
JB
27%{?with_alsa:BuildRequires: alsa-lib-devel}
28%{?with_arts:BuildRequires: artsc-devel}
d3133096
JB
29BuildRequires: autoconf >= 2.56
30BuildRequires: automake
e62907a5 31%{?with_esd:BuildRequires: esound-devel}
a26f1dac
JB
32%if %{with mmx}
33# MMX code triggers ICE in gcc 3.3.x
34BuildRequires: gcc >= 5:3.4.0
35%endif
d3133096 36BuildRequires: libtool
b0b40567 37BuildRequires: libvorbis-devel
a26f1dac 38%ifarch %{ix86}
e62907a5 39%{?with_mmx:BuildRequires: nasm}
a26f1dac
JB
40%endif
41BuildRequires: pkgconfig
b0b40567 42BuildRequires: smpeg-devel
6a3db3d8 43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
a26f1dac
JB
45%if %{with mmx}
46%define specflags_ia32 -mmmx
47%else
48%define specflags_ia32 -U__MMX__
49%endif
50
6a3db3d8 51%description
52OpenAL, the Open Audio Library, is a joint effort to create an open,
53vendor-neutral, cross-platform API for interactive, primarily
54spatialized audio. OpenAL's primary audience are application
55developers and desktop users that rely on portable standards like
56OpenGL, for games and other multimedia applications. OpenAL is already
57supported by a number of hardware vendors and developers.
58
a4959810
JR
59%description -l pl.UTF-8
60OpenAL, otwarta biblioteka dźwięku, to połączony wysiłek w celu
61stworzenia otwartego, niezależnego od producentów, międzyplatformowego
62interfejsu projektowania aplikacji w części obsługi dźwięku.
63Biblioteka adresowana jest do twórców aplikacji i użytkowników,
64którzy wybierają przenośne standardy, jak OpenGL, w grach i
65aplikacjach multimedialnych. OpenAL posiada już wsparcie wielu
66dostarczycieli sprzętu i programistów.
d451b59a 67
6a3db3d8 68%package devel
d451b59a 69Summary: Headers for OpenAL
8be14136 70Summary(pl.UTF-8): Pliki nagłówkowe do OpenAL
68071dbf 71Group: Development/Libraries
e62907a5 72Requires: %{name} = %{version}-%{release}
6a3db3d8 73
74%description devel
d451b59a 75Header files for OpenAL-based programs.
6a3db3d8 76
a4959810
JR
77%description devel -l pl.UTF-8
78Pliki nagłówkowe potrzebne przy budowaniu programów opartych na
d451b59a 79OpenAL.
80
6a3db3d8 81%package static
82Summary: OpenAL static library
8be14136 83Summary(pl.UTF-8): Statyczna biblioteka OpenAL
68071dbf 84Group: Development/Libraries
e62907a5 85Requires: %{name}-devel = %{version}-%{release}
6a3db3d8 86
87%description static
88OpenAL static library.
89
a4959810 90%description static -l pl.UTF-8
a9a6d37c 91Biblioteka OpenAL do konsolidacji statycznej.
6a3db3d8 92
6a3db3d8 93%prep
43b5504a 94%setup -q -n openal-%{version}
a7443cb5 95%patch0 -p1
68071dbf 96
6a3db3d8 97%build
7e6377c0 98%{__libtoolize}
99%{__aclocal} -I admin/autotools/m4
100%{__autoconf}
101%{__autoheader}
d3133096 102%{__automake}
68071dbf 103%configure \
7e6377c0 104 --%{?with_alsa:en}%{!?with_alsa:dis}able-alsa{,-dlopen} \
105 --%{?with_arts:en}%{!?with_arts:dis}able-arts{,-dlopen} \
106 --%{?with_esd:en}%{!?with_esd:dis}able-esd{,-dlopen} \
a35955a2 107 --enable-sdl --enable-sdl-dlopen \
68071dbf 108 --enable-capture \
a35955a2 109 --enable-linux \
110 --enable-null \
7e6377c0 111%ifarch amd64 x86_64 athlon i686 i586
a26f1dac
JB
112 --enable-optim-generic \
113%endif
a35955a2 114 --enable-waveout \
115 --enable-vorbis --enable-vorbis-dlopen \
116 --enable-mp3 --enable-mp3-dlopen \
a26f1dac 117 --with-gcc="%{__cc}"
68071dbf 118
b37eb751 119%{__make}
6a3db3d8 120
121%install
122rm -rf $RPM_BUILD_ROOT
d451b59a 123
f2c02821 124%{__make} install \
68071dbf 125 DESTDIR=$RPM_BUILD_ROOT
d451b59a 126
6a3db3d8 127%clean
128rm -rf $RPM_BUILD_ROOT
129
404a1bc6
JB
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
6a3db3d8 133%files
3f81b215 134%defattr(644,root,root,755)
f2c02821 135%doc ChangeLog NOTES TODO
a26f1dac 136%attr(755,root,root) %{_libdir}/libopenal.so.*.*.*
6a3db3d8 137
138%files devel
139%defattr(644,root,root,755)
a26f1dac
JB
140%doc common/specification/OpenAL1-1Spec.pdf
141%attr(755,root,root) %{_bindir}/openal-config
142%attr(755,root,root) %{_libdir}/libopenal.so
143%{_libdir}/libopenal.la
68071dbf 144%{_includedir}/AL
a26f1dac 145%{_pkgconfigdir}/openal.pc
d451b59a 146
6a3db3d8 147%files static
3f81b215 148%defattr(644,root,root,755)
a26f1dac 149%{_libdir}/libopenal.a
This page took 0.53753 seconds and 4 git commands to generate.