]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
Version: 18.1.6
[packages/Mesa.git] / Mesa.spec
index 4ae6f994ce4f570a7d3712e9171e5d8756502495..ad9ce17f67c355246df64c769f59fcbe2ccab213 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
 # minimal supported xserver version
 %define                xserver_ver             1.5.0
 # other packages
-%ifarch %{arm}
-%define                libdrm_ver              2.4.80
-%else
-%define                libdrm_ver              2.4.79
-%endif
+%define                libdrm_ver              2.4.91
 %define                dri2proto_ver           2.8
 %define                dri3proto_ver           1.0
 %define                glproto_ver             1.4.14
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
-Version:       17.1.6
+Version:       18.1.6
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
-# Source0-md5: 54758bf842f9ea53c8b57cce4311b87e
+# Source0-md5: f798814c0b93ca3c1cf395bb936db3e0
 Patch0:                %{name}-link.patch
+Patch1:                glvnd-fix-gl-dot-pc.patch
+Patch2:                %{name}-munmap_null.patch
 URL:           http://www.mesa3d.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -86,13 +84,12 @@ BuildRequires:      libstdc++-devel >= 6:4.2.0
 BuildRequires: libtalloc-devel >= 2:2.0.1
 BuildRequires: libtool >= 2:2.2
 %{?with_va:BuildRequires:      libva-devel >= 1.6.0}
-%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.38.0}
+%{?with_va:BuildRequires:      pkgconfig(libva) >= 0.39.0}
 BuildRequires: libvdpau-devel >= 1.1
-BuildRequires: libxcb-devel >= 1.10
-%{?with_gallium_radeon:BuildRequires:  llvm-devel >= 3.8}
-# for swr driver
-%{?with_gallium:BuildRequires: llvm-devel >= 3.9}
-%{?with_radv:BuildRequires:    llvm-devel >= 3.9}
+BuildRequires: libxcb-devel >= 1.13
+# gallium core requires 3.3.0, OpenCL/r600 require 3.9.0, swr/radeonsi/radv 4.0.0
+%{?with_gallium:BuildRequires: llvm-devel >= 4.0}
+%{?with_radv:BuildRequires:    llvm-devel >= 4.0}
 %{?with_opencl:BuildRequires:  llvm-libclc}
 # for SHA1 (could use also libmd/libsha1/libgcrypt/openssl instead)
 BuildRequires: nettle-devel
@@ -111,6 +108,7 @@ BuildRequires:      rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
 # wayland-{client,server}
 %{?with_wayland:BuildRequires: wayland-devel >= 1.11.0}
+%{?with_wayland:BuildRequires: wayland-protocols >= 1.8}
 BuildRequires: xorg-lib-libXdamage-devel >= 1.1
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXfixes-devel
@@ -124,7 +122,7 @@ BuildRequires:      xorg-proto-glproto-devel >= %{glproto_ver}
 BuildRequires: xorg-proto-presentproto-devel >= %{presentproto_ver}
 BuildRequires: xorg-util-makedepend
 %if %{with gallium}
-%{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 3.4}
+%{?with_lm_sensors:BuildRequires:      lm_sensors-devel >= 4.0}
 BuildRequires: xorg-proto-xextproto-devel >= 7.0.99.1
 BuildRequires: xorg-xserver-server-devel >= %{xserver_ver}
 %endif
@@ -134,7 +132,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # libGLESv1_CM, libGLESv2, libGL, libOSMesa:
 #  _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
 # libgbm: circular dependency with libEGL (wayland_buffer_is_drm symbol)
-%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libOSMesa.so.* libgbm.*.so.*
+%define                skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libOSMesa.so.* libgbm.*.so.* libGLX_mesa.so.0.*
 
 # llvm build broken
 %define                filterout_ld    -Wl,--as-needed
@@ -225,6 +223,7 @@ License:    MIT
 Group:         X11/Libraries
 Requires:      %{name}-libglapi = %{version}-%{release}
 Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
 Requires:      xorg-lib-libXdamage >= 1.1
 Provides:      OpenGL = 4.5
 Provides:      OpenGL-GLX = 1.4
@@ -1267,6 +1266,10 @@ radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD.
 %prep
 %setup -q -n mesa-%{version}
 %patch0 -p1
+%if %{with glvnd}
+%patch1 -p1
+%endif
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -1337,7 +1340,7 @@ vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
        %{__enable opencl} \
        %{__enable va} \
        --enable-vdpau \
-       %{?with_omx:--enable-omx} \
+       %{?with_omx:--enable-omx-bellagio} \
        %{?with_xa:--enable-xa} \
        --enable-xvmc \
        --with-gallium-drivers=${gallium_drivers} \
@@ -1422,12 +1425,22 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with egl}
 %files libEGL
 %defattr(644,root,root,755)
+%if %{with glvnd}
+%attr(755,root,root) %{_libdir}/libEGL_mesa.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libEGL_mesa.so.0
+%{_datadir}/glvnd/egl_vendor.d/50_mesa.json
+%else
 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
+%endif
 
 %files libEGL-devel
 %defattr(644,root,root,755)
+%if %{with glvnd}
+%attr(755,root,root) %{_libdir}/libEGL_mesa.so
+%else
 %attr(755,root,root) %{_libdir}/libEGL.so
+%endif
 %dir %{_includedir}/EGL
 %{_includedir}/EGL/egl.h
 %{_includedir}/EGL/eglext.h
This page took 0.208876 seconds and 4 git commands to generate.