]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
up to 20.3.4
[packages/Mesa.git] / Mesa.spec
index 5963b40f2d45de31b35984dd9d35acc80c6fdbe8..468ed7788523a26af40a284db2c501865edd62c3 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -1,15 +1,16 @@
 # TODO: libtizonia >= 0.10.0 as an alternative for bellagio?
-# opencl-spirv? BR: spirv-tools-devel >= 2018.0, pkgconfig(LLVMSPIRVLib) >= 0.2.1
 #
 # Conditional build:
 %bcond_without gallium         # gallium drivers
 %bcond_with    gallium_i915    # gallium i915 driver instead of dri i915 driver
 %bcond_without gallium_nouveau # gallium nouveau driver
 %bcond_without gallium_radeon  # gallium radeon drivers
+%bcond_without gallium_zink    # gallium zink driver (based on vulkan)
 %bcond_without egl             # EGL libraries
 %bcond_without gbm             # Graphics Buffer Manager
 %bcond_without nine            # Nine Direct3D 9+ state tracker (for Wine)
 %bcond_without opencl          # OpenCL support
+%bcond_without opencl_spirv    # OpenCL SPIRV support
 %bcond_without ocl_icd         # OpenCL as ICD (installable client driver)
 %bcond_with    glvnd           # OpenGL vendor neutral dispatcher support
 %bcond_without omx             # OpenMAX (Bellagio OMXIL) support
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver               7.1.0
 # other packages
-%define                libdrm_ver              2.4.100
+%define                libdrm_ver              2.4.102
 %define                dri2proto_ver           2.8
 %define                glproto_ver             1.4.14
 %define                zlib_ver                1.2.8
-%define                wayland_ver             1.11
+%define                wayland_ver             1.15
 %define                llvm_ver                8.0.0
 %define                gcc_ver                 6:4.8.0
 
 %undefine      with_swr
 %endif
 
+%if %{with gallium_radeon} || %{with gallium_nouveau}
+%define                with_vdpau      1
+%define                with_xvmc       1
+%endif
+
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     Wolnodostępna implementacja standardu OpenGL
 Name:          Mesa
-Version:       19.3.3
+Version:       20.3.4
 Release:       1
 License:       MIT (core) and others - see license.html file
 Group:         X11/Libraries
 #Source0:      ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
 ## Source0-md5:        7c61a801311fb8d2f7b3cceb7b5cf308
 Source0:       https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
-# Source0-md5: 56141f1a25ce387139ca9235b47a8b62
+# Source0-md5: ad5feb0518815f9df11fb60f1034ca40
 Patch0:                nouveau_no_rtti.patch
 Patch1:                i9x5-tex-ignore-the-diff-between-GL_TEXTURE_2D-and-GL_TEXTURE_RECTANGLE.patch
 URL:           http://www.mesa3d.org/
+%{?with_opencl_spirv:BuildRequires:    SPIRV-LLVM-Translator-devel >= 8.0.1.3}
+%{?with_gallium_zink:BuildRequires:    Vulkan-Loader-devel}
+BuildRequires: bison > 2.3
 %{?with_opencl:BuildRequires:  clang-devel >= %{llvm_ver}}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel >= 1.95
+BuildRequires: flex
 BuildRequires: gcc >= %{gcc_ver}
 BuildRequires: libdrm-devel >= %{libdrm_ver}
-%{?with_glvnd:BuildRequires:   libglvnd-devel >= 0.2.0}
+%{?with_glvnd:BuildRequires:   libglvnd-devel >= 1.3.2}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= %{gcc_ver}
 BuildRequires: libunwind-devel
 %{?with_va:BuildRequires:      libva-devel}
 %{?with_va:BuildRequires:      pkgconfig(libva) >= 0.39.0}
-BuildRequires: libvdpau-devel >= 1.1
+%{?with_vdpau:BuildRequires:   libvdpau-devel >= 1.1}
 BuildRequires: libxcb-devel >= 1.13
 %{?with_gallium:BuildRequires: llvm-devel >= %{llvm_ver}}
 %{?with_radv:BuildRequires:    llvm-devel >= %{llvm_ver}}
 %{?with_opencl:BuildRequires:  llvm-libclc}
 %{?with_omx:BuildRequires:     libomxil-bellagio-devel}
-BuildRequires: meson >= 0.51
+BuildRequires: meson >= 0.52
 BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
 BuildRequires: pkgconfig(talloc) >= 2.0.1
@@ -104,16 +114,18 @@ BuildRequires:    python3 >= 1:3.2
 BuildRequires: python3-Mako >= 0.8.0
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
+%{?with_opencl_spirv:BuildRequires:    spirv-tools-devel >= 2018.0}
 # wayland-{client,server}
 %{?with_wayland:BuildRequires: wayland-devel >= %{wayland_ver}}
 %{?with_wayland:BuildRequires: wayland-protocols >= 1.8}
 %{?with_wayland:BuildRequires: wayland-egl-devel >= %{wayland_ver}}
+BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXdamage-devel >= 1.1
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
-BuildRequires: xorg-lib-libXfixes-devel
+BuildRequires: xorg-lib-libXfixes-devel >= 2.0
 BuildRequires: xorg-lib-libXrandr-devel >= 1.3
 BuildRequires: xorg-lib-libXv-devel
-BuildRequires: xorg-lib-libXvMC-devel >= 1.0.6
+%{?with_xvmc:BuildRequires:    xorg-lib-libXvMC-devel >= 1.0.6}
 BuildRequires: xorg-lib-libXxf86vm-devel
 BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
 BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
@@ -122,6 +134,7 @@ BuildRequires:      xorg-proto-glproto-devel >= %{glproto_ver}
 %{?with_lm_sensors:BuildRequires:      lm_sensors-devel}
 %endif
 BuildRequires: zlib-devel >= %{zlib_ver}
+BuildRequires: zstd-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # libGLESv1_CM, libGLESv2, libGL, libOSMesa:
@@ -181,11 +194,13 @@ Requires: libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
 Requires:      xorg-lib-libXdamage-devel >= 1.1
 Requires:      xorg-lib-libXext-devel >= 1.0.5
-Requires:      xorg-lib-libXfixes-devel
+Requires:      xorg-lib-libXfixes-devel >= 2.0
 Requires:      xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
+%if %{without glvnd}
 Provides:      EGL-devel = 1.5
+%endif
 
 %description libEGL-devel
 Header files for Mesa implementation of EGL library.
@@ -260,8 +275,10 @@ Requires:  xorg-lib-libXxf86vm-devel
 Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 Requires:      xorg-proto-glproto-devel >= %{glproto_ver}
 Suggests:      OpenGL-doc-man
+%if %{without glvnd}
 Provides:      OpenGL-GLX-devel = 1.4
 Provides:      OpenGL-devel = 4.6
+%endif
 Obsoletes:     Mesa-devel
 Obsoletes:     X11-OpenGL-devel < 1:7.0.0
 Obsoletes:     X11-OpenGL-devel-base < 1:7.0.0
@@ -307,7 +324,7 @@ This package contains shared libraries of Mesa implementation of GLES
 (OpenGL ES) - cross-platform API for full-function 2D and 3D graphics
 on embedded systems. OpenGL ES specification can be found on Khronos
 Group site: <http://www.khronos.org/opengles/>. Mesa implements OpenGL
-ES 1.1 and 2.0.
+ES 1.1 and 2.0/3.2.
 
 %description libGLES -l pl.UTF-8
 Ten pakiet zawiera biblioteki współdzielone implementacji Mesa
@@ -315,7 +332,7 @@ standardu GLES (OpenGL ES) - wieloplatformowego API do w pełni
 funkcjonalnej grafiki 2D i 3D na systemach wbudowanych. Specyfikację
 OpenGL ES można znaleźć na stronie Khronos Group:
 <http://www.khronos.org/opengles/>. Mesa zawiera implementacją OpenGL
-ES 1.1 i 2.0.
+ES 1.1 i 2.0/3.2.
 
 %package libGLES-devel
 Summary:       Header files for Mesa GLES libraries
@@ -325,10 +342,12 @@ Requires: %{name}-khrplatform-devel = %{version}-%{release}
 # <EGL/egl.h> for <GLES/egl.h>
 Requires:      %{name}-libEGL-devel = %{version}-%{release}
 Requires:      %{name}-libGLES = %{version}-%{release}
+%if %{without glvnd}
 Provides:      OpenGLES-devel
 Provides:      OpenGLESv1-devel = 1.1
 Provides:      OpenGLESv2-devel = 2.0
 Provides:      OpenGLESv3-devel = 3.2
+%endif
 
 %description libGLES-devel
 Header files for Mesa GLES libraries.
@@ -1010,6 +1029,21 @@ X.org Gallium DRI driver for VMWare.
 %description dri-driver-vmwgfx -l pl.UTF-8
 Sterownik X.org DRI Gallium dla VMware.
 
+%package dri-driver-zink
+Summary:       X.org DRI driver based on Vulkan
+Summary(pl.UTF-8):     Sterownik X.org DRI oparty na Vulkanie
+License:       MIT
+Group:         X11/Libraries
+Requires:      xorg-xserver-libglx(glapi) = %{glapi_ver}
+Requires:      xorg-xserver-server >= %{xserver_ver}
+Requires:      zlib >= %{zlib_ver}
+
+%description dri-driver-zink
+X.org Gallium DRI driver based on Vulkan.
+
+%description dri-driver-zink -l pl.UTF-8
+Sterownik X.org DRI Gallium oparty na Vulkanie.
+
 %package pipe-driver-i915
 Summary:       i915 driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik i915 dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1026,6 +1060,24 @@ i915 driver for Mesa Gallium dynamic pipe loader. It supports Intel
 Sterownik i915 dla dynamicznego systemu potoków szkieletu Mesa
 Gallium. Obsługuje układy Intela z serii 915/945/G33/Q33/Q35/Pineview.
 
+%package pipe-driver-iris
+Summary:       iris driver for Mesa Gallium dynamic pipe loader
+Summary(pl.UTF-8):     Sterownik iris dla dynamicznego systemu potoków szkieletu Mesa Gallium
+Group:        Libraries
+Requires:      zlib >= %{zlib_ver}
+
+%description pipe-driver-iris
+iris driver for Mesa Gallium dynamic pipe loader. It supports Intel
+Iris (Gen8+) card family (Broadwell, Skylake, Broxton, Kabylake,
+Coffeelake, Geminilake, Whiskey Lake, Comet Lake, Cannonlake, Ice
+Lake, Elkhart Lake).
+
+%description pipe-driver-iris -l pl.UTF-8
+Sterownik iris dla dynamicznego systemu potoków szkieletu Mesa
+Gallium. Obsługuje układy Intela z rodziny kart Intel Iris (Gen8+:
+Broadwell, Skylake, Broxton, Kabylake, Coffeelake, Geminilake, Whiskey
+Lake, Comet Lake, Cannonlake, Ice Lake, Elkhart Lake).
+
 %package pipe-driver-msm
 Summary:       msm (freedreno) driver for Mesa Gallium dynamic pipe loader
 Summary(pl.UTF-8):     Sterownik msm (freedreno) dla dynamicznego systemu potoków szkieletu Mesa Gallium
@@ -1275,6 +1327,48 @@ Mesa driver for Bellagio OpenMAX IL API.
 %description -n omxil-mesa -l pl.UTF-8
 Sterownik Mesa dla API Bellagio OpenMAX IL.
 
+%package vulkan-icd-broadcom
+Summary:       v3dv - Mesa Vulkan driver for Raspberry Pi 4
+Summary(pl.UTF-8):     v3dv - sterownik Vulkan dla Raspberry Pi 4
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libXrandr >= 1.3
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
+Requires:      zlib >= %{zlib_ver}
+Suggests:      vulkan(loader)
+Provides:      vulkan(icd) = 1.0.3
+
+%description vulkan-icd-broadcom
+v3dv - Mesa Vulkan driver for Raspberry Pi 4.
+
+%description vulkan-icd-broadcom -l pl.UTF-8
+v3dv - sterownik Vulkan dla Raspberry Pi 4.
+
+%package vulkan-icd-freedreno
+Summary:       turnip - Mesa Vulkan driver for Adreno chips
+Summary(pl.UTF-8):     turnip - sterownik Vulkan dla układów Adreno
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libXrandr >= 1.3
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
+Requires:      zlib >= %{zlib_ver}
+Suggests:      vulkan(loader)
+Provides:      vulkan(icd) = 1.0.3
+
+%description vulkan-icd-freedreno
+turnip - Mesa Vulkan driver for Adreno chips.
+
+%description vulkan-icd-freedreno -l pl.UTF-8
+turnip - sterownik Vulkan dla układów Adreno.
+
 %package vulkan-icd-intel
 Summary:       Mesa Vulkan driver for Intel GPUs
 Summary(pl.UTF-8):     Sterownik Vulkan dla GPU firmy Intel
@@ -1309,6 +1403,27 @@ eader files for Mesa Intel GPU Vulkan driver.
 %description vulkan-icd-intel-devel -l pl.UTF-8
 Pliki nagłówkowe sterownika Vulkan dla GPU Intel.
 
+%package vulkan-icd-lavapipe
+Summary:       lavapipe - Mesa software Vulkan driver
+Summary(pl.UTF-8):     lavapipe - programowy sterownik Vulkan
+License:       MIT
+Group:         Libraries
+Requires:      libdrm >= %{libdrm_ver}
+Requires:      libxcb >= 1.13
+Requires:      xorg-lib-libXrandr >= 1.3
+Requires:      xorg-lib-libxshmfence >= 1.1
+# wayland-client
+Requires:      wayland >= %{wayland_ver}
+Requires:      zlib >= %{zlib_ver}
+Suggests:      vulkan(loader)
+Provides:      vulkan(icd) = 1.0.3
+
+%description vulkan-icd-lavapipe
+lavapipe - Mesa software Vulkan driver.
+
+%description vulkan-icd-lavapipe -l pl.UTF-8
+lavapipe - programowy sterownik Vulkan.
+
 %package vulkan-icd-radeon
 Summary:       radv - experimental Mesa Vulkan driver for AMD Radeon GPUs
 Summary(pl.UTF-8):     radv - eksperymentalny sterownik Vulkan dla GPU firmy AMD
@@ -1354,7 +1469,7 @@ i965 %{!?with_gallium_i915:i915} \
 
 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
 
-gallium_drivers="virgl swrast \
+gallium_drivers="virgl swrast %{?with_gallium_zink:zink} \
 %ifarch %{ix86} %{x8664} x32
 svga iris %{?with_swr:swr} %{?with_gallium_i915:i915} \
 %endif
@@ -1370,7 +1485,7 @@ freedreno \
 kmsro \
 lima \
 panfrost \
-tegra \
+%{?with_gallium_nouveau:tegra} \
 v3d \
 vc4 \
 %endif
@@ -1378,20 +1493,23 @@ vc4 \
 
 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
 
-vulkan_drivers="%{?with_radv:amd} \
+vulkan_drivers="swrast %{?with_radv:amd} \
 %ifarch %{ix86} %{x8664} x32
 intel \
 %endif
+%ifarch %{arm} aarch64
+freedreno broadcom \
+%endif
 "
 
 vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
 
 %meson build \
-       -Dplatforms=x11,drm%{?with_wayland:,wayland},surfaceless \
-       -Ddri3=true \
+       -Dplatforms=x11%{?with_wayland:,wayland} \
+       -Ddri3=enabled \
        -Ddri-drivers=${dri_drivers} \
        -Ddri-drivers-path=%{_libdir}/xorg/modules/dri \
-       -Degl=%{?with_egl:true}%{!?with_egl:false} \
+       -Degl=%{?with_egl:enabled}%{!?with_egl:disabled} \
        -Dgallium-drivers=${gallium_drivers} \
        %{?with_hud_extra:-Dgallium-extra-hud=true} \
        -Dgallium-nine=%{?with_nine:true}%{!?with_nine:false} \
@@ -1405,14 +1523,15 @@ vulkan_drivers=$(echo $vulkan_drivers | xargs | tr ' ' ',')
 %else
        -Dgallium-opencl=disabled \
 %endif
-       -Dgallium-va=%{?with_va:true}%{!?with_va:false} \
-       -Dgallium-vdpau=true \
-       -Dgallium-xvmc=true \
-       -Dgallium-xa=%{?with_xa:true}%{!?with_xa:false} \
-       -Dgbm=%{?with_gbm:true}%{!?with_gbm:false} \
+       -Dgallium-va=%{?with_va:enabled}%{!?with_va:disabled} \
+       %{?with_vdpau:-Dgallium-vdpau=enabled} \
+       %{?with_xvmc:-Dgallium-xvmc=enabled} \
+       -Dgallium-xa=%{?with_xa:enabled}%{!?with_xa:disabled} \
+       -Dgbm=%{?with_gbm:enabled}%{!?with_gbm:disabled} \
        -Dglvnd=%{?with_glvnd:true}%{!?with_glvnd:false} \
-       -Dlibunwind=true \
-       -Dlmsensors=%{?with_lm_sensors:true}%{!?with_lm_sensors:false} \
+       -Dlibunwind=enabled \
+       -Dlmsensors=%{?with_lm_sensors:enabled}%{!?with_lm_sensors:disabled} \
+       %{?with_opencl_spirv:-Dopencl-spirv=true} \
        -Dosmesa=%{?with_gallium:gallium}%{!?with_gallium:classic} \
        -Dselinux=true \
        -Dva-libs-path=%{_libdir}/libva/dri \
@@ -1440,6 +1559,9 @@ strip -R .note.ABI-tag $RPM_BUILD_ROOT%{_libdir}/libGL.so.*.*
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  OpenCL-icd -p /sbin/ldconfig
+%postun        OpenCL-icd -p /sbin/ldconfig
+
 %post  libEGL -p /sbin/ldconfig
 %postun        libEGL -p /sbin/ldconfig
 
@@ -1487,19 +1609,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libEGL_mesa.so
 %else
 %attr(755,root,root) %{_libdir}/libEGL.so
-%endif
 %dir %{_includedir}/EGL
 %{_includedir}/EGL/egl.h
 %{_includedir}/EGL/eglext.h
-%{_includedir}/EGL/eglextchromium.h
-%{_includedir}/EGL/eglmesaext.h
 %{_includedir}/EGL/eglplatform.h
 %{_pkgconfigdir}/egl.pc
 %endif
+%{_includedir}/EGL/eglextchromium.h
+%{_includedir}/EGL/eglmesaext.h
+%endif
 
 %files libGL
 %defattr(644,root,root,755)
-%doc docs/{*.html,README.UVD,features.txt,relnotes/*.html}
+%doc docs/{*.rst,README.UVD,features.txt,relnotes/*.rst}
 %if %{with glvnd}
 %attr(755,root,root) %{_libdir}/libGLX_mesa.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGLX_mesa.so.0
@@ -1515,27 +1637,32 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libGL-devel
 %defattr(644,root,root,755)
-%doc docs/specs/*
+%doc docs/_extra/specs/*
+%if %{without glvnd}
 %dir %{_includedir}/GL
 %{_includedir}/GL/gl.h
 %{_includedir}/GL/glcorearb.h
 %{_includedir}/GL/glext.h
 %{_includedir}/GL/glx.h
 %{_includedir}/GL/glxext.h
+%{_pkgconfigdir}/gl.pc
+%endif
 %dir %{_includedir}/GL/internal
 %{_includedir}/GL/internal/dri_interface.h
 %{_pkgconfigdir}/dri.pc
-%{_pkgconfigdir}/gl.pc
 
 %files libGLES
 %defattr(644,root,root,755)
+%if %{without glvnd}
 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGLESv1_CM.so.1
 %attr(755,root,root) %{_libdir}/libGLESv2.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libGLESv2.so.2
+%endif
 
 %files libGLES-devel
 %defattr(644,root,root,755)
+%if %{without glvnd}
 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so
 %attr(755,root,root) %{_libdir}/libGLESv2.so
 %{_includedir}/GLES
@@ -1543,6 +1670,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GLES3
 %{_pkgconfigdir}/glesv1_cm.pc
 %{_pkgconfigdir}/glesv2.pc
+%endif
 
 %files libOSMesa
 %defattr(644,root,root,755)
@@ -1584,12 +1712,16 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with gallium_nouveau}
 %files libXvMC-nouveau
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.*.*
+%attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so
 %endif
 
 %if %{with gallium_radeon}
 %files libXvMC-r600
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libXvMCr600.so.1.*.*
+%attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
 %attr(755,root,root) %{_libdir}/libXvMCr600.so
 %endif
 
@@ -1651,11 +1783,13 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 
 %if %{with egl}
+%if %{without glvnd}
 %files khrplatform-devel
 %defattr(644,root,root,755)
 %dir %{_includedir}/KHR
 %{_includedir}/KHR/khrplatform.h
 %endif
+%endif
 
 %files dri-driver-ati-radeon-R100
 %defattr(644,root,root,755)
@@ -1681,6 +1815,7 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %endif
 
+%ifarch %{ix86} %{x8664} x32
 %files dri-driver-intel-i915
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
@@ -1694,6 +1829,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/iris_dri.so
 %endif
+%endif
 
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
@@ -1710,11 +1846,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
 
 %if %{with gallium}
-%ifarch %{arm}
+%ifarch %{arm} aarch64
 %files dri-driver-etnaviv
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/etnaviv_dri.so
-%attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
 
 %files dri-driver-freedreno
 %defattr(644,root,root,755)
@@ -1728,14 +1863,20 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/hx8357d_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ili9225_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ili9341_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-dcss_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/imx-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/ingenic-drm_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/mcde_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/mediatek_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/meson_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mi0283qt_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/mxsfb-drm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/pl111_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/repaper_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/rockchip_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/st7586_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/st7735r_dri.so
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/stm_dri.so
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sun4i-drm_dri.so
 
 %files dri-driver-lima
@@ -1746,9 +1887,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/panfrost_dri.so
 
+%if %{with gallium_nouveau}
 %files dri-driver-tegra
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tegra_dri.so
+%endif
 
 %files dri-driver-v3d
 %defattr(644,root,root,755)
@@ -1763,17 +1906,31 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/virtio_gpu_dri.so
 
+%ifarch %{ix86} %{x8664} x32
 %files dri-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
 %endif
 
+%if %{with gallium_zink}
+%files dri-driver-zink
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/xorg/modules/dri/zink_dri.so
+%endif
+%endif
+
 %if %{with gallium}
 %if %{with opencl}
 %ifarch %{ix86} %{x8664} x32
 %if %{with gallium_i915}
+%files pipe-driver-i915
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/gallium-pipe/pipe_i915.so
 %endif
+
+%files pipe-driver-iris
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/gallium-pipe/pipe_iris.so
 %endif
 
 %ifarch %{arm}
@@ -1873,6 +2030,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/bellagio/libomx_mesa.so
 %endif
 
+%ifarch %{arm} aarch64
+%files vulkan-icd-broadcom
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libvulkan_broadcom.so
+%{_datadir}/vulkan/icd.d/broadcom_icd.*.json
+
+%files vulkan-icd-freedreno
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libvulkan_freedreno.so
+%{_datadir}/vulkan/icd.d/freedreno_icd.*.json
+%endif
+
+%ifarch %{ix86} %{x8664} x32
 %files vulkan-icd-intel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvulkan_intel.so
@@ -1881,6 +2051,12 @@ rm -rf $RPM_BUILD_ROOT
 %files vulkan-icd-intel-devel
 %defattr(644,root,root,755)
 %{_includedir}/vulkan/vulkan_intel.h
+%endif
+
+%files vulkan-icd-lavapipe
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libvulkan_lvp.so
+%{_datadir}/vulkan/icd.d/lvp_icd.*.json
 
 %if %{with radv}
 %files vulkan-icd-radeon
This page took 0.298996 seconds and 4 git commands to generate.