]> git.pld-linux.org Git - packages/Mesa.git/blobdiff - Mesa.spec
- rel 3; disable nouveau
[packages/Mesa.git] / Mesa.spec
index 2b2b69321752c035ad9d9a4471b3ea1759a487ff..162c55527c6811f45dcbe3f55704595c5d14cb97 100644 (file)
--- a/Mesa.spec
+++ b/Mesa.spec
@@ -9,6 +9,7 @@
 %bcond_with    egl     # don't build egl
 %bcond_without gallium # don't build gallium
 %bcond_with    gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
+%bcond_with    gallium_nouveau # doesn't build due to libdrm API changes (fixed in Mesa 7.8)
 %bcond_without motif   # build static libGLw without Motif interface
 %bcond_with    multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
 %bcond_without osmesa  # don't build osmesa
 # (until they start to be somehow versioned themselves)
 %define                glapi_ver       7.1.0
 #
+%define                libdrm_ver      2.4.18
+%define                dri2proto_ver   1.99.3
+#
 Summary:       Free OpenGL implementation
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja standardu OpenGL
 Name:          Mesa
 Version:       7.7
-Release:       1%{?with_multigl:.mgl}
+Release:       3%{?with_multigl:.mgl}
 License:       MIT (core), SGI (GLU,libGLw) and others - see license.html file
 Group:         X11/Libraries
 Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
 # Source0-md5: e3fa64a1508bc23dd9de9dd2cea7cfb1
 Source1:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
 # Source1-md5: 6fd616b27b9826d0faa23e08e05d9435
-Source2:       http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
-# Source2-md5: 6ae05158e678f4594343f32c2ca50515
 Patch0:                %{name}-realclean.patch
 Patch1:                %{name}-tgsi_dump.patch
 URL:           http://www.mesa3d.org/
@@ -42,7 +44,7 @@ BuildRequires:        autoconf
 BuildRequires: automake
 BuildRequires: expat-devel
 %{?with_demos:BuildRequires:   glew-devel}
-BuildRequires: libdrm-devel >= 2.4.12-3
+BuildRequires: libdrm-devel >= %{libdrm_ver}
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:1.4d
@@ -55,7 +57,7 @@ BuildRequires:        xorg-lib-libXdamage-devel
 BuildRequires: xorg-lib-libXext-devel >= 1.0.5
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-BuildRequires: xorg-proto-dri2proto-devel >= 1.99.3
+BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
 BuildRequires: xorg-proto-glproto-devel
 BuildRequires: xorg-proto-printproto-devel
 BuildRequires: xorg-util-makedepend
@@ -85,7 +87,7 @@ Summary:      Free Mesa3D implementation of libGL OpenGL library
 Summary(pl.UTF-8):     WolnodostÄ™pna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
 License:       MIT
 Group:         X11/Libraries
-Requires:      libdrm >= 2.4.5
+Requires:      libdrm >= %{libdrm_ver}
 Provides:      OpenGL = 2.1
 # reports version 1.3, but supports glXGetProcAddress() from 1.4
 Provides:      OpenGL-GLX = 1.4
@@ -122,7 +124,13 @@ License:   MIT
 Group:         X11/Development/Libraries
 # loose dependency on libGL to use with other libGL binaries
 Requires:      OpenGL >= 1.5
+Requires:      libdrm-devel >= %{libdrm_ver}
 Requires:      xorg-lib-libX11-devel
+Requires:      xorg-lib-libXdamage-devel
+Requires:      xorg-lib-libXext-devel
+Requires:      xorg-lib-libXxf86vm-devel
+Requires:      xorg-proto-dri2proto-devel >= %{dri2proto_ver}
+Suggests:      OpenGL-doc-man
 Provides:      OpenGL-GLX-devel = 1.4
 Provides:      OpenGL-devel = 2.1
 Obsoletes:     Mesa-devel
@@ -619,7 +627,7 @@ X.org DRI driver for VMWare.
 Sterownik X.org DRI dla VMware.
 
 %prep
-%setup -q -b1 -a2
+%setup -q -b1
 %patch0 -p0
 %patch1 -p1
 
@@ -690,7 +698,7 @@ mv %{_lib} osmesa32
        --enable-gallium \
        --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
        --enable-gallium-svga \
-       --enable-gallium-nouveau \
+       --%{?with_gallium_nouveau:en}%{!?with_gallium_nouveau:dis}able-gallium-nouveau \
        --with-state-trackers=dri \
 %else
        --disable-gallium \
@@ -705,10 +713,6 @@ mv %{_lib} osmesa32
 %{__make} -C progs/demos
 %endif
 
-cd gl-manpages-*
-%configure
-%{__make}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -718,11 +722,6 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd gl-manpages-*
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-cd ..
-
 %if %{with osmesa}
 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
 %endif
@@ -803,8 +802,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GL/internal/dri_interface.h
 %{_pkgconfigdir}/dri.pc
 %{_pkgconfigdir}/gl.pc
-%{_mandir}/man3/gl[^uX]*.3gl*
-%{_mandir}/man3/glX*.3gl*
 
 %if %{with static}
 %files libGL-static
@@ -823,7 +820,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/GL/glu.h
 %{_includedir}/GL/glu_mangle.h
 %{_pkgconfigdir}/glu.pc
-%{_mandir}/man3/glu*.3gl*
 
 %if %{with static}
 %files libGLU-static
@@ -929,10 +925,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
 
 %if %{with gallium}
+%if %{with gallium_nouveau}
 %files dri-driver-nouveau
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
 %endif
+%endif
 
 %files dri-driver-savage
 %defattr(644,root,root,755)
@@ -956,9 +954,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
 
+%if %{with gallium}
 %files dri-driver-vmwgfx
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
+%endif
 
 %if %{with demos}
 %files demos
This page took 0.140521 seconds and 4 git commands to generate.