]> git.pld-linux.org Git - packages/Mesa-legacy-classic.git/blame - Mesa-legacy-classic.spec
- up to 21.3.9
[packages/Mesa-legacy-classic.git] / Mesa-legacy-classic.spec
CommitLineData
22b32543
JB
1# TODO: is separate libGLX_mesa needed for classic DRI versions, or >=22.x is still compatible?
2#
3# Conditional build:
4%bcond_with sse2 # SSE2 instructions
5%bcond_with tests # tests
6#
7# glapi version (glapi tables in dri drivers and libglx must be in sync);
8# set to current Mesa version on ABI break, when xserver tables get regenerated
9# (until they start to be somehow versioned themselves)
10%define glapi_ver 7.1.0
11# other packages
12%define libdrm_ver 2.4.107
13%define dri2proto_ver 2.8
14%define glproto_ver 1.4.14
15%define zlib_ver 1.2.8
16%define libglvnd_ver 1.3.4-2
17%define llvm_ver 11.0.0
18%define gcc_ver 6:4.8.0
19
20%ifarch %{x86_with_sse2}
21%define with_sse2 1
22%endif
23
24Summary: Free OpenGL implementation
25Summary(pl.UTF-8): Wolnodostępna implementacja standardu OpenGL
26Name: Mesa-legacy-classic
88a9e079
JB
27Version: 21.3.9
28Release: 1
22b32543
JB
29License: MIT (core) and others - see license.html file
30Group: X11/Libraries
31#Source0: ftp://ftp.freedesktop.org/pub/mesa/mesa-%{version}.tar.xz
32## Source0-md5: 7c61a801311fb8d2f7b3cceb7b5cf308
33Source0: https://gitlab.freedesktop.org/mesa/mesa/-/archive/mesa-%{version}/mesa-mesa-%{version}.tar.bz2
88a9e079 34# Source0-md5: 627bdfbc3a58fa4b004f2bb49228ebee
22b32543
JB
35URL: https://www.mesa3d.org/
36%{?with_gallium_zink:BuildRequires: Vulkan-Loader-devel}
37BuildRequires: bison > 2.3
38BuildRequires: elfutils-devel
39BuildRequires: expat-devel >= 1.95
40BuildRequires: flex
41BuildRequires: gcc >= %{gcc_ver}
42BuildRequires: libdrm-devel >= %{libdrm_ver}
43BuildRequires: libglvnd-devel >= %{libglvnd_ver}
44BuildRequires: libselinux-devel
45BuildRequires: libstdc++-devel >= %{gcc_ver}
46BuildRequires: libunwind-devel
47BuildRequires: libxcb-devel >= 1.13
48BuildRequires: meson >= 0.52
49BuildRequires: ninja >= 1.5
50BuildRequires: pkgconfig
51BuildRequires: pkgconfig(talloc) >= 2.0.1
52BuildRequires: pkgconfig(xcb-dri2) >= 1.8
53BuildRequires: pkgconfig(xcb-dri3) >= 1.13
54BuildRequires: pkgconfig(xcb-glx) >= 1.8.1
55BuildRequires: pkgconfig(xcb-present) >= 1.13
56BuildRequires: pkgconfig(xcb-randr) >= 1.12
57BuildRequires: python3 >= 1:3.2
58BuildRequires: python3-Mako >= 0.8.0
59BuildRequires: rpmbuild(macros) >= 2.007
60BuildRequires: sed >= 4.0
61BuildRequires: xorg-lib-libX11-devel
62BuildRequires: xorg-lib-libXext-devel >= 1.0.5
63BuildRequires: xorg-lib-libXfixes-devel >= 2.0
64BuildRequires: xorg-lib-libXrandr-devel >= 1.3
65BuildRequires: xorg-lib-libXv-devel
66BuildRequires: xorg-lib-libXxf86vm-devel
67BuildRequires: xorg-lib-libxshmfence-devel >= 1.1
68BuildRequires: xorg-proto-dri2proto-devel >= %{dri2proto_ver}
69BuildRequires: xorg-proto-glproto-devel >= %{glproto_ver}
70BuildRequires: zlib-devel >= %{zlib_ver}
71BuildRequires: zstd-devel
72BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74# _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
75%define skip_post_check_so libGL.so.1.* libGLX_mesa.so.0.*
76
77%description
78Mesa is a 3-D graphics library with an API which is very similar to
79that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
80syntax or state machine, it is being used with authorization from
81Silicon Graphics, Inc. However, the author does not possess an OpenGL
82license from SGI, and makes no claim that Mesa is in any way a
83compatible replacement for OpenGL or associated with SGI.
84
85%description -l pl.UTF-8
86Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
87tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
88autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
89OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
90OpenGL ani powiązana z SGI.
91
92%package libGL
93Summary: Free Mesa3D implementation of libGL OpenGL library
94Summary(pl.UTF-8): Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
95License: MIT
96Group: X11/Libraries
97Requires: %{name}-libglapi = %{version}-%{release}
98Requires: libdrm >= %{libdrm_ver}
99Requires: libxcb >= 1.13
100Requires: libglvnd-libGL >= %{libglvnd_ver}
101Provides: OpenGL = 4.6
102Provides: OpenGL-GLX = 1.4
103Obsoletes: Mesa < 6.4-2
104Obsoletes: Mesa-dri < 6.4.1-3
105Obsoletes: Mesa-dri-core < 10.0.0
106Obsoletes: X11-OpenGL-libGL < 1:7.0.0
107Obsoletes: XFree86-OpenGL-libGL < 1:7.0.0
108
109%description libGL
110Mesa is a 3-D graphics library with an API which is very similar to
111that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
112syntax or state machine, it is being used with authorization from
113Silicon Graphics, Inc. However, the author does not possess an OpenGL
114license from SGI, and makes no claim that Mesa is in any way a
115compatible replacement for OpenGL or associated with SGI.
116
117This package contains libGL which implements OpenGL 4.6 and GLX 1.4
118specifications. It uses DRI for rendering.
119
120%description libGL -l pl.UTF-8
121Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
122tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
123autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
124OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
125OpenGL ani powiązana z SGI.
126
127Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 4.6 oraz
128GLX 1.4. Używa DRI do renderowania.
129
130%package libGL-devel
131Summary: Header files for Mesa3D libGL library
132Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
133License: MIT
134Group: X11/Development/Libraries
135Requires: libglvnd-libGL-devel >= %{libglvnd_ver}
136Suggests: OpenGL-doc-man
137Obsoletes: Mesa-devel < 6.4-2
138Obsoletes: Mesa-libGL-static < 18.3
139Obsoletes: Mesa-static < 6.4-2
140Obsoletes: X11-OpenGL-devel < 1:7.0.0
141Obsoletes: X11-OpenGL-devel-base < 1:7.0.0
142Obsoletes: X11-OpenGL-static < 1:7.0.0
143Obsoletes: XFree86-OpenGL-devel < 1:7.0.0
144Obsoletes: XFree86-OpenGL-devel-base < 1:7.0.0
145Obsoletes: XFree86-OpenGL-static < 1:7.0.0
146
147%description libGL-devel
148Header files for Mesa3D libGL library.
149
150%description libGL-devel -l pl.UTF-8
151Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
152
153%package libglapi
154Summary: Mesa GL API shared library
155Summary(pl.UTF-8): Biblioteka współdzielona Mesa GL API
156Group: Libraries
157Conflicts: Mesa-libEGL < 8.0.1-2
158
159%description libglapi
160Mesa GL API shared library, common for various APIs (EGL, GL, GLES).
161
162%description libglapi -l pl.UTF-8
163Biblioteka współdzielona Mesa GL API, wspólna dla różnych API (EGL,
164GL, GLES).
165
166%package khrplatform-devel
167Summary: Khronos platform header file
168Summary(pl.UTF-8): Plik nagłówkowy platformy Khronos
169Group: Development/Libraries
170Provides: khrplatform-devel
171Conflicts: Mesa-libEGL-devel < 8.0.1-2
172
173%description khrplatform-devel
174Khronos platform header file.
175
176%description khrplatform-devel -l pl.UTF-8
177Plik nagłówkowy platformy Khronos.
178
179%package dri-devel
180Summary: Direct Rendering Infrastructure interface header file
181Summary(pl.UTF-8): Plik nagłówkowy interfejsu DRI (Direct Rendering Infrastructure)
182Group: Development/Libraries
183Requires: libdrm-devel >= %{libdrm_ver}
184# <GL/gl.h>
185Requires: libglvnd-libGL-devel >= %{libglvnd_ver}
186Conflicts: Mesa-libGL-devel < 21.1.0-2
187
188%description dri-devel
189Direct Rendering Infrastructure interface header file.
190
191%description dri-devel -l pl.UTF-8
192Plik nagłówkowy interfejsu DRI (Direct Rendering Infrastructure).
193
194%package -n Mesa-dri-driver-ati-radeon-R100
195Summary: X.org DRI driver for ATI R100 card family
196Summary(pl.UTF-8): Sterownik X.org DRI dla rodziny kart ATI R100
197License: MIT
198Group: X11/Libraries
199Requires: zlib >= %{zlib_ver}
200Suggests: xorg-driver-video-amdgpu
201Suggests: xorg-driver-video-ati
202Obsoletes: X11-driver-radeon-dri < 1:7.0.0
203Conflicts: xorg-xserver-libglx(glapi) > %{glapi_ver}
204Conflicts: xorg-xserver-libglx(glapi) < %{glapi_ver}
205
206%description -n Mesa-dri-driver-ati-radeon-R100
207X.org DRI driver for ATI R100 card family (Radeon 7000-7500). It
208supports R100, RV100, RS100, RV200, RS200, RS250.
209
210%description -n Mesa-dri-driver-ati-radeon-R100 -l pl.UTF-8
211Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
212Obsługuje układy R100, RV100, RS100, RV200, RS200, RS250.
213
214%package -n Mesa-dri-driver-ati-radeon-R200
215Summary: X.org DRI driver for ATI R200 card family
216Summary(pl.UTF-8): Sterownik X.org DRI dla rodziny kart ATI R200
217License: MIT
218Group: X11/Libraries
219Requires: zlib >= %{zlib_ver}
220Suggests: xorg-driver-video-amdgpu
221Suggests: xorg-driver-video-ati
222Obsoletes: X11-driver-radeon-dri < 1:7.0.0
223Conflicts: xorg-xserver-libglx(glapi) > %{glapi_ver}
224Conflicts: xorg-xserver-libglx(glapi) < %{glapi_ver}
225
226%description -n Mesa-dri-driver-ati-radeon-R200
227X.org DRI driver for ATI R200 card family (Radeon 8500-92xx). It
228supports R200, RV250, RV280, RS300, RS350 chips.
229
230%description -n Mesa-dri-driver-ati-radeon-R200 -l pl.UTF-8
231Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
232Obsługuje układy R200, RV250, RV280, RS300, RS350.
233
234%package -n Mesa-dri-driver-intel-i915
235Summary: X.org DRI driver for Intel i915 card family
236Summary(pl.UTF-8): Sterownik X.org DRI dla rodziny kart Intel i915
237License: MIT
238Group: X11/Libraries
239Requires: zlib >= %{zlib_ver}
240Obsoletes: Mesa-dri-driver-intel-i830 < 6.5
241Obsoletes: X11-driver-i810-dri < 1:7.0.0
242Conflicts: xorg-xserver-libglx(glapi) > %{glapi_ver}
243Conflicts: xorg-xserver-libglx(glapi) < %{glapi_ver}
244
245%description -n Mesa-dri-driver-intel-i915
246X.org DRI driver for Intel i915 card family (830, 845, 852/855, 865,
247915, 945, G33, Q33, Q35, Pineview).
248
249%description -n Mesa-dri-driver-intel-i915 -l pl.UTF-8
250Sterownik X.org DRI dla rodziny kart Intel i915 (830, 845, 852/855,
251865, 915, 945, G33, Q33, Q35, Pineview).
252
253%package -n Mesa-dri-driver-intel-i965
254Summary: X.org DRI driver for Intel i965 card family
255Summary(pl.UTF-8): Sterownik X.org DRI dla rodziny kart Intel i965
256License: MIT
257Group: X11/Libraries
258Requires: zlib >= %{zlib_ver}
259Obsoletes: Mesa-dri-driver-intel-i830 < 6.5
260Obsoletes: X11-driver-i810-dri < 1:7.0.0
261Conflicts: xorg-xserver-libglx(glapi) > %{glapi_ver}
262Conflicts: xorg-xserver-libglx(glapi) < %{glapi_ver}
263
264%description -n Mesa-dri-driver-intel-i965
265X.org (non-Gallium) DRI driver for Intel i965 card family (946GZ,
266965G, 965Q, 965GM, 965GME, GM45, G41, B43, Q45/Q43, G45/G43, Ironlake,
267Sandybridge, Ivybridge, Haswell, Ray Trail, Broadwell, Cherrytrail,
268Braswell, Cherryview, Skylake, Broxton, Kabylake, Coffeelake,
269Geminilake, Whiskey Lake, Comet Lake, Cannonlake, Ice Lake, Elkhart
270Lake).
271
272%description -n Mesa-dri-driver-intel-i965 -l pl.UTF-8
273Sterownik X.org DRI (nie Gallium) dla rodziny kart Intel i965 (946GZ,
274965G, 965Q, 965GM, 965GME, GM45, G41, B43, Q45/Q43, G45/G43, Ironlake,
275Sandybridge, Ivybridge, Haswell, Ray Trail, Broadwell, Cherrytrail,
276Braswell, Cherryview, Skylake, Broxton, Kabylake, Coffeelake,
277Geminilake, Whiskey Lake, Comet Lake, Cannonlake, Ice Lake, Elkhart
278Lake).
279
280%package -n Mesa-dri-driver-nouveau
281Summary: X.org DRI driver for NVIDIA card family
282Summary(pl.UTF-8): Sterownik X.org DRI dla rodziny kart NVIDIA
283License: MIT
284Group: X11/Libraries
285Requires: zlib >= %{zlib_ver}
286Suggests: xorg-driver-video-nouveau
287Conflicts: xorg-xserver-libglx(glapi) > %{glapi_ver}
288Conflicts: xorg-xserver-libglx(glapi) < %{glapi_ver}
289
290%description -n Mesa-dri-driver-nouveau
291X.org DRI drivers for NVIDIA card family.
292
293%description -n Mesa-dri-driver-nouveau -l pl.UTF-8
294Sterowniki X.org DRI dla rodziny kart NVIDIA.
295
296%prep
297%setup -q -n mesa-mesa-%{version}
298
299%build
300dri_drivers="nouveau r100 r200 \
301%ifarch %{ix86} %{x8664} x32
302i965 i915 \
303%endif
304"
305
306dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
307
308%meson build \
309 -Dplatforms=x11 \
310 -Ddri3=enabled \
311 -Ddri-drivers=${dri_drivers} \
312 -Ddri-drivers-path=%{_libdir}/xorg/modules/dri \
313 -Degl=disabled \
314 -Dgallium-drivers= \
315 -Dgbm=disabled \
316 -Dgles1=disabled \
317 -Dgles2=disabled \
318 -Dglvnd=true \
319 -Dlibunwind=enabled \
320 -Dosmesa=false \
321 -Dselinux=true \
322 -Dsse2=%{__true_false sse2} \
323 -Dvulkan-drivers=
324
325%ninja_build -C build
326
327%{?with_tests:%ninja_test -C build}
328
329%install
330rm -rf $RPM_BUILD_ROOT
331
332%ninja_install -C build
333
334# not used externally
335%{__rm} $RPM_BUILD_ROOT%{_libdir}/libglapi.so
336
337%clean
338rm -rf $RPM_BUILD_ROOT
339
340%post libGL -p /sbin/ldconfig
341%postun libGL -p /sbin/ldconfig
342
343%post libglapi -p /sbin/ldconfig
344%postun libglapi -p /sbin/ldconfig
345
346### libraries
347
348%if 0
349# see TODO question
350%files libGL
351%defattr(644,root,root,755)
352%doc docs/{*.rst,README.UVD,features.txt,relnotes/*.rst}
353%attr(755,root,root) %{_libdir}/libGLX_mesa.so.*.*
354%attr(755,root,root) %ghost %{_libdir}/libGLX_mesa.so.0
355%attr(755,root,root) %{_libdir}/libGLX_mesa.so
356%{_datadir}/drirc.d
357
358%files libGL-devel
359%defattr(644,root,root,755)
360%doc docs/_extra/specs/*
361
362%files libglapi
363%defattr(644,root,root,755)
364%attr(755,root,root) %{_libdir}/libglapi.so.*.*
365%attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
366# libglapi-devel? nothing seems to need it atm.
367#%attr(755,root,root) %{_libdir}/libglapi.so
368
369%files dri-devel
370%defattr(644,root,root,755)
371%dir %{_includedir}/GL/internal
372%{_includedir}/GL/internal/dri_interface.h
373%{_pkgconfigdir}/dri.pc
374%endif
375
376### drivers: dri
377
378%files -n Mesa-dri-driver-ati-radeon-R100
379%defattr(644,root,root,755)
380%attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
381
382%files -n Mesa-dri-driver-ati-radeon-R200
383%defattr(644,root,root,755)
384%attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
385
386%ifarch %{ix86} %{x8664} x32
387%files -n Mesa-dri-driver-intel-i915
388%defattr(644,root,root,755)
389%attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
390%attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
391
392%files -n Mesa-dri-driver-intel-i965
393%defattr(644,root,root,755)
394%attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
395%endif
396
397%files -n Mesa-dri-driver-nouveau
398%defattr(644,root,root,755)
399%attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_vieux_dri.so
This page took 0.140518 seconds and 4 git commands to generate.