]> git.pld-linux.org Git - SPECS.git/commitdiff
SPECS updated Wed 17 Apr 22:20:02 CEST 2024
authorgit <git@pld-linux.org>
Wed, 17 Apr 2024 20:20:02 +0000 (22:20 +0200)
committergit <git@pld-linux.org>
Wed, 17 Apr 2024 20:20:02 +0000 (22:20 +0200)
advancescan.spec
immer.spec [new file with mode: 0644]

index 6743492e467e721f994573a5289b2f762c45d04a..0bd540570868bed86fa5a9ebf80712840b35b6f0 100644 (file)
@@ -3,12 +3,13 @@ Summary:      AdvanceSCAN ROMs Manager
 Summary(pl.UTF-8):     AdvanceSCAN - zarządca ROM-ów
 Name:          advancescan
 Version:       1.18
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Applications/File
 #Source0Download: https://github.com/amadvance/advancescan/releases
 Source0:       https://github.com/amadvance/advancescan/releases/download/v%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 85d964fe0d34a5722ce923f7fbb8a115
+Patch0:                %{name}-throw.patch
 URL:           http://www.advancemame.it/scan-readme
 BuildRequires: libstdc++-devel
 BuildRequires: zlib-devel
@@ -24,6 +25,7 @@ emulatorów AdvanceMAME, AdvanceMESS i innych pochodnych MAME.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure
diff --git a/immer.spec b/immer.spec
new file mode 100644 (file)
index 0000000..905fae9
--- /dev/null
@@ -0,0 +1,112 @@
+#
+# Conditional build:
+%bcond_without apidocs         # API documentation
+#
+Summary:       Postmodern immutable and persistent data structures for C++
+Summary(pl.UTF-8):     Postmodernistyczne niezmienne i trwałe struktury danych dla C++
+Name:          immer
+Version:       0.8.1
+Release:       1
+License:       Boost v1.0
+Group:         Libraries
+#Source0Download: https://github.com/arximboldi/immer/releases
+Source0:       https://github.com/arximboldi/immer/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 387ebc10056f015a9db13cb551c737a1
+%define        theme_gitref    b5adfa2a6def8aa55d95dedc4e1bfde214a5e36c
+Source1:       https://github.com/arximboldi/sinusoidal-sphinx-theme/archive/%{theme_gitref}/sinusoidal-sphinx-theme-%{theme_gitref}.tar.gz
+# Source1-md5: 8873555af1d9f75d42a440fb1c60bd07
+URL:           https://github.com/arximboldi/immer
+BuildRequires: boost-devel >= 1.56
+BuildRequires: cmake >= 3.5.1
+BuildRequires: gc-devel
+BuildRequires: libstdc++-devel >= 6:5
+BuildRequires: rpm-build >= 4.6
+BuildRequires: rpmbuild(macros) >= 1.605
+%{?with_apidocs:BuildRequires: sphinx-pdg-3 >= 1.3}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# header-only library, but cmake files location is arch-dependent
+%define                _enable_debug_packages  0
+
+%description
+Immer is a library of persistent and immutable data structures
+written in C++. These enable whole new kinds of architectures for
+interactive and concurrent programs of striking simplicity,
+correctness, and performance.
+
+%description -l pl.UTF-8
+Immer to biblioteka trwałych i niezmiennych struktur danych napisana w
+C++. Pozwalają one na nowe rodzaje architektury dla programów
+interaktywnych i współbieżnych, odznaczające się prostotą,
+poprawnością i wydajnością.
+
+%package devel
+Summary:       Postmodern immutable and persistent data structures for C++
+Summary(pl.UTF-8):     Postmodernistyczne niezmienne i trwałe struktury danych dla C++
+Group:         Development/Libraries
+Requires:      libstdc++-devel >= 6:5
+
+%description devel
+immer is a library of persistent and immutable data structures
+written in C++. These enable whole new kinds of architectures for
+interactive and concurrent programs of striking simplicity,
+correctness, and performance.
+
+%description devel -l pl.UTF-8
+immer to biblioteka trwałych i niezmiennych struktur danych napisana w
+C++. Pozwalają one na nowe rodzaje architektury dla programów
+interaktywnych i współbieżnych, odznaczające się prostotą,
+poprawnością i wydajnością.
+
+%package apidocs
+Summary:       API documentation for Immer library
+Summary(pl.UTF-8):     Dokumentacja API biblioteki Immer
+Group:         Documentation
+BuildArch:     noarch
+
+%description apidocs
+API documentation for Immer library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki Immer.
+
+%prep
+%setup -q
+
+tar xf %{SOURCE1} -C tools/sinusoidal-sphinx-theme --strip-components=1
+
+%build
+install -d build
+cd build
+%cmake .. \
+       -Dimmer_BUILD_EXAMPLES=OFF \
+       -Dimmer_BUILD_TESTS=OFF
+
+%{__make}
+cd ..
+
+%if %{with apidocs}
+%{__make} -C doc html \
+       SPHINXBUILD=sphinx-build-3
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files devel
+%defattr(644,root,root,755)
+%doc LICENSE README.rst
+%{_includedir}/immer
+%{_libdir}/cmake/Immer
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/_build/html/{_static,*.html,*.js}
+%endif
This page took 0.148893 seconds and 4 git commands to generate.